[PATCH] gnu: Add netpanzer.

  • Open
  • quality assurance status badge
Details
One participant
  • Antero Mejr
Owner
unassigned
Submitted by
Antero Mejr
Severity
normal
A
A
Antero Mejr wrote on 12 Oct 01:45 +0200
(address . guix-patches@gnu.org)
87set2jjaf.fsf@antr.me
* gnu/packages/games.scm (netpanzer): New variable.

Change-Id: I989834b3b20c9848f53f1f17bb97bd9c49fc86e8
---
gnu/packages/games.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8137015fcf..a50a70f5d8 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2418,6 +2418,38 @@ (define-public nethack
(license:fsdg-compatible
"https://nethack.org/common/license.html"))))
+(define-public netpanzer
+ (package
+ (name "netpanzer")
+ (version "0.9.0-RC-7") ;0.8.7 was released 8 years ago
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/netpanzer/netpanzer")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1bc29cxjragbhgsg89sliyiqw289nd37wb1f9qarknir73ijnfac"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:tests? #f)) ;2/2 (trivial) tests fail, need filesystem access
+ (native-inputs (list pkg-config))
+ (inputs (list freetype
+ lua
+ physfs
+ sdl2
+ sdl2-mixer
+ sdl2-ttf))
+ (home-page "https://github.com/netpanzer/netpanzer")
+ (synopsis "Online tactical warfare game")
+ (description
+ "NetPanzer is an online multiplayer tactical warfare game. It is based
+on quick tactical action and unit management in real-time. Battles progress
+constantly as destroyed players respawn with a set of new units. Players can
+join or leave multiplayer games at any time.")
+ (license license:gpl2+)))
+
(define-public pipewalker
(package
(name "pipewalker")

base-commit: b8fd792ea267cb920da0651074a533d8abf00488
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73756@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73756
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch