[PATCH] gnu: Add swaysome

  • Open
  • quality assurance status badge
Details
One participant
  • Luca Matei Pintilie
Owner
unassigned
Submitted by
Luca Matei Pintilie
Severity
normal
L
L
Luca Matei Pintilie wrote on 11 Oct 23:14 +0200
(address . guix-patches@gnu.org)
2ytpuku66nbi4kkclx3r53qu4puxsrsih4cioxtefyoml36f2f@jf23conz2qck
Signed-off-by: Luca Matei Pintilie <luca@lucamatei.com>
Change-Id: I7e9b43b875cfdf68131b0fcff99721655c5af2d0
---
First guix package, be gentle :D

I am very new to guix, and as such I do not feel comfortable
maintaining this package. Regardless, I have tested this both on
void-linux and Guix System and it works as intended for me.

gnu/packages/rust-apps.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 12205ef1aa..967d628d8a 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -3105,6 +3105,31 @@ (define-public swayr
daemon which executes them.")
(license license:gpl3+)))
+(define-public swaysome
+ (package
+ (name "swaysome")
+ (version "2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "swaysome" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "02lvq4pr7dbslxvlhfha6rhbqfmj8a6kq0p41b25a56p0pwhd7qq"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-clap" ,rust-clap-4)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1))))
+ (home-page "https://gitlab.com/hyask/swaysome")
+ (synopsis
+ "Awesome way to manage your multiple outputs with the sway windows manager")
+ (description
+ "This package provides swaysome provides an awesome way to manage your multiple
+outputs with the sway windows manager.")
+ (license license:expat)))
+
(define-public tealdeer
(package
(name "tealdeer")
--
2.46.2
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsAuFgxpQsqQNV0tL8lw3bm5rpQgFAmcJlVEACgkQ8lw3bm5r
pQgrURAAg9vxe/Kzh692oyuRV0JUYpqB46c23s2ILFtyC6DR5Vrbc4j6juzLllSL
O+Eb6KyoUClJvgblXTSDSret+Me9PfpgLSqm31Ja2Jtb8MHlvcLmQ7OK/pq3RO1z
z8q74woQRZHnLCneyw2EF4vpPn+nKmJms68Gh3LYfnbqM90HLELm7VglvcHZ7xOR
LdTqtWt6T3IJkgPmbzPI+K2Pfrh+kTeuXYt6FPeBhOVaveVgtjmNvl7r4F10Hb+0
NOs4fY9kcgDE5q7BRTPPfaZ/WXkss0Kl5aUIC5SfEKMCfHTAscP2ydiF/gNZ1l/+
p//p5BNEDyal+gneokiK6q6PnTjnH3EGs7zxMWEfLJtvfMlveYwk2sMlBVSZSZpa
1og5R8WvTKpvxocHbMIw/KUYXsEcrd+e4I5SXdUJHgFxwEAzVLWFixipbLFjS1Lg
5N20aSkCVCp+fy/j5DGlAzGePnYGcAV9wItA4v7gAiOwKNnHpVF5fYTWw1tGOWaP
BGataAmm83Bmg5H9F4zdxpt98tDflITcFjm0Ry7HbA5eGgUNdGL6I5Y9kh9DkXr0
qsBNSajoYceYIrfMI53dZOjM59EhMQ5GsF2bNXbaaKoqustiQOv32y/VTc6c/FBo
vpeQyPO0sJSleNppFDLAQepmP49phbUAP9u7nOaKGOK+dO8LNzw=
=S6ZM
-----END PGP SIGNATURE-----


?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73753@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73753
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch