[PATCH] gnu: Add wtw

  • Open
  • quality assurance status badge
Details
2 participants
  • Sharlatan Hellseher
  • Thomas Albers Raviola
Owner
unassigned
Submitted by
Thomas Albers Raviola
Severity
normal

Debbugs page

Thomas Albers Raviola wrote 5 months ago
(address . guix-patches@gnu.org)(name . Thomas Albers Raviola)(address . thomas@thomaslabs.org)
20241011175908.16443-1-thomas@thomaslabs.org
* gnu/packages/xdisorg.scm (wtw): New variable

Change-Id: Idcb580debda0d26b9e8ee6ec53d6f905415037ba
---
gnu/packages/xdisorg.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 21681119f1..5baaec3dc7 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -65,6 +65,7 @@
;;; Copyright © 2024 Igor Goryachev <igor@goryachev.org>
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2024 Spencer Peters <spencerpeters@protonmail.com>
+;;; Copyright © 2024 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3959,3 +3960,36 @@ (define-public xxkb
accepts events from XKB. That means that it will work with the existing
setup of your X Server without any modifications.")
(license license:artistic2.0)))
+
+(define-public wtw
+ (let ((commit "a92feab7bb8e354a9136da82c9b716ffd7cdf08b")
+ (revision "0"))
+ (package
+ (name "wtw")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/sewn/wtw.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ni06zbrcp7pqidqfa5fr8dzkd84plf8s9y696g2rdmj8fdgynfj"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f
+ #:make-flags
+ #~(list
+ (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs (list fcft pixman wayland wayland-protocols))
+ (native-inputs (list pkg-config))
+ (synopsis "Simple text widget for wlroot compositors")
+ (description "Simple text widget for wlroot compositors; ported from stw
+and inheriting it's behavior.")
+ (home-page "https://codeberg.org/sewn/wtw")
+ (license license:expat))))
--
2.46.0
Sharlatan Hellseher wrote 4 months ago
(address . 73749@debbugs.gnu.org)(name . Thomas Albers Raviola)(address . thomas@thomaslabs.org)
877c9puykd.fsf@gmail.com
Hi Thomas,

Thank you for the patch, please see some review points.

Toggle snippet (4 lines)
+(define-public wtw
+ (let ((commit "a92feab7bb8e354a9136da82c9b716ffd7cdf08b")
+ (revision "0"))
No release no version tag? If any open issue mentioned that in upstream
please provide, or even open a new one asking about that ;-).

Toggle snippet (2 lines)
+ (version (git-version "0" revision commit))
"0" -> "0.0.0" if above is not resolved

Toggle snippet (2 lines)
+ (list #:tests? #f
Please be specific why: failed (short log), no tests, require network


Toggle snippet (2 lines)
+ (string-append "PREFIX=" %output))
%output -> #$output


Toggle snippet (2 lines)
+ (delete 'configure))))
Be more specific here as well: no configure, failing etc.

Toggle snippet (5 lines)
+ (synopsis "Simple text widget for wlroot compositors")
+ (description "Simple text widget for wlroot compositors; ported from stw
+and inheriting it's behavior.")
+ (home-page "https://codeberg.org/sewn/wtw")
Some style pick: place home-page before above synopsis, start
description from the new line.


Looking forward for the v2!

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmciloIACgkQdtcnv/Ys
0rXYvRAAiZNkBUc1bw3gOBmWhUFiUPyupi0Pj2DKVoC4AazC87LkQzD4vhA5CeLN
64f29DsDd2xJhfrFWrDB1WDY/OShB2mZLgOra20RXCz9BEziJ08OJnIPPiwWnl/p
6uSafNWZu3pd8kB5j5Cfb72q9d9CtLONVjBgAKGRVvmqGmd5aVB2WNsmMPI8iDHh
cGFsSd58QjyioIcoVt44uWqqkTwBUx1f//egrZx5gXS5IaxSvkRlJJrqnf9suYFR
lbRrhLp208muNAUU6PxgSWs++9dXuSsFqzmiW123s3kYUCd4elxOxEFuqv1VVMi0
K2hWN2DUzU+iqfcq/igTDNUQJ/kZZOC2cv1JZUpybh/EFNDFSUs3NwK1rTsa5LHZ
EE+hPcMUSYFDH54vjioIvIeRhScJHKq723EZ2mV1ve/fQf05nGM7aaergRUjOItD
mcgKr0dqZZPwTv2GehvDQcLBj4N/FRGPG3XOacs2cuegtgnIKISqyCNxw/OvTgXT
rKIcph82tc2PVtmM8cewGQWMW46CTEKkDDXqz08vjUiYjUp6EiTLwQ95lh/QjXI9
c1QVGJAs0cup+s5mrGxbl6nDuMEn86AmG5ychfAOgjVpazyNQWhzhAjtjzGzEiLN
Sxhrw2sPEUiPUEPFrTuw3vyb3T1cGESzQmIakEaVGbFDHALDS7k=
=kIQx
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73749@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73749
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help