Thomas Albers Raviola wrote 5 months ago
(address . guix-patches@gnu.org)(name . Thomas Albers Raviola)(address . thomas@thomaslabs.org)
* gnu/packages/xdisorg.scm (wtw): New variable
Change-Id: Idcb580debda0d26b9e8ee6ec53d6f905415037ba
---
gnu/packages/xdisorg.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
Toggle diff (51 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 21681119f1..5baaec3dc7 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -65,6 +65,7 @@
;;; Copyright © 2024 Igor Goryachev <igor@goryachev.org>
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2024 Spencer Peters <spencerpeters@protonmail.com>
+;;; Copyright © 2024 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3959,3 +3960,36 @@ (define-public xxkb
accepts events from XKB. That means that it will work with the existing
setup of your X Server without any modifications.")
(license license:artistic2.0)))
+
+(define-public wtw
+ (let ((commit "a92feab7bb8e354a9136da82c9b716ffd7cdf08b")
+ (revision "0"))
+ (package
+ (name "wtw")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/sewn/wtw.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ni06zbrcp7pqidqfa5fr8dzkd84plf8s9y696g2rdmj8fdgynfj"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f
+ #:make-flags
+ #~(list
+ (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs (list fcft pixman wayland wayland-protocols))
+ (native-inputs (list pkg-config))
+ (synopsis "Simple text widget for wlroot compositors")
+ (description "Simple text widget for wlroot compositors; ported from stw
+and inheriting it's behavior.")
+ (home-page "https://codeberg.org/sewn/wtw")
+ (license license:expat))))
--
2.46.0