[PATCH 0/2] gnu: Add python-pyglet.

  • Done
  • quality assurance status badge
Details
One participant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 5 months ago
(address . guix-patches@gnu.org)
cover.1728658722.git.sharlatanus@gmail.com
Hi Guix!

While checking python-science module for enabling optional packages for
python-trimesh:

- python-pycollada ; not packed yet, optional
- python-pyglet ; not packed yet, optional

I've packed python-pycollada as a part of Astro update for this month, it
would required to complete long packaging chain.

After check issues for python-pyglet I've found a few attempts to pack it
already in:

- 48467 [PATCH] gnu: Add python-pyglet.
;;; Copyright © 2021 Adam Kandur <kefironpremise@gmail.com>
- 50505 [PATCH 00/12] gnu: Add python-manim
;;; Copyright © 2021 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
- 52116 [PATCH 0/2] gnu: Add printrun.
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
- 67131 [PATCH 0/7] gnu: Add tuxemon.
;;; Copyright © 2023 Adam Faiz <adam.faiz@disroot.org>

This patch series introduces a new module - python-graphics (following naming
style taken from rust-team), and the latest python-pyglet with all bindings
implemented. Some tests are disabled, but most of them passed and module loads
successfly.

In the future I'd like to move some related packages from chunky python-xyz
into python-graphics.

Thanks,
Oleg

Sharlatan Hellseher (2):
gnu: Add packages/python-graphics module.
gnu: Add python-pyglet.

gnu/local.mk | 1 +
gnu/packages/python-graphics.scm | 178 +++++++++++++++++++++++++++++++
2 files changed, 179 insertions(+)
create mode 100644 gnu/packages/python-graphics.scm


base-commit: 053accdde356eaf84751b16d3aaf1425f410a70b
--
2.46.0
Sharlatan Hellseher wrote 5 months ago
[PATCH 1/2] gnu: Add packages/python-graphics module.
(address . 73747@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
fc20e1afc4a8915220859d0e09b411bb413cbfb5.1728658722.git.sharlatanus@gmail.com
* gnu/packages/python-graphics.scm: New file.
* gnu/local.mk: Add gnu/packages/python-graphics.scm to the scope.

Change-Id: I1d077c838ff1c3c014c3d699b539eaf8befd5084
---
gnu/local.mk | 1 +
gnu/packages/python-graphics.scm | 28 ++++++++++++++++++++++++++++
2 files changed, 29 insertions(+)
create mode 100644 gnu/packages/python-graphics.scm

Toggle diff (48 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index afff609501..b47d4dc917 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -561,6 +561,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/python-check.scm \
%D%/packages/python-compression.scm \
%D%/packages/python-crypto.scm \
+ %D%/packages/python-graphics.scm \
%D%/packages/python-science.scm \
%D%/packages/python-web.scm \
%D%/packages/python-xyz.scm \
diff --git a/gnu/packages/python-graphics.scm b/gnu/packages/python-graphics.scm
new file mode 100644
index 0000000000..ef981bd8d7
--- /dev/null
+++ b/gnu/packages/python-graphics.scm
@@ -0,0 +1,28 @@
+;;; GNU Guix --- Functional package management for GNU
+
+(define-module (gnu packages python-graphics)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module ((guix build-system python) #:select (pypi-uri))
+ #:use-module (guix build-system pyproject)
+ #:use-module (guix download)
+ #:use-module (guix gexp)
+ #:use-module (guix packages)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages python-build)
+ #:use-module (gnu packages python-xyz))
+
+;;; Commentary:
+;;;
+;;; Python modules which are meant to be used in GUI creation or mainly are
+;;; bindings to low level libraries such as Glue, Mesa, OpenGL, Xorg etc.
+;;;
+;;; Please: Try to add new module packages in alphabetic order.
+;;;
+;;; Code:
+
+
+;;;
+;;; Avoid adding new packages to the end of this file. To reduce the chances
+;;; of a merge conflict, place them above in alphabetical order.
+;;;
--
2.46.0
Sharlatan Hellseher wrote 5 months ago
[PATCH 2/2] gnu: Add python-pyglet.
(address . 73747@debbugs.gnu.org)
6f47672066456fa0bb4e38e5f052095c4032098d.1728658722.git.sharlatanus@gmail.com
This project was mentioned in #48467, #50505, #52116 and #67131. It's a
refreshed version with most of the bindings implemented.

* gnu/packages/python-graphics.scm (python-pyglet): New variable.

Change-Id: I78718376bc2945184c32cb013309fbba2b2749d0
Co-Authored-By: Adam Kandur <kefironpremise@gmail.com>
Co-Authored-By: Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
Co-Authored-By: Morgan Smith <Morgan.J.Smith@outlook.com>
Co-Authored-By: Adam Faiz <adam.faiz@disroot.org>
---
gnu/packages/python-graphics.scm | 152 ++++++++++++++++++++++++++++++-
1 file changed, 151 insertions(+), 1 deletion(-)

Toggle diff (179 lines)
diff --git a/gnu/packages/python-graphics.scm b/gnu/packages/python-graphics.scm
index ef981bd8d7..d0b4a1df74 100644
--- a/gnu/packages/python-graphics.scm
+++ b/gnu/packages/python-graphics.scm
@@ -1,4 +1,9 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Adam Kandur <kefironpremise@gmail.com>
+;;; Copyright © 2021 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
+;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2023 Adam Faiz <adam.faiz@disroot.org>
+;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
(define-module (gnu packages python-graphics)
#:use-module ((guix licenses) #:prefix license:)
@@ -8,9 +13,18 @@ (define-module (gnu packages python-graphics)
#:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (gnu packages)
+ #:use-module (gnu packages audio)
#:use-module (gnu packages check)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages fontutils)
+ #:use-module (gnu packages gl)
+ #:use-module (gnu packages base)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python-build)
- #:use-module (gnu packages python-xyz))
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages video)
+ #:use-module (gnu packages xorg))
;;; Commentary:
;;;
@@ -21,6 +35,142 @@ (define-module (gnu packages python-graphics)
;;;
;;; Code:
+(define-public python-pyglet
+ (package
+ (name "python-pyglet")
+ (version "2.0.18")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyglet" version))
+ (sha256
+ (base32 "1p4rizj81vfqxal288m3afbrgk0il3w7k5kmhai2sah8f26j7ybw"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~(list "tests"
+ "--ignore=tests/interactive"
+ ;; All tests errored
+ "--ignore=tests/integration/media/test_openal.py"
+ "--ignore=tests/integration/text/test_empty_document.py"
+ ;; Tests failed
+ "-k" (string-append "not test2"
+ " and not test5"
+ " and not testPad"
+ " and not testPad"
+ " and not testRange"
+ " and not testRect"
+ " and not testRect"
+ " and not testSet"
+ " and not testSquare"
+ " and not testSquare"
+ " and not testTuple"
+ " and not testTupleRange"
+ " and not test_context_noshare_texture"
+ " and not test_context_share_texture"
+ " and not test_method"
+ " and not test_openal_listener"
+ " and not test_parse_all_controller_mappings"
+ " and not test_player_play"
+ " and not test_player_play_multiple"
+ " and not test_stream_write_needed"
+ " and not test_window_caption"
+ " and not test_window_caption_from_argv"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-lib-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* (list "pyglet/font/fontconfig.py"
+ "pyglet/font/freetype_lib.py"
+ "pyglet/gl/lib_glx.py"
+ "pyglet/input/linux/evdev.py"
+ "pyglet/libs/egl/egl.py"
+ "pyglet/libs/egl/lib.py"
+ "pyglet/libs/x11/xf86vmode.py"
+ "pyglet/libs/x11/xinerama.py"
+ "pyglet/libs/x11/xlib.py"
+ "pyglet/libs/x11/xsync.py"
+ "pyglet/media/drivers/openal/lib_openal.py"
+ "pyglet/media/drivers/pulse/lib_pulseaudio.py")
+ (("'EGL'")
+ (format #f "'~a/~a'" #$(this-package-input "mesa")
+ "lib/libEGL.so"))
+ (("\"fontconfig\"")
+ (format #f "'~a/~a'" #$(this-package-input "fontconfig-minimal")
+ "lib/libfontconfig.so"))
+ (("\"freetype\"")
+ (format #f "'~a/~a'" #$(this-package-input "freetype")
+ "lib/libfreetype.so"))
+ (("'GL'")
+ (format #f "'~a/~a'" #$(this-package-input "mesa")
+ "lib/libGL.so"))
+ (("'GLU'")
+ (format #f "'~a/~a'" #$(this-package-input "glu")
+ "lib/libGLU.so"))
+ (("'X11'")
+ (format #f "'~a/~a'" #$(this-package-input "libx11")
+ "lib/libX11.so"))
+ (("'Xext'")
+ (format #f "'~a/~a'" #$(this-package-input "libxext")
+ "lib/libXext.so"))
+ (("'Xinerama'")
+ (format #f "'~a/~a'" #$(this-package-input "libxinerama")
+ "lib/libXinerama.so"))
+ (("'Xxf86vm'")
+ (format #f "'~a/~a'" #$(this-package-input "libxxf86vm")
+ "lib/libXxf86vm.so"))
+ (("'c'")
+ (format #f "'~a/~a'" #$(this-package-input "glibc")
+ "lib/libc.so"))
+ (("'gdk-x11-2.0'")
+ (format #f "'~a/~a'" #$(this-package-input "gtk+")
+ "lib/gdk-pixbuf-2.0.so"))
+ (("'gdk_pixbuf-2.0'")
+ (format #f "'~a/~a'" #$(this-package-input "gdk-pixbuf")
+ "lib/libgdk_pixbuf-2.0.so"))
+ (("'openal'")
+ (format #f "'~a/~a'" #$(this-package-input "openal")
+ "lib/libopenal.so"))
+ (("'pulse'")
+ (format #f "'~a/~a'" #$(this-package-input "pulseaudio")
+ "lib/libpulse.so")))))
+ (add-before 'check 'prepare-test-environment
+ (lambda _
+ ;; The test suite requires a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ (setenv "HOME" "/tmp")
+ (setenv "PYGLET_HEADLESS" "True"))))))
+ (native-inputs
+ (list python-flit-core
+ python-pytest
+ unzip
+ xorg-server-for-tests))
+ (inputs
+ (list ffmpeg
+ fontconfig
+ freeglut
+ freetype
+ gdk-pixbuf
+ glibc
+ glu
+ gtk+
+ libx11
+ libxext
+ libxinerama
+ libxxf86vm
+ mesa
+ openal
+ pulseaudio))
+ (home-page "https://github.com/pyglet/pyglet")
+ (synopsis "Windowing and multimedia library")
+ (description
+ "Pyglet is a Python library for developing games and other visually-rich
+applications. It supports windowing, user interface event handling,
+Joysticks, OpenGL graphics, loading images and videos, playing sounds and
+music." )
+ (license license:bsd-3)))
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
--
2.46.0
Sharlatan Hellseher wrote 5 months ago
[PATCH 0/2] gnu: Add python-pyglet.
(address . 73747-done@debbugs.gnu.org)
87v7xoo8vq.fsf@gmail.com
Pushed as 88471af678959b1eb4e357a47293030d05de8658 to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmcTXgkACgkQdtcnv/Ys
0rVRgBAAnr6mG3uY+vdKGLpjazBqfIPyXLpheCgKmPiyIRDTn8UFTnij0Rgqbz/G
8dZId2d3t1DDpVkX8G+NVBYeMC+hsVFv9TaehSsN1MeHKtFnbqbXdz7EcoRhLRiJ
xV1q1K4B0gwjjxMbUFyN11Z7iFtK1fiOvl43ljhXGlRizniTneM0YbMSQiQsO6YP
3VOAAik1z22A4vQFzQbG3gufVJbjDmMt89ToGYcY83nP83Rk33hYLGt5bul0JTSv
r56YE91MwMz4LOWAjnGhCSg4MsXkzXUToi7sPPn3N28ATswH2O33HWFLLaCBklIG
MiS2ZmBicOt+3TXfNg4uJrVIOxfK/93L3x5+iqds/XJbJ4kKnHPN7j6nZQispkW9
9rLUdYiCcRm26xqEzuI5QTgzBX+K/CbRTeuZwizsaln/qTXrc+r5KFa0dEUbHRaV
1cvqm7i3tQiXQQzWVXBt4+gZ3oH8thha/hbuYPDjekND0nL4OdAD2azuJO/q01rO
Tfl27OINoNbMyoWidmiQF0QmyGc45pmoc9ZQdoFZreILZwOpjt6W4JFNjCfHgJiY
sWCljVbfUkx2BDnqW1w6vRtQMcMyDNClkY4FmtfFA8gTeaOZe298AauVH47Fx2mQ
yIcHMSJrw+pMTw4DzlSKlM++U6WW3GEm2EezICeLVQMQ3YPECD4=
=0AlV
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73747@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73747
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help