[PATCH] gnu: nzbget: Update to 24.3. [security fixes]

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Graves
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 8 Oct 10:25 +0200
(address . guix-patches@gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241008082553.14239-1-ngraves@ngraves.fr
This fixes CVE-2023-49102.

* gnu/packages/networking.scm (nzbget): Update to 24.3.
[build-system]: Switch to cmake-build-system.
[arguments]<configure-flags>: Update field.
[inputs]: Add boost, openssl.
[native-inputs]: Remove pkg-config.
---
gnu/packages/networking.scm | 22 +++++++---------------
1 file changed, 7 insertions(+), 15 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3be037ecd7..7e28f053f6 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2843,26 +2843,18 @@ (define-public nethogs
(define-public nzbget
(package
(name "nzbget")
- (version "21.1")
+ (version "24.3")
(source
(origin
(method url-fetch)
- (uri (string-append "https://github.com/nzbget/nzbget/releases"
- "/download/v" version
- "/nzbget-" version "-src.tar.gz"))
+ (uri (string-append "https://github.com/nzbgetcom/nzbget/archive/v"
+ version ".tar.gz"))
(sha256
- (base32 "09900x1k0yf4yi2cc0k093advvadyhrkm8rnd8nszhhdp2zc33sf"))))
+ (base32 "1h3w1g6b52pj43v9cgcdfjal2lc1dqclhyik02zmz0k72gdg03xj"))))
+ (build-system cmake-build-system)
(arguments
- `(#:configure-flags
- (list
- (string-append "--with-libcurses-includes="
- (assoc-ref %build-inputs "ncurses") "/include")
- (string-append "--with-libcurses-libraries="
- (assoc-ref %build-inputs "ncurses") "/lib")
- (string-append "--with-tlslib=GnuTLS"))))
- (build-system gnu-build-system)
- (inputs (list gnutls libxml2 ncurses zlib))
- (native-inputs (list pkg-config))
+ (list #:configure-flags '(list "-DENABLE_TESTS=1")))
+ (inputs (list boost gnutls libxml2 ncurses openssl zlib))
(home-page "https://github.com/nzbget/nzbget")
(synopsis "Usenet binary file downloader")
(description
--
2.46.0
N
N
Nicolas Graves wrote on 16 Oct 07:19 +0200
[PATCH v2] gnu: nzbget: Update to 24.3. [security fixes]
(address . 73699@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241016051922.14328-1-ngraves@ngraves.fr
This fixes CVE-2023-49102.

* gnu/packages/networking.scm (nzbget): Update to 24.3.
[source]: Switch to git-fetch.
[build-system]: Switch to cmake-build-system.
[arguments]<configure-flags>: Update field.
[inputs]: Add boost, openssl.
[native-inputs]: Remove pkg-config, add which.
---
gnu/packages/networking.scm | 27 +++++++++++----------------
1 file changed, 11 insertions(+), 16 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f209c1e27c..79d3859eb1 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2843,26 +2843,21 @@ (define-public nethogs
(define-public nzbget
(package
(name "nzbget")
- (version "21.1")
+ (version "24.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/nzbget/nzbget/releases"
- "/download/v" version
- "/nzbget-" version "-src.tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nzbgetcom/nzbget")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "09900x1k0yf4yi2cc0k093advvadyhrkm8rnd8nszhhdp2zc33sf"))))
+ (base32 "13hakpkxqvqfjhk679l088209f54j7mqi3ifi820lyz6b1nvvj0r"))))
+ (build-system cmake-build-system)
(arguments
- `(#:configure-flags
- (list
- (string-append "--with-libcurses-includes="
- (assoc-ref %build-inputs "ncurses") "/include")
- (string-append "--with-libcurses-libraries="
- (assoc-ref %build-inputs "ncurses") "/lib")
- (string-append "--with-tlslib=GnuTLS"))))
- (build-system gnu-build-system)
- (inputs (list gnutls libxml2 ncurses zlib))
- (native-inputs (list pkg-config))
+ (list #:configure-flags '(list "-DENABLE_TESTS=1")))
+ (inputs (list boost gnutls libxml2 ncurses openssl zlib))
+ (native-inputs (list which))
(home-page "https://github.com/nzbget/nzbget")
(synopsis "Usenet binary file downloader")
(description
--
2.46.0
N
N
Nicolas Graves wrote on 17 Oct 07:03 +0200
[PATCH v3 1/2] gnu: nzbget: Update to 24.3. [security fixes]
(address . 73699@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241017050310.13529-1-ngraves@ngraves.fr
This fixes CVE-2023-49102.

* gnu/packages/networking.scm (nzbget): Update to 24.3.
[source]: Switch to git-fetch.
[build-system]: Switch to cmake-build-system.
[arguments]<configure-flags>: Update field.
[inputs]: Add boost, openssl.
[native-inputs]: Remove pkg-config, add which.
---
gnu/packages/networking.scm | 27 +++++++++++----------------
1 file changed, 11 insertions(+), 16 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f209c1e27c..79d3859eb1 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2843,26 +2843,21 @@ (define-public nethogs
(define-public nzbget
(package
(name "nzbget")
- (version "21.1")
+ (version "24.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/nzbget/nzbget/releases"
- "/download/v" version
- "/nzbget-" version "-src.tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nzbgetcom/nzbget")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "09900x1k0yf4yi2cc0k093advvadyhrkm8rnd8nszhhdp2zc33sf"))))
+ (base32 "13hakpkxqvqfjhk679l088209f54j7mqi3ifi820lyz6b1nvvj0r"))))
+ (build-system cmake-build-system)
(arguments
- `(#:configure-flags
- (list
- (string-append "--with-libcurses-includes="
- (assoc-ref %build-inputs "ncurses") "/include")
- (string-append "--with-libcurses-libraries="
- (assoc-ref %build-inputs "ncurses") "/lib")
- (string-append "--with-tlslib=GnuTLS"))))
- (build-system gnu-build-system)
- (inputs (list gnutls libxml2 ncurses zlib))
- (native-inputs (list pkg-config))
+ (list #:configure-flags '(list "-DENABLE_TESTS=1")))
+ (inputs (list boost gnutls libxml2 ncurses openssl zlib))
+ (native-inputs (list which))
(home-page "https://github.com/nzbget/nzbget")
(synopsis "Usenet binary file downloader")
(description
--
2.46.0
N
N
Nicolas Graves wrote on 17 Oct 07:03 +0200
[PATCH v3 2/2] gnu: nzbget: Ignore failing tests.
(address . 73699@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241017050310.13529-2-ngraves@ngraves.fr
* gnu/packages/networking.scm (nzbget)[arguments]<#:phases>:
Ignore a misconfigured test on aarch64.
---
gnu/packages/networking.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 79d3859eb1..590a9fdeff 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2855,7 +2855,16 @@ (define-public nzbget
(base32 "13hakpkxqvqfjhk679l088209f54j7mqi3ifi820lyz6b1nvvj0r"))))
(build-system cmake-build-system)
(arguments
- (list #:configure-flags '(list "-DENABLE_TESTS=1")))
+ (append (list #:configure-flags '(list "-DENABLE_TESTS=1"))
+ (if (target-aarch64?)
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-failing-tests
+ (lambda _
+ (substitute* "tests/system/CMakeLists.txt"
+ (("(.*)SystemInfo.cpp" all)
+ (string-append "#" all)))))))
+ #~((list)))))
(inputs (list boost gnutls libxml2 ncurses openssl zlib))
(native-inputs (list which))
(home-page "https://github.com/nzbget/nzbget")
--
2.46.0
N
N
Nicolas Graves wrote on 17 Oct 07:40 +0200
[PATCH v4 1/2] gnu: nzbget: Update to 24.3. [security fixes]
(address . 73699@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241017054025.25131-1-ngraves@ngraves.fr
This fixes CVE-2023-49102.

* gnu/packages/networking.scm (nzbget): Update to 24.3.
[source]: Switch to git-fetch.
[build-system]: Switch to cmake-build-system.
[arguments]<configure-flags>: Update field.
[inputs]: Add boost, openssl.
[native-inputs]: Remove pkg-config, add which.
---
gnu/packages/networking.scm | 27 +++++++++++----------------
1 file changed, 11 insertions(+), 16 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f209c1e27c..79d3859eb1 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2843,26 +2843,21 @@ (define-public nethogs
(define-public nzbget
(package
(name "nzbget")
- (version "21.1")
+ (version "24.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/nzbget/nzbget/releases"
- "/download/v" version
- "/nzbget-" version "-src.tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nzbgetcom/nzbget")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "09900x1k0yf4yi2cc0k093advvadyhrkm8rnd8nszhhdp2zc33sf"))))
+ (base32 "13hakpkxqvqfjhk679l088209f54j7mqi3ifi820lyz6b1nvvj0r"))))
+ (build-system cmake-build-system)
(arguments
- `(#:configure-flags
- (list
- (string-append "--with-libcurses-includes="
- (assoc-ref %build-inputs "ncurses") "/include")
- (string-append "--with-libcurses-libraries="
- (assoc-ref %build-inputs "ncurses") "/lib")
- (string-append "--with-tlslib=GnuTLS"))))
- (build-system gnu-build-system)
- (inputs (list gnutls libxml2 ncurses zlib))
- (native-inputs (list pkg-config))
+ (list #:configure-flags '(list "-DENABLE_TESTS=1")))
+ (inputs (list boost gnutls libxml2 ncurses openssl zlib))
+ (native-inputs (list which))
(home-page "https://github.com/nzbget/nzbget")
(synopsis "Usenet binary file downloader")
(description
--
2.46.0
N
N
Nicolas Graves wrote on 17 Oct 07:40 +0200
[PATCH v4 2/2] gnu: nzbget: Ignore failing tests.
(address . 73699@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241017054025.25131-2-ngraves@ngraves.fr
* gnu/packages/networking.scm (nzbget)[arguments]<#:phases>:
Ignore a misconfigured test on aarch64.
---
gnu/packages/networking.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 79d3859eb1..b75aa078ff 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2855,7 +2855,16 @@ (define-public nzbget
(base32 "13hakpkxqvqfjhk679l088209f54j7mqi3ifi820lyz6b1nvvj0r"))))
(build-system cmake-build-system)
(arguments
- (list #:configure-flags '(list "-DENABLE_TESTS=1")))
+ (append (list #:configure-flags '(list "-DENABLE_TESTS=1"))
+ (if (string-prefix? "aarch64" (%current-system))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-failing-tests
+ (lambda _
+ (substitute* "tests/system/CMakeLists.txt"
+ (("(.*)SystemInfo.cpp" all)
+ (string-append "#" all)))))))
+ #~((list)))))
(inputs (list boost gnutls libxml2 ncurses openssl zlib))
(native-inputs (list which))
(home-page "https://github.com/nzbget/nzbget")
--
2.46.0
S
S
Sharlatan Hellseher wrote on 18 Oct 11:45 +0200
[PATCH] gnu: nzbget: Update to 24.3. [security fixes]
(address . 73699@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
87a5f1pww1.fsf@gmail.com
Hi,

Thanks for the patch.

I could build v4 1/1 patch without disabling system tests on aarch64
Toggle snippet (4 lines)
./pre-inst-env guix build nzbget --system=aarch64-linux
/gnu/store/cdjbbx3iyrmglg9pbvmb8645bcxv1x33-nzbget-24.3

May you provide some reasoning or error log what you see on your end
please?

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmcSLj4ACgkQdtcnv/Ys
0rUyMw/6A9aR/lbFbCHnsObOR5LlxaTl/+YFnddIWCqpjmhGG4vjT9WQH2SGVdu4
kpP9r7i0/eyJgUsBd+r9o4EmVOJLLFhj0yhx+wr+RdaJnC1ldxzDIyTjiCmzC6U4
OxIy1quECYuBAfv+3teupbe1jQajeSPI4XFRu66Pd8mtXlPBrqO93fOu3Nt52rxv
tkShiXKoZzExuZC8dUo8019Whg2VqYxLfN/BwddeTLXcr4HxAKSQVW7xPEUfWDlW
1kOv+oh+rr8ZZPzxbLZ3YVx3qNzU4vt8ix2Qc+VVMYaAzJkoFv7XkcNyZqMGJ85x
jT3WfTEoMg9aP9LaIqNHPHZ/+wqg5UiXZwNxmXGpirDfF9DlP++uTBy83dWaMtmE
YzGtpWU+iWLTdD/zesbxPLNmk0E0W2ib551xNg/1zNcl3C3ysRh7he6p9OB+2RHs
twG39EP2dw6pgggxZas97hC9N5a9j0TD7Gpq6XpJgOh8pNmId46ybKfjVqJuqghT
5dG3eGMs63ceo3oC0LtXRFodkzsDScQMyrnoMY9Zf5wFgkMrxHk5QqyGR4YoBK/L
4v3IqXEIwo61iFs+L7xuTkw8CMqS6RwkUvs4hFuC+hw4satgb6gNAJieMNNSnMn/
B0iB0FyeYpXvojyyb/eXrvPHFIs+dX63mnk6TzOQkQfPkLNjq78=
=Fp69
-----END PGP SIGNATURE-----

N
N
Nicolas Graves wrote on 18 Oct 12:25 +0200
87msj1vhc3.fsf@ngraves.fr
On 2024-10-18 10:45, Sharlatan Hellseher wrote:

Toggle quote (13 lines)
> Hi,
>
> Thanks for the patch.
>
> I could build v4 1/1 patch without disabling system tests on aarch64
> --8<---------------cut here---------------start------------->8---
> ./pre-inst-env guix build nzbget --system=aarch64-linux
> /gnu/store/cdjbbx3iyrmglg9pbvmb8645bcxv1x33-nzbget-24.3
> --8<---------------cut here---------------end--------------->8---
>
> May you provide some reasoning or error log what you see on your end
> please?

I only relied on QA, which was indicating a failure for this test,
without much more information about why it was failing. IIRC, the
xmlResult was indicating <string></string> instead of <string/> for some
system info (so something is read as an empty string rather than NULL or
something like that probably). It seemed harmless anyway so I proceeded
to ignore the test without much further inquiry.

I still have it in my browser history, here's the link if you want to
investigate further:

Toggle quote (4 lines)
>
> --
> Oleg

--
Best regards,
Nicolas Graves
N
N
Nicolas Graves wrote on 20 Oct 17:42 +0200
[PATCH v5 1/2] gnu: nzbget: Update to 24.3. [security fixes]
(address . 73699@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241020154231.28757-1-ngraves@ngraves.fr
This fixes CVE-2023-49102.

* gnu/packages/networking.scm (nzbget): Update to 24.3.
[source]: Switch to git-fetch.
[build-system]: Switch to cmake-build-system.
[arguments]<configure-flags>: Update field.
[inputs]: Add boost, openssl.
[native-inputs]: Remove pkg-config, add which.
---
gnu/packages/networking.scm | 27 +++++++++++----------------
1 file changed, 11 insertions(+), 16 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f209c1e27c..79d3859eb1 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2843,26 +2843,21 @@ (define-public nethogs
(define-public nzbget
(package
(name "nzbget")
- (version "21.1")
+ (version "24.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/nzbget/nzbget/releases"
- "/download/v" version
- "/nzbget-" version "-src.tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nzbgetcom/nzbget")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "09900x1k0yf4yi2cc0k093advvadyhrkm8rnd8nszhhdp2zc33sf"))))
+ (base32 "13hakpkxqvqfjhk679l088209f54j7mqi3ifi820lyz6b1nvvj0r"))))
+ (build-system cmake-build-system)
(arguments
- `(#:configure-flags
- (list
- (string-append "--with-libcurses-includes="
- (assoc-ref %build-inputs "ncurses") "/include")
- (string-append "--with-libcurses-libraries="
- (assoc-ref %build-inputs "ncurses") "/lib")
- (string-append "--with-tlslib=GnuTLS"))))
- (build-system gnu-build-system)
- (inputs (list gnutls libxml2 ncurses zlib))
- (native-inputs (list pkg-config))
+ (list #:configure-flags '(list "-DENABLE_TESTS=1")))
+ (inputs (list boost gnutls libxml2 ncurses openssl zlib))
+ (native-inputs (list which))
(home-page "https://github.com/nzbget/nzbget")
(synopsis "Usenet binary file downloader")
(description
--
2.46.0
N
N
Nicolas Graves wrote on 20 Oct 17:42 +0200
[PATCH v5 2/2] gnu: nzbget: Ignore failing tests.
(address . 73699@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241020154231.28757-2-ngraves@ngraves.fr
* gnu/packages/networking.scm (nzbget)[arguments]<#:phases>:
Ignore a misconfigured test on aarch64.
---
gnu/packages/networking.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 79d3859eb1..a98f11268a 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2855,7 +2855,16 @@ (define-public nzbget
(base32 "13hakpkxqvqfjhk679l088209f54j7mqi3ifi820lyz6b1nvvj0r"))))
(build-system cmake-build-system)
(arguments
- (list #:configure-flags '(list "-DENABLE_TESTS=1")))
+ (append (list #:configure-flags '(list "-DENABLE_TESTS=1"))
+ (if (string=? "aarch64-linux" (%current-system))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-failing-tests
+ (lambda _
+ (substitute* "tests/system/CMakeLists.txt"
+ (("(.*)SystemInfo.cpp" all)
+ (string-append "#" all)))))))
+ '())))
(inputs (list boost gnutls libxml2 ncurses openssl zlib))
(native-inputs (list which))
(home-page "https://github.com/nzbget/nzbget")
--
2.46.0
N
N
Nicolas Graves wrote on 12 Nov 18:06 +0100
control message for bug #73699
(address . control@debbugs.gnu.org)
87frnw4c0s.fsf@ngraves.fr
close 73699
quit

Applied in 700126f654~2.
--
Best regards,
Nicolas Graves
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73699@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73699
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch