(address . guix-patches@gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
This fixes CVE-2023-49102.
* gnu/packages/networking.scm (nzbget): Update to 24.3.
[build-system]: Switch to cmake-build-system.
[arguments]<configure-flags>: Update field.
[inputs]: Add boost, openssl.
[native-inputs]: Remove pkg-config.
---
gnu/packages/networking.scm | 22 +++++++---------------
1 file changed, 7 insertions(+), 15 deletions(-)
Toggle diff (40 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3be037ecd7..7e28f053f6 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2843,26 +2843,18 @@ (define-public nethogs
(define-public nzbget
(package
(name "nzbget")
- (version "21.1")
+ (version "24.3")
(source
(origin
(method url-fetch)
- (uri (string-append "https://github.com/nzbget/nzbget/releases"
- "/download/v" version
- "/nzbget-" version "-src.tar.gz"))
+ (uri (string-append "https://github.com/nzbgetcom/nzbget/archive/v"
+ version ".tar.gz"))
(sha256
- (base32 "09900x1k0yf4yi2cc0k093advvadyhrkm8rnd8nszhhdp2zc33sf"))))
+ (base32 "1h3w1g6b52pj43v9cgcdfjal2lc1dqclhyik02zmz0k72gdg03xj"))))
+ (build-system cmake-build-system)
(arguments
- `(#:configure-flags
- (list
- (string-append "--with-libcurses-includes="
- (assoc-ref %build-inputs "ncurses") "/include")
- (string-append "--with-libcurses-libraries="
- (assoc-ref %build-inputs "ncurses") "/lib")
- (string-append "--with-tlslib=GnuTLS"))))
- (build-system gnu-build-system)
- (inputs (list gnutls libxml2 ncurses zlib))
- (native-inputs (list pkg-config))
+ (list #:configure-flags '(list "-DENABLE_TESTS=1")))
+ (inputs (list boost gnutls libxml2 ncurses openssl zlib))
(home-page "https://github.com/nzbget/nzbget")
(synopsis "Usenet binary file downloader")
(description
--
2.46.0