[PATCH] * gnu/packages/python-xyz.scm (python-icalendar): Update to 5.0.13.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Fabio Natali
Owner
unassigned
Submitted by
Fabio Natali
Severity
normal

Debbugs page

Fabio Natali wrote 5 months ago
(address . guix-patches@gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
cf372104657f7718ca908f5b5252e641d216be6c.1728211827.git.me@fabionatali.com
Change-Id: Iafa906540df87db84cd4752cb4b345d838bff15c
---
Hi All,

This is to update python-icalendar to 5.0.13.

I hope everything looks good.

Thanks, best wishes, Fabio.


gnu/packages/python-xyz.scm | 24 +++++++++++++++++-------
1 file changed, 17 insertions(+), 7 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ac3e224d1d..ff58dcec6d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18517,19 +18517,29 @@ (define-public python-execnet
(define-public python-icalendar
(package
(name "python-icalendar")
- (version "4.1.0")
+ (version "5.0.13")
(source (origin
(method url-fetch)
(uri (pypi-uri "icalendar" version))
(sha256
(base32
- "15dkq42rkqjdi17rpvmd1plnbwn4daby0nk1s1c3xi7w5v0bfj4p"))))
- (build-system python-build-system)
+ "01lp0advx60z8wgng8aga1p1668ydn1r6d9qm3d622yfikg9yycj"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "src/icalendar/tests")))))))
(propagated-inputs
- (list python-dateutil python-pytz))
- (synopsis "Python library for parsing iCalendar files")
- (description "The icalendar package is a parser/generator of iCalendar
-files for use with Python.")
+ (list python-dateutil python-tzdata))
+ (native-inputs
+ (list python-pytest python-pytz))
+ (synopsis "Python library for parsing and generating iCalendar files")
+ (description
+ "@code{icalendar} is a Python library for parsing and generating iCalendar files.")
(home-page "https://github.com/collective/icalendar")
(license license:bsd-2)))

base-commit: a873666d3bf716a5ae29275efaa000eaf6d1e2a8
--
2.46.0
Fabio Natali wrote 5 months ago
[PATCH] gnu: Update python-icalendar.
(address . 73655@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
b7c344fb15bbabbab9651abb27308fd5f27a7591.1728496157.git.me@fabionatali.com
* gnu/packages/python-xyz.scm (python-icalendar): Update to 5.0.13.
[propagated-inputs]: Add python-tzdata.
[native-inputs]: Add python-pytest, python-pytz.

Change-Id: Iafa906540df87db84cd4752cb4b345d838bff15c
---
gnu/packages/python-xyz.scm | 24 +++++++++++++++++-------
1 file changed, 17 insertions(+), 7 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ac3e224d1d..1b1a5c095f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18517,19 +18517,29 @@ (define-public python-execnet
(define-public python-icalendar
(package
(name "python-icalendar")
- (version "4.1.0")
+ (version "5.0.13")
(source (origin
(method url-fetch)
(uri (pypi-uri "icalendar" version))
(sha256
(base32
- "15dkq42rkqjdi17rpvmd1plnbwn4daby0nk1s1c3xi7w5v0bfj4p"))))
- (build-system python-build-system)
+ "01lp0advx60z8wgng8aga1p1668ydn1r6d9qm3d622yfikg9yycj"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "src/icalendar/tests")))))))
(propagated-inputs
- (list python-dateutil python-pytz))
- (synopsis "Python library for parsing iCalendar files")
- (description "The icalendar package is a parser/generator of iCalendar
-files for use with Python.")
+ (list python-dateutil python-pytz python-tzdata))
+ (native-inputs
+ (list python-pytest python-pytz))
+ (synopsis "Python library for parsing and generating iCalendar files")
+ (description
+ "@code{icalendar} is a Python library for parsing and generating iCalendar files.")
(home-page "https://github.com/collective/icalendar")
(license license:bsd-2)))

base-commit: a873666d3bf716a5ae29275efaa000eaf6d1e2a8
--
2.46.0
jgart wrote 5 months ago
7e15bcfc6943524606161a9a35f71645be380b42@dismail.de
Hi Fabio,

Thanks for the patch and for contributing to GNU Guix.

This update to python-icalendar breaks xandikos:

https://toys.whereis.みんな/?search=xandikos https://toys.whereis.xn--q9jyb4c/?search=xandikos

Updating xandikos would require an update to python-dulwich.

The latest release of python-dulwich requires packaging various Rust crates.

todoman is currently/previously broken from what I see so we can ignore that as a blocker for updating python-icalendar.

I realize that this increases the scope of updating python-icalendar.

Try the following command to see what packages depend on python-icalendar:

guix refresh -l python-icalendar

all best,

jgart
Attachment: file
jgart wrote 5 months ago
f03018a23b2acc62da430788042ef23036b26443@dismail.de
Toggle quote (3 lines)
>
> This update to python-icalendar breaks xandikos
>
The other option is to provide two different versions of python-icalendar so that xandikos doesn't break with the python-icalendar update.

all best,

jgart
Attachment: file
Fabio Natali wrote 5 months ago
87iku0kikv.fsf@fabionatali.com
On 2024-10-09, 20:13 +0000, "jgart" <jgart@dismail.de> wrote:
Toggle quote (6 lines)
>> This update to python-icalendar breaks xandikos
>>
> The other option is to provide two different versions of
> python-icalendar so that xandikos doesn't break with the
> python-icalendar update.

Hi jgart, thanks for looking at my patch and providing feedback - and
all this additional context.

I feel I should have checked things with 'guix refresh -l' before
submitting the patch, sorry about that. That was mentioned to my at the
Guix meetup we had earlier this evening, but we didn't get as far as
checking xandikos - we checked the other two packages though.

I'm not desperately in need of python-icalendar[0]. Perhaps it'd be more
beneficial to simply work on something else, instead of necessarily
pushing for a double python-icalendar version...

Glad to hear what you think if we have the chance to speak tomorrow or
maybe I can reach out on IRC.

Best wishes, Fabio.


- [0] Not that it's of any relevance, but here's some context:


--
Fabio Natali
jgart wrote 5 months ago
9303ad2ed4951c36b87dab5e26aceec3f77b53b3@dismail.de
Toggle quote (4 lines)
>
> I feel I should have checked things with 'guix refresh -l' before
> submitting the patch, sorry about that.
>
No worries, it's happened to me before as well on various ocassions  ;()

I would recommend working on something else until someone can upgrade python-dulwich properly or we figure out another approach.

Another option is to create your own Guix channel for these extra versions that you need.

If you do create your own Guix channel, feel free to join toys so that your channel is indexed there:


all the best,

jgart
Attachment: file
jgart wrote 5 months ago
Re: [PATCH] * gnu/packages/python-xyz.scm (python-icalendar): Update to 5.0.13.
(address . 73655-done@debbugs.gnu.org)
878quvuxyu.fsf@dismail.de
Thanks, I made some edits, updates, and added the library update.

Thanks for your contribution.
--
all the best,
jgart
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73655@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73655
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help