[PATCH] Add indicator-sound-switcher

  • Open
  • quality assurance status badge
Details
One participant
  • Sebastian Willenbrink
Owner
unassigned
Submitted by
Sebastian Willenbrink
Severity
normal
S
S
Sebastian Willenbrink wrote on 5 Oct 20:50 +0200
(address . guix-patches@gnu.org)(name . Sebastian Willenbrink)(address . sebastian.willenbrink@gmail.com)
1266383a76e3fe2cd6e05894e3c04b5b5fdc0242.1728154207.git.sebastian.willenbrink@gmail.com
This commit adds indicator-sound-switcher.
Unfortunately, I couldn't figure out how to export the icons so
that the program (/GTK?) finds them so it shows only a default gray icon.
Besides that it works fine.

Change-Id: I75e5dde35abe0a95af7c11ab2abfbc368ec9dff7
---
gnu/packages/wm.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 38cb8cc717..836b770c02 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -112,6 +112,7 @@ (define-module (gnu packages wm)
#:use-module (gnu packages)
#:use-module (gnu packages bash)
#:use-module (gnu packages admin)
+ #:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
@@ -3957,3 +3958,43 @@ (define-public wf-config
configuration files of Wayifre. It can set key and mouse bindings,
configure input, and customize Wayfire plugins.")
(license license:expat)))
+
+(define-public indicator-sound-switcher
+ (package
+ (name "indicator-sound-switcher")
+ (version "2.3.10.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yktoo/indicator-sound-switcher")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0y52k56ww2327r7ywwdvld5lx85qmcy8yrpaxc5lim7w3jbf3s85"))))
+ (build-system python-build-system)
+ (native-inputs (list gettext-minimal gobject-introspection))
+ (inputs (list python-pygobject girara python-pulsectl pulseaudio))
+ (propagated-inputs (list libappindicator keybinder))
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'install 'patch-xdg-autostart
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((pulseaudio (assoc-ref inputs "pulseaudio"))
+ (pulse (string-append pulseaudio
+ "/lib/libpulse.so.0")))
+ (substitute* "setup.py"
+ (("/etc/xdg/autostart")
+ '"share/etc/xdg/autostart"))
+ (substitute* "lib/indicator_sound_switcher/lib_pulseaudio.py"
+ (("libpulse.so.0")
+ pulse))))))))
+ (home-page "https://github.com/yktoo/indicator-sound-switcher")
+ (synopsis "Sound input/output selector indicator for Linux")
+ (description
+ "It shows an icon in the indicator area or the system tray
+(whatever is available in your desktop environment).
+The icon's menu allows you to switch the current sound input and output
+(i.e. source ports and sink ports in PulseAudio's terms, respectively) with just two clicks:")
+ (license license:gpl3)))

base-commit: 713f5562faf1acc02dc9e3f3a2d45dc39abbe9f1
--
2.46.0
S
S
Sebastian Willenbrink wrote on 6 Oct 22:51 +0200
Small oversight
(address . 73647@debbugs.gnu.org)
4f12902f-250d-4c80-be69-9d951595c716@gmail.com
Actually, the icons work fine after logging in again. So it works
exactly as I would expect it to and can IMHO be merged as it is.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73647@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73647
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch