[PATCH] gnu: guile-cv: Update to 0.4.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sébastien Lerique
  • Zheng Junjie
Owner
unassigned
Submitted by
Sébastien Lerique
Severity
normal
S
S
Sébastien Lerique wrote on 4 Oct 22:21 +0200
(address . guix-patches@gnu.org)(name . Sébastien Lerique)(address . sl@eauchat.org)
180a812616edec5a2a447948a90c09fe1a1c0876.1728073314.git.sl@eauchat.org
* gnu/packages/guile-xyz.scm (guile-cv): Update to 0.4.0.
[arguments]: Set GUILE_AUTO_COMPILE to prevent warnings, fix and
separate phase modifications into different tasks.
[inputs]: Update guile-2.0 to guile-3.0.
[native-inputs]: Update syntax and add autoconf, automake, texinfo,
libtool, gettext-minimal.
[propagated-inputs]: Update syntax.

Change-Id: I0a4141740de7cdadbe103c62831f11474cb4ddb2
---
gnu/packages/guile-xyz.scm | 42 +++++++++++++++++++++++---------------
1 file changed, 25 insertions(+), 17 deletions(-)

Toggle diff (78 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 27a30e6622..6d440512f6 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4494,25 +4494,28 @@ (define-public nomad
(define-public guile-cv
(package
(name "guile-cv")
- (version "0.2.1")
+ (version "0.4.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/guile-cv/guile-cv-"
version ".tar.gz"))
(sha256
(base32
- "0qdf0s2h1xj5lbhnc1pfw69i3zg08pqy2y6869b92ydfis8r82j9"))))
+ "00620zxm1rxlws7vn1zp2zzcb6y6r3szzj6b4b9fyjb86k972izb"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:make-flags '("GUILE_AUTO_COMPILE=0") ; to prevent guild warnings
+ #:phases
(modify-phases %standard-phases
- (add-after 'unpack 'prepare-build
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* "configure"
+ (add-after 'unpack 'fix-guile-site-directory
+ (lambda _
+ (substitute* "configure.ac"
(("SITEDIR=\"\\$datadir/guile-cv\"")
"SITEDIR=\"$datadir/guile/site/$GUILE_EFFECTIVE_VERSION\"")
(("SITECCACHEDIR=\"\\$libdir/guile-cv/")
- "SITECCACHEDIR=\"$libdir/"))
+ "SITECCACHEDIR=\"$libdir/"))))
+ (add-after 'unpack 'substitute-libs
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(substitute* "cv/init.scm"
(("\\(dynamic-link \"libvigra_c\"\\)")
(string-append "(dynamic-link \""
@@ -4532,18 +4535,23 @@ (define-public guile-cv
(string-append (assoc-ref inputs "vigra-c") "/lib"))
#t)))))
(inputs
- (list vigra vigra-c guile-2.2))
+ (list vigra vigra-c guile-3.0))
(native-inputs
- `(("texlive" ,(texlive-updmap.cfg
- (list texlive-booktabs
- texlive-iwona
- texlive-lm
- texlive-siunitx
- texlive-standalone
- texlive-xcolor)))
- ("pkg-config" ,pkg-config)))
+ (list (texlive-updmap.cfg
+ (list texlive-booktabs
+ texlive-iwona
+ texlive-lm
+ texlive-siunitx
+ texlive-standalone
+ texlive-xcolor))
+ pkg-config
+ autoconf
+ automake
+ texinfo
+ libtool
+ gettext-minimal))
(propagated-inputs
- `(("guile-lib" ,guile2.2-lib)))
+ (list guile-lib))
(home-page "https://www.gnu.org/software/guile-cv/")
(synopsis "Computer vision library for Guile")
(description "Guile-CV is a Computer Vision functional programming library

base-commit: 2f0644a8c024f589b9237e1d0fb1ce1025fa522f
--
2.46.0
Z
Z
Zheng Junjie wrote on 14 Oct 04:19 +0200
(name . Sébastien Lerique)(address . sl@eauchat.org)(address . 73630-done@debbugs.gnu.org)
8734kz77es.fsf@iscas.ac.cn
Sébastien Lerique <sl@eauchat.org> writes:

Toggle quote (90 lines)
> * gnu/packages/guile-xyz.scm (guile-cv): Update to 0.4.0.
> [arguments]: Set GUILE_AUTO_COMPILE to prevent warnings, fix and
> separate phase modifications into different tasks.
> [inputs]: Update guile-2.0 to guile-3.0.
> [native-inputs]: Update syntax and add autoconf, automake, texinfo,
> libtool, gettext-minimal.
> [propagated-inputs]: Update syntax.
>
> Change-Id: I0a4141740de7cdadbe103c62831f11474cb4ddb2
> ---
> gnu/packages/guile-xyz.scm | 42 +++++++++++++++++++++++---------------
> 1 file changed, 25 insertions(+), 17 deletions(-)
>
> diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
> index 27a30e6622..6d440512f6 100644
> --- a/gnu/packages/guile-xyz.scm
> +++ b/gnu/packages/guile-xyz.scm
> @@ -4494,25 +4494,28 @@ (define-public nomad
> (define-public guile-cv
> (package
> (name "guile-cv")
> - (version "0.2.1")
> + (version "0.4.0")
> (source (origin
> (method url-fetch)
> (uri (string-append "mirror://gnu/guile-cv/guile-cv-"
> version ".tar.gz"))
> (sha256
> (base32
> - "0qdf0s2h1xj5lbhnc1pfw69i3zg08pqy2y6869b92ydfis8r82j9"))))
> + "00620zxm1rxlws7vn1zp2zzcb6y6r3szzj6b4b9fyjb86k972izb"))))
> (build-system gnu-build-system)
> (arguments
> - `(#:phases
> + `(#:make-flags '("GUILE_AUTO_COMPILE=0") ; to prevent guild warnings
> + #:phases
> (modify-phases %standard-phases
> - (add-after 'unpack 'prepare-build
> - (lambda* (#:key inputs outputs #:allow-other-keys)
> - (substitute* "configure"
> + (add-after 'unpack 'fix-guile-site-directory
> + (lambda _
> + (substitute* "configure.ac"
> (("SITEDIR=\"\\$datadir/guile-cv\"")
> "SITEDIR=\"$datadir/guile/site/$GUILE_EFFECTIVE_VERSION\"")
> (("SITECCACHEDIR=\"\\$libdir/guile-cv/")
> - "SITECCACHEDIR=\"$libdir/"))
> + "SITECCACHEDIR=\"$libdir/"))))
> + (add-after 'unpack 'substitute-libs
> + (lambda* (#:key inputs outputs #:allow-other-keys)
> (substitute* "cv/init.scm"
> (("\\(dynamic-link \"libvigra_c\"\\)")
> (string-append "(dynamic-link \""
> @@ -4532,18 +4535,23 @@ (define-public guile-cv
> (string-append (assoc-ref inputs "vigra-c") "/lib"))
> #t)))))
> (inputs
> - (list vigra vigra-c guile-2.2))
> + (list vigra vigra-c guile-3.0))
> (native-inputs
> - `(("texlive" ,(texlive-updmap.cfg
> - (list texlive-booktabs
> - texlive-iwona
> - texlive-lm
> - texlive-siunitx
> - texlive-standalone
> - texlive-xcolor)))
> - ("pkg-config" ,pkg-config)))
> + (list (texlive-updmap.cfg
> + (list texlive-booktabs
> + texlive-iwona
> + texlive-lm
> + texlive-siunitx
> + texlive-standalone
> + texlive-xcolor))
> + pkg-config
> + autoconf
> + automake
> + texinfo
> + libtool
> + gettext-minimal))
> (propagated-inputs
> - `(("guile-lib" ,guile2.2-lib)))
> + (list guile-lib))
> (home-page "https://www.gnu.org/software/guile-cv/")
> (synopsis "Computer vision library for Guile")
> (description "Guile-CV is a Computer Vision functional programming library
>
> base-commit: 2f0644a8c024f589b9237e1d0fb1ce1025fa522f

push, and use gexp, Remove trailing #t.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmcMf7sACgkQO1qpk+Gi
3/A7CxAAh1k9+LTRzKgeEv8+0NKrV+cK39BrhVYq7AKeBurRV1tGgxKy4o3I1cYB
GBHjjulGpgVF8CRD7MjsfDpeoeT4ty6gf6k1yFPKgw0nbZ9AZUH/gpFc7coSNjhi
2G0txUyHQb7SztzdkrkhmOp9ECERJ5sWeKHlfCLrOf0HfiS+/y2EoRvGQ6ys69n6
43g9yLZh1ZifbaXv6DS3oHcwDLimx3A5RrkG39ULPTjIiiTvOwEpSsOnyImUSQBN
OHsffqckKCihajPfwruJ5DvtWFLqJYJPXoNCvXQbkzDusSIqIgauPCJmmhQjKLgK
nU8ITJPqZzhubC+kj5dcWVtufogVxrr8oe/fBVwzoOgfcZQYYTWKwiJEKuxqM4Pg
OHsATOtmp19JikEqNhy1iFOqd8t7Cvgg0K6Wck0kCbMbR4S3+nKaqGN/NB8K1kYq
2RQ4/FCq+qit8gdeKLqsmQw5wdOWapzb1zeWVxPQJKGKU4CuS9EnrBdipVwKv88A
oCNkQFaIKE7bakfti4EFzbDeTNzVULhjkqBeXiqpGLFDC3UhJXjMydRjs4YfsX2g
yxC490iX1Gnat548oGFWJXix1ONR+x+AgRn7+MvH1+UcwZTN+0v1J4RR9Jnwr6LU
/tIdRJIiYRLOjCB538dtMp+vE8HZ0LYI85u/Q9e/p5fRXvndnfk=
=nUSR
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73630@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73630
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch