(name . Guix Patches)(address . guix-patches@gnu.org)
From 2992489231eea92a2ae7cb1089b6c911f500015d Mon Sep 17 00:00:00 2001
From: Peepo Froggings <peepofroggings@tutanota.de>
Date: Thu, 3 Oct 2024 18:46:37 +0200
Subject: [PATCH] Add Gnome Accessibility Implementation Library - gail
---
gnu/packages/gtk.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
Toggle diff (45 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 2742427..88abc7e 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2024 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2024 Peepo Froggings <peepofroggings@tutanota.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -519,6 +520,30 @@ (define-public pangox-compat
functions which were removed.")
(license license:lgpl2.0+)))
+(define-public gail
+ (package
+ (name "gail")
+ (version "1.22.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://download.gnome.org/sources/" name "/"
+ (version-major+minor version) "/" name "-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "is4j2fv3bdriihn4s6vv4e4hatokzakzxr3hzloixnx5ozldaeoq"))))
+ (build-system gnu-build-system)
+ (arguments '(#:tests? #f))
+ (inputs (list
+ gtk libgnomecanvas pkg-config))
+ (synopsis "GNOME Accessibility Implementation Library")
+ (description "Gail implements ATK interfaces for GTK widgets which are
+ dynamically loadable at runtime by a GTK application.
+ Once loaded, those parts of an application that use standard GTK
+ widgets will have a basic level of accessibility, without the
+ need to modify the application at all.")
+ (home-page "https://www.gnome.org/")
+ (license license:lgpl2.0+)))
+
(define-public ganv
(package
(name "ganv")
--
2.45.2