(address . bug-guix@gnu.org)
With a package definition adding a propagated input.
Using guix build to build a package like so:
guix build --rounds=3 --no-substitutes --no-grafts --keep-failed
--load-path=. <the package>
and then taking the store path at the end for example:
phase `compress-documentation' succeeded after 0.0 seconds
successfully built /gnu/store/vcj7bq0igj2354m5pqk9zf1x0cnwgjzd-po4a-0.73.drv
/gnu/store/j37fygmv7p69nmw0md916acinc8c8m4y-po4a-0.73
and installing it in the profile with
guix package --install /gnu/store/j37fygmv7p69nmw0md916acinc8c8m4y-po4a-0.73
will not install the propagated input into the profile. It will only
have po4a installed.
$ guix package --install
/gnu/store/j37fygmv7p69nmw0md916acinc8c8m4y-po4a-0.73
The following package will be installed:
po4a 0.73
The following derivation will be built:
/gnu/store/mc57jjaqlrmp0dw8sy2vlcv3c5giblk9-profile.drv
building CA certificate bundle...
listing Emacs sub-directories...
building fonts directory...
building directory of Info manuals...
building profile with 1 package...
$ guix package --list-installed
po4a 0.73 out /gnu/store/j37fygmv7p69nmw0md916acinc8c8m4y-po4a-0.73
$
;; This file was automatically generated and is for internal use only.
;; It cannot be passed to the '--manifest' option.
;; Run 'guix package --export-manifest' if you want to export a file
;; suitable for '--manifest'.
(manifest
(version 4)
(packages
(("po4a"
"0.73"
"out"
"/gnu/store/j37fygmv7p69nmw0md916acinc8c8m4y-po4a-0.73"))))