[PATCH] gnu: aerc: Add a patch for bug with signed messages.

  • Open
  • quality assurance status badge
Details
One participant
  • ashish.is
Owner
unassigned
Submitted by
ashish.is
Severity
normal
A
A
ashish.is wrote 2 days ago
(address . guix-patches@gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
1d0f2f3a7fd150961ebe21b4966b204569e62a3c.1727772744.git.ashish.is@lostca.se
From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/mail.scm (aerc): (source)[origin]<patches>: Add patch.

Change-Id: I9e080662854b93022255f53e9f6eff11a2c934a3
---
gnu/packages/mail.scm | 13 ++++++++++++-
1 file changed, 12 insertions(+), 1 deletion(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index e4316831d0..ead8740627 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -5071,7 +5071,18 @@ (define-public aerc
(file-name (git-file-name name version))
(sha256
(base32
- "0y34cv2vcwhr0vbd1ax2hv9rmv79dp9i02y2xqyr23krfb5bp197"))))
+ "0y34cv2vcwhr0vbd1ax2hv9rmv79dp9i02y2xqyr23krfb5bp197"))
+ (patches
+ (list
+ ;; patch from upstream to fix encoding problem with sending
+ ;; gpg-signed messages
+ ;; see https://todo.sr.ht/~rjarry/aerc/79
+ (origin
+ (method url-fetch)
+ (uri "https://git.sr.ht/~rjarry/aerc/commit/7346d20.patch")
+ (file-name "aerc-fix-gpg-signed-message-encoding.patch")
+ (sha256 (base32
+ "14avr323sr9qipf9d7npqwrzq37i9946z9m6jdkzi8n9rs6zwzq9")))))))
(build-system go-build-system)
(arguments
(list #:import-path "git.sr.ht/~rjarry/aerc"

base-commit: 7e63a35ff265f5cb6efa8bbe0bbf62bb9c102cf0
--
2.46.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73578@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73578
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch