Mate fails to build on i686-linux

  • Open
  • quality assurance status badge
Details
One participant
  • Dariqq
Owner
unassigned
Submitted by
Dariqq
Severity
normal

Debbugs page

Dariqq wrote 5 months ago
(address . bug-guix@gnu.org)
f5fac497-fd0b-4e36-97f9-cde4f8c8f524@posteo.net
Hi,

The meta-package for the mate-desktop fails to build on i686-linux due
to test failures in the dependency graph:

- python-werkzeug
- skia
- node


After skipping these tests with --without-tests the mate build passes.

I have not yet looked into the details why some tests are failing.
Dariqq wrote 5 months ago
(address . 73575@debbugs.gnu.org)
cb11f7b6-eaad-496c-b315-31aca9031674@posteo.net
Had a look at the test failures:


- python-werkzeug:
tests/test_serving.py: ConnectionRefusedError: [Errno 111] Connection
refused

Not sure what is causing this. Some other linux distributions disable
this test (this package has a lot of dependants though)



- skia
../../src/base/SkContainers.cpp:66: fatal error: "assert(capacity >= 0)"


The function that is causing the error looks like this

#+begin_src cpp
size_t SkContainerAllocator::roundUpCapacity(int64_t capacity) const {
SkASSERT(capacity >= 0);

// If round will not go above fMaxCapacity return rounded capacity.
if (capacity < fMaxCapacity - kCapacityMultiple) {
return SkAlignTo(capacity, kCapacityMultiple);
}

return SkToSizeT(fMaxCapacity);
}
#+end_src


In the same file there is another function which calls roundUpCapacity
which looks like it can overflow because things get castet to int64_t
after the multiplication which will fail to catch the overflow

#+begin_src cpp
size_t SkContainerAllocator::growthFactorCapacity(int capacity, double
growthFactor) const {
SkASSERT(capacity >= 0);
SkASSERT(growthFactor >= 1.0);
// Multiply by the growthFactor. Remember this must be done in
64-bit ints and not
// size_t because size_t changes.
const int64_t capacityGrowth = static_cast<int64_t>(capacity *
growthFactor);

// Notice that for small values of capacity, rounding up will
provide most of the growth.
return this->roundUpCapacity(capacityGrowth);
}
#+end_src




- node:
In tests/parallel/test-fs-utimes-y2K38.js
this is failing:

#+begin_src js
const path = `${tmpdir.path}/test-utimes-precision`;
fs.writeFileSync(path, '');

const Y2K38_mtime = 2 ** 31;
fs.utimesSync(path, Y2K38_mtime, Y2K38_mtime);
#+end_src

with
#+begin_example
not ok 1133 parallel/test-fs-utimes-y2K38
---
duration_ms: 157.49700
severity: fail
exitcode: 1
stack: |-
node:internal/fs/utils:351
throw err;
^

Error: EINVAL: invalid argument, utime
'/tmp/guix-build-node-18.19.0.drv-0/node-v18.19.0/test/.tmp.1155/test-utimes-precision'
at Object.utimesSync (node:fs:2134:3)
at Object.<anonymous>
(/tmp/guix-build-node-18.19.0.drv-0/node-v18.19.0/test/parallel/test-fs-utimes-y2K38.js:46:4)
at Module._compile (node:internal/modules/cjs/loader:1356:14)
at Module._extensions..js
(node:internal/modules/cjs/loader:1414:10)
at Module.load (node:internal/modules/cjs/loader:1197:32)
at Module._load (node:internal/modules/cjs/loader:1013:12)
at Function.executeUserEntryPoint [as runMain]
(node:internal/modules/run_main:128:12)
at node:internal/main/run_main_module:28:49 {
errno: -22,
syscall: 'utime',
code: 'EINVAL',
path:
'/tmp/guix-build-node-18.19.0.drv-0/node-v18.19.0/test/.tmp.1155/test-utimes-precision'
}

Node.js v18.19.0
#+end_example


This seems to be another overflow/integer too big error as 2**31 -1 works.
Dariqq wrote 3 months ago
(address . 73575@debbugs.gnu.org)
9890d432-cb93-403c-aac9-f851fbf0a823@posteo.net
Since the python-team merge and the node update python-werkzeug and node
build without issues.

However there are some new issues in the dependency graph for cantarell
font:

Test failures in

- python-pandas-2 : TypeError: Cannot cast array data from
dtype('int64') to dtype('int32') according to the rule 'safe'
- python-pytest-regressions : tests/test_ndarrays_regression.py:140:
AssertionError

which are both needed by scipy.

Honestly at this point I think it would be easier to just remove
cantarell font from the default mate package.
Dariqq wrote 6 days ago
Re: Mate fails to build on i686-linux , post gnome-team merge
(address . 73575@debbugs.gnu.org)
13f83a18-740c-4148-ad45-24892a0c7351@posteo.net
Good news:

python-pandas-2 tests are skipped because of
162179e787f4d196e809dd19c74b7ad8318d7ac1


Bad news:
Mutliple new failing tests in gnome dependencies:

gst-plugins-good


Toggle snippet (36 lines)
33/116 elements_matroskademux FAIL 0.16s exit
status 3
>>> GST_STATE_IGNORE_ELEMENTS='aasink autoaudiosrc autoaudiosink
autovideosrc
autovideosink cacasink cairotextoverlay gtkglsink gtksink jackaudiosrc
jackaudiosink osssrc osssink osxaudiosink osxaudiosrc osxvideosrc
osxvideosink
pulsesink pulsesrc pulsemixer v4l2src' MESON_TEST_ITERATION=1
GSETTINGS_BACKEND=memory GST_PLUGIN_SYSTEM_PATH_1_0=''
GST_PLUGIN_SCANNER_1_0=/gnu/store/kk0rlcbb90x2a33n31h2qahz90lbb9yd-gstreamer-1.24.9/libexec/gstreamer-1.0/gst-plugin-scanner
GST_PLUGIN_PATH_1_0=/tmp/guix-build-gst-plugins-good-1.24.9.drv-0/build:/gnu/store/kk0rlcbb90x2a33n31h2qahz90lbb9yd-gstreamer-1.24.9/lib/gstreamer-1.0:/gnu/store/zwshf1i6m9ilr6wxp819ympgdb6rm4dd-gst-plugins-base-1.24.9/lib/gstreamer-1.0
MALLOC_PERTURB_=189
UBSAN_OPTIONS=halt_on_error=1:abort_on_error=1:print_summary=1:print_stacktrace=1
CK_DEFAULT_TIMEOUT=600
GST_REGISTRY=/tmp/guix-build-gst-plugins-good-1.24.9.drv-0/build/tests/check/elements_matroskademux.registry
ASAN_OPTIONS=halt_on_error=1:abort_on_error=1:print_summary=1
GST_PLUGIN_LOADING_WHITELIST=gstreamer:gst-plugins-base:timecode:gst-plugins-good@/tmp/guix-build-gst-plugins-good-1.24.9.drv-0/build
MSAN_OPTIONS=halt_on_error=1:abort_on_error=1:print_summary=1:print_stacktrace=1
/tmp/guix-build-gst-plugins-good-1.24.9.drv-0/build/tests/check/elements_matroskademux
――――――――――――――――――――――――――――――――――――― ✀
―――――――――――――――――――――――――――――――――――――
Running suite(s): matroskademux
40%: Checks: 5, Failures: 3, Errors: 0
../gst-plugins-good-1.24.9/tests/check/elements/matroskademux.c:402:F:general:test_segment_looping:0:
'segment_end' (116099772) is not equal to 'PINKNOISE_MKV_DURATION'
(116099773)
../gst-plugins-good-1.24.9/tests/check/elements/matroskademux.c:442:F:general:test_segment_looping_middle_segment:0:
'segment->duration' (116099772) is not equal to 'PINKNOISE_MKV_DURATION'
(116099773)
../gst-plugins-good-1.24.9/tests/check/elements/matroskademux.c:442:F:general:test_segment_looping_middle_segment_with_rate:0:
'segment->duration' (116099772) is not equal to 'PINKNOISE_MKV_DURATION'
(116099773)
Check suite matroskademux ran in 0.024s (tests failed: 3)


gtk:


Toggle snippet (20 lines)
Summary of Failures:

5779/6091 gtk:css / parser math.css
ERROR 0.15s exit status 1
5999/6091 gtk:reftest / reftest hbox-with-ellipsizing-wrapping-label.ui
FAIL 0.76s 0/1 subtests passed
6084/6091 gtk:reftest / reftest window-border-width.ui
FAIL 0.80s 0/1 subtests passed


In the meson outputI could not find anything that looks like the reason
for the errors/failures




vte-with-gtk+3


Toggle snippet (6 lines)
3/16 colors FAIL 0.09s killed by signal 6 SIGABRT
test-colors: ../vte-0.78.2/src/color-test.cc:84: void
assert_color_parse_value(const string_view&, const Color&, color_format,
int) [with Color = vte::color::rgba_base<float>; std::string_view =
std::basic_string_view<char>]: Assertion `*value == expected_value' failed.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73575@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73575
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help