* gnu/packages/algebra.scm (pari-gp): Update to 2.17.0.
* gnu/packages/patches/pari-gp-qfcvp.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register patch.
Change-Id: If0ea83651ae7aa4cb5de61dfaa5ec2b11051eaab
---
gnu/local.mk | 1 +
gnu/packages/algebra.scm | 4 ++--
gnu/packages/patches/pari-gp-qfcvp.patch | 19 +++++++++++++++++++
3 files changed, 22 insertions(+), 2 deletions(-)
create mode 100644 gnu/packages/patches/pari-gp-qfcvp.patch
Toggle diff (61 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 89a795bfbd..3e9943daa5 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1944,6 +1944,7 @@ dist_patch_DATA = \
%D%/packages/patches/strace-readlink-tests.patch \
%D%/packages/patches/sunxi-tools-remove-sys-io.patch \
%D%/packages/patches/p11-kit-hurd.patch \
+ %D%/packages/patches/pari-gp-qfcvp.patch \
%D%/packages/patches/patch-hurd-path-max.patch \
%D%/packages/patches/perl-5.14-autosplit-default-time.patch \
%D%/packages/patches/perl-5.14-module-pluggable-search.patch \
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 2187cd062d..2c81b88d8d 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -230,7 +230,7 @@ (define-public python-fpylll
(define-public pari-gp
(package
(name "pari-gp")
- (version "2.15.5")
+ (version "2.17.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -238,7 +238,7 @@ (define-public pari-gp
version ".tar.gz"))
(sha256
(base32
- "10grsn8wr8k02akj8f8wm1rhzrk0qls4phr46gv59nfr2msxmz8f"))))
+ "1a5fn64x7255ma7rkkjg5g17fq6mnjlzjfi8wbncc24dy77ff8z7"))))
(build-system gnu-build-system)
(native-inputs (list (texlive-updmap.cfg)))
(inputs (list gmp libx11 perl readline))
diff --git a/gnu/packages/patches/pari-gp-qfcvp.patch b/gnu/packages/patches/pari-gp-qfcvp.patch
new file mode 100644
index 0000000000..4dfaedc54a
--- /dev/null
+++ b/gnu/packages/patches/pari-gp-qfcvp.patch
@@ -0,0 +1,19 @@
+commit 9086c5ce165bdff6ac0e63b641279f6d9e44f4a7
+Author: Bill Allombert <Bill.Allombert@math.u-bordeaux.fr>
+Date: Tue Oct 1 23:54:34 2024 +0200
+
+ qfcvp: fix prototype code [#2575]
+
+diff --git a/src/functions/linear_algebra/qfcvp b/src/functions/linear_algebra/qfcvp
+index 5ee883390a..7be5fa9570 100644
+--- a/src/functions/linear_algebra/qfcvp
++++ b/src/functions/linear_algebra/qfcvp
+@@ -1,7 +1,7 @@
+ Function: qfcvp
+ Section: linear_algebra
+ C-Name: qfcvp0
+-Prototype: GGDGDGD0,L,p
++Prototype: GGDGDGD0,L,
+ Help: qfcvp(x,t,{B},{m},{flag=0}): x being a square and symmetric
+ matrix representing a positive definite quadratic form, and t a vector of
+ the same dimension, this function deals with the vectors of whose squared
--
2.46.0