[PATCH] committer: Fix for inputs that are lists by using object->string.

  • Done
  • quality assurance status badge
Details
2 participants
  • attila.lendvai
  • Ludovic Courtès
Owner
unassigned
Submitted by
attila.lendvai
Severity
normal
A
A
attila.lendvai wrote on 30 Sep 10:00 +0200
(address . guix-patches@gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
54f91b3947aaa9bd7cadae6afeae5dd574ae76b1.1727683241.git.attila@lendvai.name
From: Attila Lendvai <attila@lendvai.name>

* etc/committer.scm.in (change-commit-message): Use object->string to deal
with more complex dependency specifications.

Change-Id: Ieee39709fd3eb26368df400a9228d77aa97a9d9d
---
etc/committer.scm.in | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/etc/committer.scm.in b/etc/committer.scm.in
index c49935da600..9b128c8f1e7 100755
--- a/etc/committer.scm.in
+++ b/etc/committer.scm.in
@@ -301,8 +301,9 @@ (define* (change-commit-message file-name old new #:optional (port (current-outp
(format port
"[~a]: ~a~%" field
(break-string
- (match (list (map symbol->string removed)
- (map symbol->string added))
+ ;; A dependency can be a list of (pkg output).
+ (match (list (map object->string removed)
+ (map object->string added))
((() added)
(format #f "Add ~a."
(listify added)))

base-commit: d74fc6c8e6428c37a5bfad85b08999ff47000208
prerequisite-patch-id: 69604c6ecc6bc38af1f4d570957913136e47a744
prerequisite-patch-id: 0191b92812f5c7df75e6aa67ea7dddfcf69ba5ad
prerequisite-patch-id: 246a683ad6063f26d3164b70a25946d0ff195493
--
2.46.0
L
L
Ludovic Courtès wrote on 15 Oct 18:22 +0200
(address . attila.lendvai@gmail.com)
87a5f5wd2u.fsf@gnu.org
attila.lendvai@gmail.com skribis:

Toggle quote (7 lines)
> From: Attila Lendvai <attila@lendvai.name>
>
> * etc/committer.scm.in (change-commit-message): Use object->string to deal
> with more complex dependency specifications.
>
> Change-Id: Ieee39709fd3eb26368df400a9228d77aa97a9d9d

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73562@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73562
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch