Request for merging "wip-gsl-upgrade" branch

  • Open
  • quality assurance status badge
Details
One participant
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
normal
L
L
Ludovic Courtès wrote on 29 Sep 22:32 +0200
(address . guix-patches@gnu.org)
87ttdyi4kh.fsf@inria.fr
Hello,

I’d like to merge the ‘wip-gsl-upgrade’ branch, with the following
patches:

a42a779e76 gnu: lib2geom: Update to 1.4.
dcc666e15a gnu: gsl: Update to 2.8.
85a2d861d8 gnu: gsl: Build with ‘-O2 -g’ unconditionally.
db4c0559ec gnu: gsl: Add debug output.

Note that lib2geom is not strictly speaking related to gsl, but it’s a
dependent of gsl and in need of an update, too.

Ludo’.
L
L
Ludovic Courtès wrote on 29 Sep 22:36 +0200
[PATCH 1/4] gnu: gsl: Add debug output.
(address . 73558@debbugs.gnu.org)
db4c0559ec7e965c6e8d3d0c1dc8ce3b7fe87930.1727642162.git.ludo@gnu.org
From: Artyom Bologov <mail@aartaka.me>

* gnu/packages/maths.scm (gsl)[outputs]: Add "debug".

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
gnu/packages/maths.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 5f47d5e390..9032b5268a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -725,7 +725,7 @@ (define-public gsl
(sha256
(base32
"0jxkxrnpys2j3rh8bzx0bmnh4w6xm28jd57rgxsjp0s863agpc6w"))))
- (outputs '("out" "static"))
+ (outputs '("out" "static" "debug"))
(build-system gnu-build-system)
(arguments
(list ;; FIXME: Setting CFLAGS=-fPIC is not only unnecessary, it's also

base-commit: e464a3e166b826a040aea7140ee33f3e89da6a88
--
2.46.0
L
L
Ludovic Courtès wrote on 29 Sep 22:36 +0200
[PATCH 2/4] gnu: gsl: Build with ‘-O2 -g’ unconditionally.
(address . 73558@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
85a2d861d815ffee24f109c2c5fe2cdba64e23ca.1727642162.git.ludo@gnu.org
Fixes a regression introduced in
53bec65c51c3f2b7e318db4dc7a5c3a09ad00214 that would cause gsl to be
built without optimizations and without debugging symbols (equivalent to
“-O0 -g0”).

* gnu/packages/maths.scm (gsl)[arguments]: Remove #:make-flags.

Change-Id: I5297e3602bffbb7655d655622cc3d7595f82b25a
---
gnu/packages/maths.scm | 12 +-----------
1 file changed, 1 insertion(+), 11 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9032b5268a..d318dc3d0b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -728,17 +728,7 @@ (define-public gsl
(outputs '("out" "static" "debug"))
(build-system gnu-build-system)
(arguments
- (list ;; FIXME: Setting CFLAGS=-fPIC is not only unnecessary, it's also
- ;; harmful because it removes the default '-O2 -g', meaning that the
- ;; library ends up being compiled as -O0. Consequently, some
- ;; numerical tests fail, notably on i686-linux. TODO: Remove
- ;; 'CFLAGS=-fPIC' for all systems and revisit or remove
- ;; 'disable-failing-tests' phases accordingly.
- #:make-flags (if (and (not (%current-target-system))
- (string=? (%current-system) "i686-linux"))
- #~'()
- #~(list "CFLAGS=-fPIC"))
- #:phases
+ (list #:phases
#~(modify-phases %standard-phases
#$@(cond
((and (target-riscv64?)
--
2.46.0
L
L
Ludovic Courtès wrote on 29 Sep 22:36 +0200
[PATCH 3/4] gnu: gsl: Update to 2.8.
(address . 73558@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
dcc666e15a941bfecb6ceb606275f3f09b5bfa1d.1727642162.git.ludo@gnu.org
* gnu/packages/maths.scm (gsl): Update to 2.8.

Change-Id: I7a7af6af46b0be57a435a09460cb1237c65c6ff8
---
gnu/packages/maths.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d318dc3d0b..33d55a35b0 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -717,14 +717,14 @@ (define-public dsfmt
(define-public gsl
(package
(name "gsl")
- (version "2.7.1")
+ (version "2.8")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gsl/gsl-"
version ".tar.gz"))
(sha256
(base32
- "0jxkxrnpys2j3rh8bzx0bmnh4w6xm28jd57rgxsjp0s863agpc6w"))))
+ "141i8ag2qazyqqk17bfr2l7mr1asxm1da7avi5a66b332pnyx6ba"))))
(outputs '("out" "static" "debug"))
(build-system gnu-build-system)
(arguments
--
2.46.0
L
L
Ludovic Courtès wrote on 29 Sep 22:36 +0200
[PATCH 4/4] gnu: lib2geom: Update to 1.4.
(address . 73558@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
a42a779e7687e1cad71775a2a5cfe5bc0731059d.1727642162.git.ludo@gnu.org
* gnu/packages/graphics.scm (lib2geom): Update to 1.4.
[arguments]: In ‘skip-faulty-test’ phase, add two tests.

Change-Id: I14fed9225a8f27174f67fecc231ab44dd10bcf10
---
gnu/packages/graphics.scm | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 7ed5cdc92d..f0dc30e323 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2021, 2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015-2016, 2021-2022, 2024 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Tomáš ?ech <sleep_walker@gnu.org>
;;; Copyright © 2016, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017, 2019, 2023 Ricardo Wurmus <rekado@elephly.net>
@@ -912,7 +912,7 @@ (define-public ilmbase
(define-public lib2geom
(package
(name "lib2geom")
- (version "1.3")
+ (version "1.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -921,7 +921,7 @@ (define-public lib2geom
(file-name (git-file-name "lib2geom" version))
(sha256
(base32
- "1ypcn0yxk9ny7qg8s8h3px2wpimhfgkwk7x1548ky12iqmdjjmcn"))))
+ "0gfgzwm5s50caj5s6l7irgmlifpmypd0fnm6ckzli1fdziwjgdwi"))))
(build-system cmake-build-system)
(arguments
(list
@@ -961,7 +961,9 @@ (define-public lib2geom
;; XXX: Additional unresolved test failures.
(("elliptical-arc-test") "")
- (("self-intersections-test") ""))))))
+ (("self-intersections-test") "")
+ (("polynomial-test") "")
+ (("line-test") ""))))))
;; See https://gitlab.com/inkscape/lib2geom/-/issues/63
((or (target-aarch64?)
(target-riscv64?))
--
2.46.0
L
L
Ludovic Courtès wrote on 29 Sep 22:56 +0200
Re: bug#73558: Request for merging "wip-gsl-upgrade" branch
(address . 73558@debbugs.gnu.org)
87plomi3g7.fsf@gnu.org
Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (8 lines)
> I’d like to merge the ‘wip-gsl-upgrade’ branch, with the following
> patches:
>
> a42a779e76 gnu: lib2geom: Update to 1.4.
> dcc666e15a gnu: gsl: Update to 2.8.
> 85a2d861d8 gnu: gsl: Build with ‘-O2 -g’ unconditionally.
> db4c0559ec gnu: gsl: Add debug output.

This is being built here:


Ludo’.
L
L
Ludovic Courtès wrote on 2 Oct 18:55 +0200
(address . 73558@debbugs.gnu.org)
87setev3zt.fsf_-_@gnu.org
Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (14 lines)
> Ludovic Courtès <ludo@gnu.org> skribis:
>
>> I’d like to merge the ‘wip-gsl-upgrade’ branch, with the following
>> patches:
>>
>> a42a779e76 gnu: lib2geom: Update to 1.4.
>> dcc666e15a gnu: gsl: Update to 2.8.
>> 85a2d861d8 gnu: gsl: Build with ‘-O2 -g’ unconditionally.
>> db4c0559ec gnu: gsl: Add debug output.
>
> This is being built here:
>
> https://ci.guix.gnu.org/jobset/gsl-upgrade

I gave up on the lib2geom upgrade because its only direct dependent,
Inkscape, fails to build with it (I guess we’d need to upgrade Inkscape
as well but I didn’t feel like doing that).

Apart from that, it looks good!

Ludo’.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73558@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73558
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch