[PATCH] gnu: xpra: Add optional dependencies (tray, audio management, notifications).

  • Open
  • quality assurance status badge
Details
One participant
  • Sisiutl
Owner
unassigned
Submitted by
Sisiutl
Severity
normal

Debbugs page

Sisiutl wrote 5 months ago
(address . guix-patches@gnu.org)(name . Sisiutl)(address . sisiutl@egregore.fun)
20240929123215.15435-2-sisiutl@egregore.fun
* gnu/packages/xorg.scm (xpra)[inputs]: Add libappindicator, gstreamer, pulseaudio and python-pyinotify.

Change-Id: I76904f57ca52de7f0d456e9e69d9875293951629
---
gnu/packages/xorg.scm | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 0de08a4ad1..318cff886f 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6161,8 +6161,8 @@ (define-public xpra
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/Xpra-org/xpra.git")
- (commit (string-append "v" version))))
+ (url "https://github.com/Xpra-org/xpra.git")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32 "0zw1zsv5348bbykg6qaz2bn5ayrz5xgmnpfhi4i8pjlw0k7z8raa"))
@@ -6175,6 +6175,7 @@ (define-public xpra
libjpeg-turbo
libwebp
ffmpeg
+ libappindicator
libx11
libxrandr
libxtst
@@ -6185,9 +6186,12 @@ (define-public xpra
libxext
libxres
lz4
+ gstreamer
gtk+
+ pulseaudio
python-pycairo
python-pygobject
+ python-pyinotify
xauth
xorg-server
xf86-video-dummy
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73554@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73554
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help