(address . guix-patches@gnu.org)(name . squishypinkelephant)(address . squishypinkelephant@gmail.com)
From: squishypinkelephant <squishypinkelephant@gmail.com>
Change-Id: Ife9cb2b22c19e671db76e4e03acccc64e2d1e56b
---
gnu/packages/profiling.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)
Toggle diff (29 lines)
diff --git a/gnu/packages/profiling.scm b/gnu/packages/profiling.scm
index 3862dc2e22..e44eaf4954 100644
--- a/gnu/packages/profiling.scm
+++ b/gnu/packages/profiling.scm
@@ -26,6 +26,7 @@ (define-module (gnu packages profiling)
#:use-module ((guix licenses) #:prefix license:) ; avoid zlib, expat clashes
#:use-module (guix download)
#:use-module (guix utils)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
@@ -479,3 +480,14 @@ (define-public tracy
(delete "libxkbcommon" "wayland")
(prepend glfw)))
(synopsis "Frame profiler (X11 version)")))
+
+(define-public tracy-headers
+ (package
+ (inherit tracy-wayland)
+ (name "tracy-headers")
+ (build-system cmake-build-system)
+ ;; the default cmake target is to build headers. how convenient!
+ (arguments
+ `(#:phases %standard-phases
+ #:tests? #f))
+ (synopsis "Headers for Tracy profiler")))
--
2.46.0