[PATCH] gnu: Add emacs-persid.

  • Open
  • quality assurance status badge
Details
One participant
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 28 Sep 23:29 +0200
(address . guix-patches@gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20240928212943.30108-1-ngraves@ngraves.fr
* gnu/packages/emacs-xyz.scm (emacs-persid): New variable.
---
gnu/packages/emacs-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 05077d331d..467f2f84f2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -37665,6 +37665,41 @@ (define-public emacs-auto-dictionary-mode
detected language.")
(license license:gpl2+)))
+(define-public emacs-persid
+ ;; This is the commit of master + upstream pull request 8.
+ (let ((commit "ff370f0612dd83363bb10c4649c3f21f692c2409")
+ (revision "1"))
+ (package
+ (name "emacs-persid")
+ (version (git-version "1.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rougier/persid")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16nij3sv1fgpbxz7z3z4vdwxavz5hbad2y0585vp24h3zxhqq74y"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/rougier/persid")
+ (synopsis "Persistent Identifier Library")
+ (description "This package provides a library to manipulate
+persistent identifiers that are used to locate scholar resources
+online. The library knows about the following formats:
+@itemize
+@item isbn: @url{https://isbn.org, International Standard Book Number}
+@item issn: @url{https://www.issn.org, International Standard Serial Number}
+@item doi: @url{https://www.doi.org, Digital Object identifier}
+@item pmid: @url{https://pubmed.ncbi.nlm.nih.gov, PubMed}
+@item pmcid: @url{https://www.ncbi.nlm.nih.gov/pmc, PubMed Central}
+@item arxiv: @url{https://arxiv.org, Cornell University}
+@end itemize
+
+Given an identifier in one of the known formats, the libray can query
+information about the resources and format it as a bibtex entry.")
+ (license license:gpl3+))))
+
(define-public emacs-persist
(package
(name "emacs-persist")
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73534@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73534
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch