Marcel van der Boom wrote 6 months ago
(address . guix-patches@gnu.org)(name . Marcel van der Boom)(address . marcel@van-der-boom.nl)
* gnu/packages/graphics.scm (lib2geom)[arguments]: When building for
ppc64le-linux add a phase to skip a test known to fail upstream.
---
gnu/packages/graphics.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
Toggle diff (19 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 7ed5cdc92d..b32ac118c9 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -964,7 +964,8 @@ (define-public lib2geom
(("self-intersections-test") ""))))))
;; See https://gitlab.com/inkscape/lib2geom/-/issues/63
((or (target-aarch64?)
- (target-riscv64?))
+ (target-riscv64?)
+ (target-ppc64le?))
#~((add-after 'unpack 'fix-aarch64-faulty-test
(lambda _
(substitute* "tests/CMakeLists.txt"
base-commit: e6a771c7baf9662b4c9832045ad86c8b92b46bb3
prerequisite-patch-id: b10ed84afde75e57539cf04790b04cc07b2fb3d4
--
2.46.0