[PATCH] gnu: lib2geom: Skip a test on ppc64le

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Marcel van der Boom
Owner
unassigned
Submitted by
Marcel van der Boom
Severity
normal

Debbugs page

Marcel van der Boom wrote 6 months ago
(address . guix-patches@gnu.org)(name . Marcel van der Boom)(address . marcel@van-der-boom.nl)
9effe8f3d05b7316f72513c80126c5c6cda9a2d5.1727435624.git.marcel@van-der-boom.nl
* gnu/packages/graphics.scm (lib2geom)[arguments]: When building for
ppc64le-linux add a phase to skip a test known to fail upstream.
---
gnu/packages/graphics.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 7ed5cdc92d..b32ac118c9 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -964,7 +964,8 @@ (define-public lib2geom
(("self-intersections-test") ""))))))
;; See https://gitlab.com/inkscape/lib2geom/-/issues/63
((or (target-aarch64?)
- (target-riscv64?))
+ (target-riscv64?)
+ (target-ppc64le?))
#~((add-after 'unpack 'fix-aarch64-faulty-test
(lambda _
(substitute* "tests/CMakeLists.txt"

base-commit: e6a771c7baf9662b4c9832045ad86c8b92b46bb3
prerequisite-patch-id: b10ed84afde75e57539cf04790b04cc07b2fb3d4
--
2.46.0
Marcel van der Boom wrote 5 months ago
QA review for 73514
(address . control@debbugs.gnu.org)(address . 73514@debbugs.gnu.org)
d98de5b5-1dd1-4338-89e4-07aeac31ddc7@van-der-boom.nl
user guix
usertag 73514 + reviewed-looks-good
thanks

Guix QA review form submission:


Items marked as checked: Lint warnings, Commit messages
Ludovic Courtès wrote 5 months ago
Re: [bug#73514] [PATCH] gnu: lib2geom: Skip a test on ppc64le
(name . Marcel van der Boom)(address . marcel@van-der-boom.nl)(address . 73514-done@debbugs.gnu.org)
87zfngxme4.fsf@gnu.org
Marcel van der Boom <marcel@van-der-boom.nl> skribis:

Toggle quote (3 lines)
> * gnu/packages/graphics.scm (lib2geom)[arguments]: When building for
> ppc64le-linux add a phase to skip a test known to fail upstream.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73514@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73514
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help