[PATCH] gnu: Add r-cellchat-v2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Afkhami, Navid
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Afkhami, Navid
Severity
normal

Debbugs page

Afkhami, Navid wrote 6 months ago
(address . guix-patches@gnu.org)(name . Afkhami, Navid)(address . Navid.Afkhami@mdc-berlin.de)
c335fa0c0f0b5403713e23f409d12fe3d8d147bb.1727347038.git.Navid.Afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-cellchat-v2): New variable.

Change-Id: Iae15f373aefa1c2a0899d5271cf8dddbbfdfa2bd
---
gnu/packages/bioinformatics.scm | 66 +++++++++++++++++++++++++++++++++
1 file changed, 66 insertions(+)

Toggle diff (81 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ad7baad590..91cf6a0e2b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14315,6 +14315,72 @@ (define-public r-cellchat
communication networks from scRNA-seq data.")
(license license:gpl3))))
+(define-public r-cellchat-v2
+ (let ((commit "b05405af0f4f2cac99f2211e888d42de4c5a9d59")
+ (revision "1"))
+ (package
+ (name "r-cellchat-v2")
+ (version (git-version "2.1.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jinworks/CellChat")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14s7bl70xi21ivqr1c3qx6kjf1ndlyxag880xldqkfsqpksvyvkc"))
+ (snippet '(for-each delete-file
+ '("src/CellChat.so" "src/CellChat_Rcpp.o"
+ "src/RcppExports.o")))))
+ (properties `((upstream-name . "CellChat")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biocgenerics
+ r-biocneighbors
+ r-bslib
+ r-circlize
+ r-colorspace
+ r-complexheatmap
+ r-cowplot
+ r-dplyr
+ r-fnn
+ r-future
+ r-future-apply
+ r-ggalluvial
+ r-ggnetwork
+ r-ggplot2
+ r-ggpubr
+ r-ggrepel
+ r-igraph
+ r-irlba
+ r-magrittr
+ r-matrix
+ r-nmf
+ r-patchwork
+ r-pbapply
+ r-plotly
+ r-plyr
+ r-rcolorbrewer
+ r-rcpp
+ r-rcppeigen
+ r-reshape2
+ r-reticulate
+ r-rspectra
+ r-scales
+ r-shape
+ r-shiny
+ r-sna
+ r-stringr
+ r-svglite))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/jinworks/CellChat")
+ (synopsis
+ "Inference of cell-cell communication from single-cell and transcriptomics")
+ (description
+ "This R tool infers, visualizes, and analyzes cell-cell communication networks.
+It supports scRNA-seq and spatially resolved transcriptomics data.")
+ (license license:gpl3))))
+
(define-public r-copykat
(let ((commit ;no tag
"256de33dfc1b80a1a0ac9e098c5557f95a4e0d53")

base-commit: f6715a4715eaed485300dffffa1b5e182ded3cea
--
2.34.1
Ricardo Wurmus wrote 4 months ago
(address . 73497-done@debbugs.gnu.org)
87wmhnjiun.fsf@elephly.net
I renamed this to just r-cellchat (same package name), and the variable
to "r-cellchat-2".

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73497@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73497
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help