emacs-guix: shell commands broken

  • Open
  • quality assurance status badge
Details
2 participants
  • Christopher Howard
  • Suhail Singh
Owner
unassigned
Submitted by
Christopher Howard
Severity
normal
C
C
Christopher Howard wrote on 24 Sep 23:31 +0200
(address . bug-guix@gnu.org)
877cb0ivrj.fsf@librehacker.com
Recipe:
1. M-x guix
2. c (for "guix shell commands)

bt:

```
Debugger entered--Lisp error: (error "Error in evaluating guile expression: ice-9/boot-9.scm:1685:16: In procedure raise-exception:\n/home/christopher/.config/guix/current/share/guile/site/3.0/guix/scripts/deploy.scm:176:7: Unknown # object: \"#~\"\n\nEntering a new prompt. Type `,bt' for a backtrace or `,q' to continue.")
signal(error ("Error in evaluating guile expression: ice-9/boot-9.scm:1685:16: In procedure raise-exception:\n/home/christopher/.config/guix/current/share/guile/site/3.0/guix/scripts/deploy.scm:176:7: Unknown # object: \"#~\"\n\nEntering a new prompt. Type `,bt' for a backtrace or `,q' to continue."))
error("Error in evaluating guile expression: %s" "ice-9/boot-9.scm:1685:16: In procedure raise-exception:\n/home/christopher/.config/guix/current/share/guile/site/3.0/guix/scripts/deploy.scm:176:7: Unknown # object: \"#~\"\n\nEntering a new prompt. Type `,bt' for a backtrace or `,q' to continue.")
guix-geiser-eval("(help-string )" #<buffer *Guix Internal REPL*>)
guix-geiser-eval-read("(help-string )" #<buffer *Guix Internal REPL*>)
guix-eval-read("(help-string )")
guix-help-string(nil)
guix-command-parse-arguments(nil)
guix-command--all-arguments(nil)
guix-command-all-arguments(nil)
guix-command-generate-popup(guix-command-popup nil)
guix-command(nil)
funcall-interactively(guix-command nil)
call-interactively(guix-command)
magit-invoke-popup-action(99)
funcall-interactively(magit-invoke-popup-action 99)
call-interactively(magit-invoke-popup-action nil nil)
command-execute(magit-invoke-popup-action)
```

I noticed this issue using Emacs 30 pretest, and my normal init.el, but I also see the same error running the Emacs 29.4 binary with the -q option.

Here is my system information:

```
christopher@theoden
-------------------
OS: Guix System x86_64
Host: OptiPlex 9020 00
Kernel: 5.15.166-gnu
Uptime: 7 days, 23 hours, 42 mins
Packages: 167 (guix-system), 251 (guix-user)
Shell: bash 5.1.16
Resolution: 1920x1080
DE: GNOME
Theme: Adwaita [GTK2/3]
Icons: Adwaita [GTK2/3]
Terminal: guix
CPU: Intel i5-4570 (4) @ 3.600GHz
GPU: AMD ATI Radeon HD 8490 / R5 235X OEM
GPU: Intel HD Graphics
Memory: 4203MiB / 15914MiB
```

``` M-x version
GNU Emacs 30.0.91 (build 6, x86_64-pc-linux-gnu, GTK+ Version 3.24.41, cairo version 1.18.0) of 2024-09-23
```

``` guix describe
Generation 145 Sep 13 2024 07:30:24 (current)
guix 013bda5
branch: master
commit: 013bda5e2c53bcf1d9093286c3658b95f5e32c09
```

--
? Christopher Howard
? gemini://gem.librehacker.com

?????? ??? ????? ?? ????? ??? ????
C
C
Christopher Howard wrote on 27 Sep 23:10 +0200
(address . 73462@debbugs.gnu.org)
87o748u7km.fsf@librehacker.com
In studying the bt and the code, it seems like the problem is here, in

/home/christopher/.config/guix/current/share/guile/site/3.0/guix/scripts/deploy.scm

around line 176

```
(define (invoke-command store machine command)
"Invoke COMMAND, a list of strings, on MACHINE. Display its output (if any)
and its error code if it's non-zero. Return true if COMMAND succeeded, false
otherwise."
(define invocation
#~(begin
(use-modules (ice-9 match)
(ice-9 rdelim)
(srfi srfi-11))
```

For some reason the "#~" g-expression syntax is not being recognized here, as far as I can tell without knowing much about g-expressions. I see that the (guix gexp) module is being used, so I suppose it must have something to do with the way the syntax is being used (misused?)

--
Christopher Howard
S
S
Suhail Singh wrote on 1 Oct 21:55 +0200
(name . Christopher Howard)(address . christopher@librehacker.com)(address . 73462@debbugs.gnu.org)
87ploj38ey.fsf@gmail.com
Christopher Howard <christopher@librehacker.com> writes:

Toggle quote (4 lines)
> Recipe:
> 1. M-x guix
> 2. c (for "guix shell commands)

In case relevant, on a foreign distribution with on Emacs 29.4 and
emacs-guix installed via MELPA (using the same commit emacs-guix uses
for upstream) I am unable to reproduce the issue.

However, the below allows me to observe the issue:

#+begin_src sh
guix shell emacs emacs-guix guix -- emacs -q
#+end_src

--
Suhail
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73462@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73462
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch