[PATCH] gnu: qview: Update to 6.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Sergey Trofimov
Owner
unassigned
Submitted by
Sergey Trofimov
Severity
normal

Debbugs page

Sergey Trofimov wrote 6 months ago
(address . guix-patches@gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
fce8e58b5fe8c112ff1e0aec9d0410f1de2a904a.1727209300.git.sarg@sarg.org.ru
* gnu/packages/image-viewers.scm (qview): Update to 6.1.
[inputs, native-inputs]: Use qt6.
[arguments]: Disable broken tests. Workaround lrelease being resolved
relative to qtbase instead of qttools.
---
gnu/packages/image-viewers.scm | 25 ++++++++++++-------------
1 file changed, 12 insertions(+), 13 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 81ee770420..7fd8585ff1 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -700,7 +700,7 @@ (define-public qpageview
(define-public qview
(package
(name "qview")
- (version "5.0")
+ (version "6.1")
(source
(origin
(method git-fetch)
@@ -709,32 +709,31 @@ (define-public qview
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1ck4mvhzc4m72n010n43d8ipjczzk6ya637rgfyi7bzb4gv0f3am"))))
+ (base32 "1c719ivzdm0m8apbqx8h0wi796k5myrm4q3vl16vxwzjcx5ball7"))))
(build-system qt-build-system)
(arguments
(list
+ #:qtbase qtbase
+ #:tests? #f ; test code doesn't compile
#:phases
#~(modify-phases %standard-phases
(replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "qmake" (string-append "PREFIX=" #$output))))
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (invoke "qmake" (string-append "PREFIX=" #$output))
+ (substitute* "Makefile"
+ (((string-append #$qtbase "/bin/lrelease"))
+ (search-input-file inputs "/bin/lrelease")))))
;; Don't phone home or show "Checking for updates..." in the About
;; menu.
(add-before 'build 'disable-auto-update
(lambda _
(substitute* "src/qvaboutdialog.cpp"
(("qvApp->checkUpdates\\(\\);") "")
- (("updateText\\(\\);") ""))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (with-directory-excursion "tests"
- (invoke "qmake" "tests.pro")
- (invoke "make" "tests"))))))))
+ (("updateText\\(\\);") "")))))))
(native-inputs
- (list qttools-5))
+ (list qttools))
(inputs
- (list qtbase-5 qtimageformats-5 qtsvg-5))
+ (list qtbase qtimageformats qtsvg))
(home-page "https://interversehq.com/qview/")
(synopsis "Convenient and minimal image viewer")
(description "qView is a Qt image viewer designed with visually

base-commit: 759b74b85224f1da1e1027bb48427648c1bbde98
--
2.46.0
Ludovic Courtès wrote 5 months ago
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)(address . 73459-done@debbugs.gnu.org)
871q0431w7.fsf@gnu.org
Sergey Trofimov <sarg@sarg.org.ru> skribis:

Toggle quote (5 lines)
> * gnu/packages/image-viewers.scm (qview): Update to 6.1.
> [inputs, native-inputs]: Use qt6.
> [arguments]: Disable broken tests. Workaround lrelease being resolved
> relative to qtbase instead of qttools.

Hi! Applied it with the change below, which resorts to a literal
regexp in ‘substitute*’, which is usually safer:

Toggle snippet (15 lines)
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 7fd8585ff1..cb4e903f39 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -721,7 +721,7 @@ (define-public qview
(lambda* (#:key inputs outputs #:allow-other-keys)
(invoke "qmake" (string-append "PREFIX=" #$output))
(substitute* "Makefile"
- (((string-append #$qtbase "/bin/lrelease"))
+ (("[[:graph:]]+/bin/lrelease")
(search-input-file inputs "/bin/lrelease")))))
;; Don't phone home or show "Checking for updates..." in the About
;; menu.

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73459@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73459
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help