[PATCH] Update openfortivpn to 1.22.1

  • Open
  • quality assurance status badge
Details
One participant
  • Rick Huijzer
Owner
unassigned
Submitted by
Rick Huijzer
Severity
normal
R
R
Rick Huijzer wrote on 24 Sep 15:42 +0200
(address . guix-patches@gnu.org)(name . Rick Huijzer)(address . ikbenrickhuyzer@gmail.com)
20240924134254.24669-2-ikbenrickhuyzer@gmail.com
Works and builds on multiple amd64 machines
---
gnu/packages/vpn.scm | 26 +++++++++++++-------------
1 file changed, 13 insertions(+), 13 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 0f7300ff51..e8ac94d768 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -840,26 +840,26 @@ (define-public openconnect-sso
(define-public openfortivpn
(package
(name "openfortivpn")
- (version "1.17.3")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/adrienverge/openfortivpn")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0an58f0qcyxdx3d5zb5m8vi45a0251b950b5lh16572n8z2g6s2l"))))
+ (version "1.22.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/adrienverge/openfortivpn")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0lapfy03b0cafn2mmym72jyidhr53d2ndxhqxzp64hvmramvh50n"))))
(build-system gnu-build-system)
- (native-inputs
- (list autoconf automake pkg-config))
+ (native-inputs (list autoconf automake pkg-config))
(inputs
;; ppp < 2.5.0 is required due to
;; <https://github.com/adrienverge/openfortivpn/pull/1148>.
(list openssl ppp-2.4.9))
(home-page "https://github.com/adrienverge/openfortivpn")
(synopsis "Client for PPP+SSL VPN tunnel services")
- (description "Openfortivpn is a client for PPP+SSL VPN tunnel services. It
+ (description
+ "Openfortivpn is a client for PPP+SSL VPN tunnel services. It
spawns a pppd process and operates the communication between the gateway and
this process. It is compatible with Fortinet VPNs.")
(license license:gpl3+)))
--
2.46.0
R
R
R
Rick Huijzer wrote on 27 Sep 09:30 +0200
[PATCH v1] update openfortivpn to 1.22.1
(address . 73450@debbugs.gnu.org)(name . Rick Huijzer)(address . ikbenrickhuyzer@gmail.com)
20240927073121.8290-1-ikbenrickhuyzer@gmail.com
Toggle diff (21 lines)
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index e8ac94d768..febb59d644 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -852,10 +852,7 @@ (define-public openfortivpn
(base32 "0lapfy03b0cafn2mmym72jyidhr53d2ndxhqxzp64hvmramvh50n"))))
(build-system gnu-build-system)
(native-inputs (list autoconf automake pkg-config))
- (inputs
- ;; ppp < 2.5.0 is required due to
- ;; <https://github.com/adrienverge/openfortivpn/pull/1148>.
- (list openssl ppp-2.4.9))
+ (inputs (list openssl ppp))
(home-page "https://github.com/adrienverge/openfortivpn")
(synopsis "Client for PPP+SSL VPN tunnel services")
(description

base-commit: 60dfa7f673344f7f81faafc225191c4492f9dd03
prerequisite-patch-id: 044031c3ed1919b3402b702d6c87e42dc045db3d
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73450@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73450
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch