[PATCH] gnu: Add python-country-converter.

  • Done
  • quality assurance status badge
Details
One participant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 6 months ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
f94e7173428e85ecbc79164884738e1d48026c54.1727177906.git.sharlatanus@gmail.com
* gnu/packages/iso-codes.scm (python-country-converter): New variable.

Change-Id: Ib40f94c22b297de02a2ab16b143dcfa59e3a5bdd
---
gnu/packages/iso-codes.scm | 44 +++++++++++++++++++++++++++++++++++++-
1 file changed, 43 insertions(+), 1 deletion(-)

Toggle diff (75 lines)
diff --git a/gnu/packages/iso-codes.scm b/gnu/packages/iso-codes.scm
index d2bace6a3c..746f3ce0ba 100644
--- a/gnu/packages/iso-codes.scm
+++ b/gnu/packages/iso-codes.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,9 +26,12 @@ (define-module (gnu packages iso-codes)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
+ #:use-module (gnu packages check)
#:use-module (gnu packages gettext)
#:use-module (gnu packages perl)
- #:use-module (gnu packages python))
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages python-science))
(define-public iso-codes/official
;; This package variant is intended for ‘external’ use, such as users running
@@ -87,6 +91,44 @@ (define-public iso-codes
(("(Taiwan), [^\"]*" _ name) name))))))
(synopsis "Various ISO standards as used by GNU@tie{}Guix"))))
+(define-public python-country-converter
+ (package
+ (name "python-country-converter")
+ (version "1.2")
+ (source
+ (origin
+ (method git-fetch) ;no test data in PyPI archive
+ (uri (git-reference
+ (url "https://github.com/IndEcol/country_converter")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0i1nlbahfwgx1f5q4ib32539xmc694834s0flzp0wlki0hwzd4rd"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-pandas))
+ (native-inputs
+ (list python-pytest))
+ (home-page "https://github.com/IndEcol/country_converter")
+ (synopsis "Auto conversion from different country name standards")
+ (description
+ "The country converter (coco) automates the conversion from different
+standards and version of country names. Internally, coco is based on a table
+specifying the different ISO and UN standards per country together with the
+official name and a regular expression which aim to match all English versions
+of a specific country name. In addition, coco includes classification based
+on UN-, EU-, OECD-membership, UN regions specifications, continents and
+various MRIO and IAM databases.
+
+Supported classification schemas: APEC, BASIC, BRIC, CC41, CIS, Cecilia 2050
+classification, DACcode, EEA membership, EU membership, EXIOBASE 1
+classification, EXIOBASE 2 classification, EXIOBASE 3 classification, Eora,
+FAOcode, G20, G7, GBDcode, GWcode, IEA, IMAGE, IOC ISO 3166-1 alpha-2, ISO
+3166-1 alpha-3, ISO 3166-1 numeric, MESSAGE 11-region classification, OECD
+membership, REMIND, Schengen region, UN membership, UN numeric code, UN
+region, WIOD classification, ccTLD.")
+ (license license:gpl3)))
+
(define-public python-iso639
(package
(name "python-iso639")

base-commit: 75824be1ac60b39e123e6ee9617a64bbf2ee4add
--
2.46.0
Sharlatan Hellseher wrote 5 months ago
(address . 73449-done@debbugs.gnu.org)
877caq6tzc.fsf@gmail.com
Pushed as 308877be17b2c2c92d972e105e8cc6a782ab4c82 to mster.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmb9w7cACgkQdtcnv/Ys
0rXdkQ//ez8Kjl364LqeD1L8G/LbuCF/Vy1ebOPv4zXDhJf5yGxuSthmHKR1GQGn
Hv/gg2P73SNstyGphh6cJdfABIja2/AZhi34Fj6WMTrhJUGyuCzfnMyQo3OqHFJM
WPeZN6yrcgFk7tDH1Cz5Nz9feInauNGuLsXhUBwl89YnkhixyRKEhg+BjDmKn+2i
IAc0mRJzt7zeEZJP7bu5jA5WfL4esM/TEor/Nsg8BUES5Rh0aDb8JqUzGxR2plyk
eXICOLgq623hL0Y29BpMX08qnt0RfGr0cXOIeTsRpHGvY6sKwKSKNl392sdmFAlM
hrpI8jFkmJJjngFnBf6gliCZUoydoR2PPgeNpAPa+oqpU0hRV2AEwKcPph2QX1T2
LDbT2qdLQSTlUyM14mGlTn76txU8d08TW3gzKa0fuPx/CUqiNyOXm7wWgxFnCysk
BsOpQ0LKNw8p4x6/gLdThwpHTLr/ms/oK69/swon39N0ISe+fCssOd5qW5y/jXSl
f2n3cngXaYYJlFyvrSnDH91arMSencuhQ0KyO8Tdwlr/+4fgKTb5/XwGgflI9SwU
LBIJoxPsB/USDfGfLDF6nBkjSuCGJeMZ2Vdj40KhGppfS62QeeAiwfXSn5FpYl8P
f0MDPrlWI4Y1zTaPBfavmcCVBZxAwJYsLFsr6I8B32ahXvY6184=
=WPv7
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73449@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73449
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help