[PATCH] Better error message in checkStoreName

  • Done
  • quality assurance status badge
Details
2 participants
  • Brennan Vincent
  • Ludovic Courtès
Owner
unassigned
Submitted by
Brennan Vincent
Severity
normal
B
B
Brennan Vincent wrote on 23 Sep 13:21 +0200
(address . guix-patches@gnu.org)
871q1ad3a4.fsf@denver.mail-host-address-is-not-set
When trying to pass a local-file beginning with a dot to something like
home-files-service-type, one gets an error message like:

guix home: error: invalid name: `.vimrc'

which does not explain what went wrong. This update should make it more clear.

Change-Id: I045a663bc6cd9844677c65b38a31d3941cf212b5
---
nix/libstore/store-api.cc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/nix/libstore/store-api.cc b/nix/libstore/store-api.cc
index 781fb9e693..38a1403a71 100644
--- a/nix/libstore/store-api.cc
+++ b/nix/libstore/store-api.cc
@@ -61,7 +61,7 @@ void checkStoreName(const string & name)
/* Disallow names starting with a dot for possible security
reasons (e.g., "." and ".."). */
if (string(name, 0, 1) == ".")
- throw Error(format("invalid name: `%1%'") % name);
+ throw Error(format("invalid name: `%1%' (can't begin with dot)") % name);
foreach (string::const_iterator, i, name)
if (!((*i >= 'A' && *i <= 'Z') ||
(*i >= 'a' && *i <= 'z') ||

base-commit: 6ea75bb9bcc52521f0bb3f121799745fdc17f1c9
--
2.46.0
L
L
Ludovic Courtès wrote on 17 Nov 22:42 +0100
(name . Brennan Vincent)(address . brennan@umanwizard.com)(address . 73438-done@debbugs.gnu.org)
87mshxiljx.fsf@gnu.org
Brennan Vincent <brennan@umanwizard.com> skribis:

Toggle quote (9 lines)
> When trying to pass a local-file beginning with a dot to something like
> home-files-service-type, one gets an error message like:
>
> guix home: error: invalid name: `.vimrc'
>
> which does not explain what went wrong. This update should make it more clear.
>
> Change-Id: I045a663bc6cd9844677c65b38a31d3941cf212b5

I tweaked the commit log to match our conventions and applied it,
thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73438@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73438
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch