Add new package: sqlite-doc

  • Open
  • quality assurance status badge
Details
One participant
  • Kristian Lein-Mathisen
Owner
unassigned
Submitted by
Kristian Lein-Mathisen
Severity
normal
K
K
Kristian Lein-Mathisen wrote on 23 Sep 2024 13:07
(address . guix-patches@gnu.org)
CAAGQtHydvtMFDGRp_6f37FmM_c2UzD3UapVjz8EYVHhr=03+Bw@mail.gmail.com
Hi!

I'd like to package sqlite-doc so that I can browse this wonderful
documentation suite offline.
In order to do that, however, I had to refactor sqlite.scm slightly.
Therefor, this consists of two patches:

- Refactoring of sqlite.scm (sqlite-uri specifically)
- The new sqlite-doc package

Please consider applying these modifications.
Thank you!
Attachment: file
From bb9e92a92158bc8c55ed7cf609ca1ba2b5e206c9 Mon Sep 17 00:00:00 2001
From: Kristian Lein-Mathisen <kristianlein@gmail.com>
Date: Mon, 23 Sep 2024 13:06:34 +0200
Subject: [PATCH 0/2] *** SUBJECT HERE ***

*** BLURB HERE ***

Kristian Lein-Mathisen (2):
gnu: sqlite: refactor sqlite-uri into sqlite-numeric-version
gnu: sqlite: add variable sqlite-doc

gnu/packages/sqlite.scm | 153 +++++++++++++++++++++++++---------------
1 file changed, 96 insertions(+), 57 deletions(-)


base-commit: 41e408eb1f93d96b549d345e2de74143220b7b76
--
2.46.0
K
K
Kristian Lein-Mathisen wrote on 23 Sep 2024 13:14
patchset
(address . 73437@debbugs.gnu.org)
CAAGQtHyENoifz5etaYPyzwVhjYMh6bowg6_RM_Kwo=0SC4qq8w@mail.gmail.com
K.
Attachment: file
From bb9e92a92158bc8c55ed7cf609ca1ba2b5e206c9 Mon Sep 17 00:00:00 2001
From: Kristian Lein-Mathisen <kristianlein@gmail.com>
Date: Mon, 23 Sep 2024 12:58:37 +0200
Subject: [PATCH 2/2] gnu: sqlite: add variable sqlite-doc

* gnu/packages/sqlite.scm: new variable sqlite-doc

Change-Id: Iafb018e79e7305c267998b41f90b4327acb61765
---
gnu/packages/sqlite.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/sqlite.scm b/gnu/packages/sqlite.scm
index 8a49c8f9e8..65ddfa595b 100644
--- a/gnu/packages/sqlite.scm
+++ b/gnu/packages/sqlite.scm
@@ -117,6 +117,38 @@ (define-public sqlite
is in the public domain.")
(license license:public-domain))))
+(define-public sqlite-doc
+ (let* ((version (package-version sqlite))
+ (numeric-version (sqlite-numeric-version version)))
+ (package
+ (name "sqlite-doc")
+ (version version)
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.sqlite.org/2022/sqlite-doc-" numeric-version ".zip"))
+ (sha256
+ (base32 "032hgazrcmm9a7r0qrw81i906q2rfafbp9lfincskndgygyk4z2q"))))
+ (build-system trivial-build-system)
+ (native-inputs (list unzip))
+ (arguments
+ (list
+ #:modules '((guix build utils))
+ #:builder
+ #~(let ((out #$output)
+ (unzip (assoc-ref %build-inputs "unzip"))
+ (dest (string-append #$output "/share/doc/sqlite")))
+ (use-modules (guix build utils))
+ (mkdir-p dest)
+ (invoke (string-append unzip "/bin/unzip")
+ (assoc-ref %build-inputs "source"))
+ (copy-recursively #$(package-source this-package)
+ (string-append dest "/dest")))))
+ (home-page "")
+ (synopsis "")
+ (description "")
+ (license license:ipa))))
+
;; Newer version required for e.g. fossil.
(define-public sqlite-next
(let* ((version "3.46.0")
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73437@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73437
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch