[PATCH] gnu: Add activate-linux-1.1.0.

  • Open
  • quality assurance status badge
Details
One participant
  • Sisiutl
Owner
unassigned
Submitted by
Sisiutl
Severity
normal

Debbugs page

Sisiutl wrote 6 months ago
(address . guix-patches@gnu.org)(name . Sisiutl)(address . sisiutl@egregore.fun)
20240920211359.15206-1-sisiutl@egregore.fun
* gnu/packages/toys.scm (activate-linux): New variable.

Change-Id: Ib3ac7fcf8c5e710670a4a44f7183e068e180852f
---
gnu/packages/toys.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index a88b827704..170f40c17a 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -140,2 +140,2 @@ (define-public fortunes-jkirchartz
display via @command{fortune}, drawn from sources all around the world.")
(license license:unlicense))))

+(define-public activate-linux
+ (package
+ (name "activate-linux")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/MrGlockenspiel/activate-linux/archive/refs/tags/v"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0vbq4skm2jy2lri9v8qdjk2cfvq6lxx205bpfxph5xkvln82r2fg"))))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/MrGlockenspiel/activate-linux")
+ (synopsis "The \"Activate Windows\" watermark ported to Linux")
+ (description "The \"Activate Windows\" watermark ported to Linux.")
+ (native-inputs (list pkg-config
+ cairo
+ wayland
+ wayland-protocols
+ libxi
+ libx11
+ xorgproto
+ libxt
+ libxfixes
+ libxinerama
+ libxrandr))
+ (arguments
+ '(#:make-flags (list (string-append "CC="
+ (cc-for-target)))
+ #:tests? #f ;no check target
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (license license:gpl3+)))
+
(define-public lolcat
(package
(name "lolcat")
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73395@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73395
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help