[PATCH v2 0/2] SANE: fix a locking bug for plustek backend

  • Open
  • quality assurance status badge
Details
2 participants
  • Adrien 'neox' Bourmault
  • neox
Owner
unassigned
Submitted by
neox
Severity
normal
Merged with
N
[PATCH 1/2] gnu: sane-backends-minimal: fix lock path for plustek backend
(address . guix-patches@gnu.org)(name . Adrien 'neox' Bourmault)(address . neox@gnu.org)
5c51a9beba46c7f611fe90cc824f0fcbf2505600.1726827449.git.neox@gnu.org
From: Adrien 'neox' Bourmault <neox@gnu.org>

* gnu/packages/scanner.scm (sane-backends-minimal)
[arguments]<#:configure-flags>: add "--with-lockdir=/var/lock/sane"
[arguments]<#:phases>: add disable-lockdir-creation to prevent creating the
lockpath during install

Change-Id: I338c16cd4c0bfa0d165c9906b0f1f87ab79a4f75
Signed-off-by: Adrien 'neox' Bourmault <neox@gnu.org>
---
gnu/packages/scanner.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/scanner.scm b/gnu/packages/scanner.scm
index a2faaa2728..a20d27ad2a 100644
--- a/gnu/packages/scanner.scm
+++ b/gnu/packages/scanner.scm
@@ -136,7 +136,8 @@ (define-public sane-backends-minimal
(inputs
(list libusb))
(arguments
- `(#:phases
+ `(#:configure-flags '("--with-lockdir=/var/lock/sane") ;; Avoid errors with plustek
+ #:phases
(modify-phases %standard-phases
(add-before 'bootstrap 'zap-unnecessary-git-dependency
(lambda _
@@ -145,6 +146,12 @@ (define-public sane-backends-minimal
(("/bin/sh") (which "sh")))
(with-output-to-file ".tarball-version"
(lambda _ (format #t ,version)))))
+ (add-before 'configure 'disable-lockdir-creation
+ (lambda _
+ ;; Modify the Makefile.am to prevent the creation of the lock dir
+ (substitute* "backend/Makefile.am"
+ (("^install-lockpath:.*$")
+ "install-lockpath: # pass"))))
(add-before 'configure 'disable-backends
(lambda _
(setenv "BACKENDS" " ")
--
2.46.0
A
A
Adrien 'neox' Bourmault wrote on 20 Sep 2024 21:21
Re: bug#73392: Acknowledgement ([PATCH 1/2] gnu: sane-backends-minimal: fix lock path for plustek backend)
b6a589d6a295e755f40b9d6f9cff1e2815248626.camel@gnu.org
Hi, please close as this is a duplicate of #73391 due to a
misconfiguration on my part. Thanks a lot and sorry about this.
A
A
Adrien 'neox' Bourmault wrote on 20 Sep 2024 22:02
(address . control@debbugs.gnu.org)
b649a628022ccddaa97d00ffd7e9a8a79dfecf1c.camel@gnu.org
user guix
merge 73391 73392 73393
quit
A
A
Adrien 'neox' Bourmault wrote on 21 Sep 2024 10:06
(address . control@debbugs.gnu.org)
66ec29ed5356fb6d9c9d75789eb7875b67031b6f.camel@gnu.org
user guix
merge 73393 73406
quit
A
A
Adrien 'neox' Bourmault wrote on 21 Sep 2024 10:36
(address . control@debbugs.gnu.org)
1e13b19de7a66164e901100842803696de3cefc4.camel@a-lec.org
user guix
unmerge 73406
unmerge 73393
merge 73391 73392 73393 73406
quit
A
A
Adrien 'neox' Bourmault wrote on 21 Sep 2024 18:58
(address . control@debbugs.gnu.org)
97c2dacdb82edc04cae8a610b9a510d2cb977130.camel@a-lec.org
user guix
unmerge 73406
thanks
A
A
Adrien 'neox' Bourmault wrote on 21 Sep 2024 23:42
(address . control@debbugs.gnu.org)
e3f95f2487dbb48ff89a8b69d16454d457de6ff4.camel@gnu.org
user guix
unmerge 73393
thanks
A
A
Adrien 'neox' Bourmault wrote on 22 Sep 2024 00:56
(address . control@debbugs.gnu.org)
7bc43cd9449d5b1b8f80c90fc4a4e54234364d5d.camel@gnu.org
user guix
merge 73391 73392 73393 73406
quit
A
A
Adrien 'neox' Bourmault wrote on 22 Sep 2024 10:51
(address . control@debbugs.gnu.org)
7b4460cf8c1e715a60e513c256b2b9159662c3c4.camel@a-lec.org
user guix
retitle 73393 [PATCH v2 0/2] SANE: fix a locking bug for plustek backend
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73392@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73392
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch