[PATCH] gnu: sirikali: Update to 1.6.0

  • Open
  • quality assurance status badge
Details
One participant
  • Aaron Covrig
Owner
unassigned
Submitted by
Aaron Covrig
Severity
normal
A
A
Aaron Covrig wrote on 19 Sep 07:48 +0200
(address . guix-patches@gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20240919054901.1656605-1-aaron.covrig.us@ieee.org
* gnu/packages/file-systems.scm (sirikali): Update to 1.6.0
---
gnu/packages/file-systems.scm | 35 ++++++++++++++++++-----------------
1 file changed, 18 insertions(+), 17 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index c6a49a6bc0..e6b673780b 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;; Copyright © 2021, 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
;;; Copyright © 2022 Brian Cully <bjc@spork.org>
-;;; Copyright © 2023 Aaron Covrig <aaron.covrig.us@ieee.org>
+;;; Copyright © 2023, 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
;;; Copyright © 2024 Ahmad Draidi <a.r.draidi@redscript.org>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;
@@ -2231,25 +2231,26 @@ (define-public dwarfs
(define-public sirikali
(package
(name "sirikali")
- (version "1.5.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mhogomchungu/sirikali")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1l52s8rxkfcxcx3s2fnsh08wy6hhjjvp7gcggdi84aqc4dq3rdnm"))))
+ (version "1.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mhogomchungu/sirikali")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06cl7srxaqpzv7gcd17cl78qhrpqhdvpfcj4pr73fr5hhackrf52"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ;No tests
- #:configure-flags '("-DQT5=true")))
+ #:configure-flags '("-DQT5=true" "-DCMAKE_BUILD_TYPE=RELEASE")))
(inputs (list xdg-utils libpwquality libgcrypt libsecret qtbase-5))
(native-inputs (list pkg-config))
(home-page "https://mhogomchungu.github.io/sirikali/")
- (synopsis "Graphical program for managing encrypted file-systems")
- (description "@dfn{SiriKali} is a Qt / C++ @acronym{GUI, graphical user
-interface} application that manages ecryptfs, cryfs, encfs, gocryptfs, fscrypt
-and securefs based encrypted folders.")
- (license license:gpl2+)))
+ (synopsis
+ "GUI front end to sshfs, ecryptfs, cryfs, gocryptfs, securefs, fscrypt and encfs")
+ (description "@dfn{SiriKali} is a Qt/C++ GUI application that manages
+ecryptfs, cryfs, encfs, gocryptfs, fscrypt and securefs
+based encrypted folders")
+ (license (list license:gpl3 license:gpl2))))

base-commit: 1b6ce1796abdf497f61f426d61339318f4f4f23d
--
2.46.0
A
A
Aaron Covrig wrote on 24 Oct 23:08 +0200
[PATCH v1] gnu: sirikali: Update to 1.6.0
(address . 73349@debbugs.gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20241024210845.987170-1-aaron.covrig.us@ieee.org
* gnu/packages/file-systems.scm (sirikali): Update to 1.6.0
---
gnu/packages/file-systems.scm | 34 +++++++++++++++++-----------------
1 file changed, 17 insertions(+), 17 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 059bdf67a9..3ff675df19 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;; Copyright © 2021, 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
;;; Copyright © 2022 Brian Cully <bjc@spork.org>
-;;; Copyright © 2023 Aaron Covrig <aaron.covrig.us@ieee.org>
+;;; Copyright © 2023, 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
;;; Copyright © 2024 Ahmad Draidi <a.r.draidi@redscript.org>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;
@@ -2339,25 +2339,25 @@ (define-public dwarfs
(define-public sirikali
(package
(name "sirikali")
- (version "1.5.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mhogomchungu/sirikali")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1l52s8rxkfcxcx3s2fnsh08wy6hhjjvp7gcggdi84aqc4dq3rdnm"))))
+ (version "1.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mhogomchungu/sirikali")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06cl7srxaqpzv7gcd17cl78qhrpqhdvpfcj4pr73fr5hhackrf52"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ;No tests
- #:configure-flags '("-DQT5=true")))
+ #:configure-flags '("-DQT5=true" "-DCMAKE_BUILD_TYPE=RELEASE")))
(inputs (list xdg-utils libpwquality libgcrypt libsecret qtbase-5))
(native-inputs (list pkg-config))
(home-page "https://mhogomchungu.github.io/sirikali/")
- (synopsis "Graphical program for managing encrypted file-systems")
- (description "@dfn{SiriKali} is a Qt / C++ @acronym{GUI, graphical user
-interface} application that manages ecryptfs, cryfs, encfs, gocryptfs, fscrypt
-and securefs based encrypted folders.")
- (license license:gpl2+)))
+ (synopsis
+ "GUI front end to sshfs, ecryptfs, cryfs, gocryptfs, securefs, fscrypt and encfs")
+ (description
+ "@dfn{SiriKali} is a Qt/C++ @acronym{GUI, graphical user interface} application that manages ecryptfs, cryfs, encfs, gocryptfs, fscrypt and securefs based encrypted folders")
+ (license (list license:gpl3 license:gpl2))))

base-commit: f125143d64c3fac8c9576a55b48331cbf6096460
--
2.46.0
A
A
Aaron Covrig wrote 6 days ago
[PATCH v2] gnu: sirikali: Update to v1.7.2
(address . 73349@debbugs.gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20241204235201.127296-1-aaron.covrig.us@ieee.org
* gnu/packages/file-systems.scm (sirikali): Upgrade to v1.7.2
---
gnu/packages/file-systems.scm | 16 ++++++++--------
1 file changed, 8 insertions(+), 8 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 46febebb0d..985c4185c4 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -2360,7 +2360,7 @@ (define-public dwarfs
(define-public sirikali
(package
(name "sirikali")
- (version "1.5.1")
+ (version "1.7.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2369,16 +2369,16 @@ (define-public sirikali
(file-name (git-file-name name version))
(sha256
(base32
- "1l52s8rxkfcxcx3s2fnsh08wy6hhjjvp7gcggdi84aqc4dq3rdnm"))))
+ "1288adycjkd7gpk9qscr06v9b7436cn448wz8kxa89rsmpx0mn2j"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ;No tests
- #:configure-flags '("-DQT5=true")))
+ #:configure-flags '("-DQT5=true" "-DCMAKE_BUILD_TYPE=RELEASE")))
(inputs (list xdg-utils libpwquality libgcrypt libsecret qtbase-5))
(native-inputs (list pkg-config))
(home-page "https://mhogomchungu.github.io/sirikali/")
- (synopsis "Graphical program for managing encrypted file-systems")
- (description "@dfn{SiriKali} is a Qt / C++ @acronym{GUI, graphical user
-interface} application that manages ecryptfs, cryfs, encfs, gocryptfs, fscrypt
-and securefs based encrypted folders.")
- (license license:gpl2+)))
+ (synopsis "GUI front end to sshfs, ecryptfs, cryfs, gocryptfs, securefs, fscrypt and encfs")
+ (description "@dfn{SiriKali} is a Qt/C++ GUI @acronym{GUI, graphical user
+-interface} application that manages ecryptfs, cryfs, encfs, gocryptfs, fscrypt
+and securefs based encrypted folders")
+ (license (list license:gpl3 license:gpl2))))
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73349@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73349
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch