[PATCH] gnu: python-gphoto2: Update to 2.5.0

  • Open
  • quality assurance status badge
Details
One participant
  • Aaron Covrig
Owner
unassigned
Submitted by
Aaron Covrig
Severity
normal
A
A
Aaron Covrig wrote on 19 Sep 2024 03:03
(address . guix-patches@gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20240919010318.1428883-1-aaron.covrig.us@ieee.org
* gnu/packages/python-xyz.scm (python-gphoto2): Update to 2.5.0
---
gnu/packages/python-xyz.scm | 23 +++++++++++------------
1 file changed, 11 insertions(+), 12 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8d402d4f94..0f2985fdcb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2284,21 +2284,20 @@ (define-public python-glymur
(define-public python-gphoto2
(package
(name "python-gphoto2")
- (version "2.2.1")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "gphoto2" version))
- (sha256
- (base32
- "118zm25c8mlajfl0pzssnwz4b8lamj9dgymla9rn4nla7l244a0r"))))
+ (version "2.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "gphoto2" version))
+ (sha256
+ (base32 "104yb4g427rqjkaw3i0w30x3sssvmpna802nabjclzq688y7ml4p"))))
(build-system python-build-system)
- (native-inputs
- (list pkg-config))
- (inputs
- (list libgphoto2))
+ (native-inputs (list pkg-config))
+ (inputs (list libgphoto2))
(home-page "https://github.com/jim-easterbrook/python-gphoto2")
(synopsis "Python interface to libgphoto2")
- (description "@code{python-gphoto2} is a comprehensive Python interface
+ (description
+ "@code{python-gphoto2} is a comprehensive Python interface
(or binding) to @code{libgphoto2}. It is built using @code{SWIG} to
automatically generate the interface code.")
(license license:gpl3+)))

base-commit: 1b6ce1796abdf497f61f426d61339318f4f4f23d
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73345@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73345
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch