[PATCH 2/2] gnu: Add emacs-anaconda-mode.

  • Open
  • quality assurance status badge
Details
One participant
  • Rostislav Svoboda
Owner
unassigned
Submitted by
Rostislav Svoboda
Severity
normal
R
R
Rostislav Svoboda wrote on 18 Sep 16:29 +0200
(address . guix-patches@gnu.org)(name . Rostislav Svoboda)(address . Rostislav.Svoboda@gmail.com)
207719d3698c0e4e1bc5e1daec97d4d0d306a98c.1726669768.git.Rostislav.Svoboda@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-anaconda-mode): New variable.

Change-Id: I91d2ba701c465fa70b0632b327dccf805556de4a
---
gnu/packages/emacs-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1469148949..b2003f434d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11050,6 +11050,43 @@ (define-public emacs-pythonic
to install docker-tramp Emacs package.")
(license license:gpl3+))))
+(define-public emacs-anaconda-mode
+ (let ((commit "f900bd7656a03aa24ef3295251f266736f7756eb")
+ (revision "0"))
+ (package
+ (name "emacs-anaconda-mode")
+ (version (git-version "0.1.16" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/proofit404/anaconda-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1gricygbs9f210z7bnzdhcmqpwnpzs4mwbw8rvabfplcbiw7sg6r"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:include #~(cons "^anaconda-mode\\.py$" %default-include)))
+ (propagated-inputs (list emacs-pythonic
+ emacs-dash
+ emacs-f
+ emacs-s
+ emacs-tramp
+ emacs-xref))
+ (home-page "https://github.com/proofit404/anaconda-mode")
+ (synopsis
+ "Python code navigation, documentation lookup & completion in Emacs")
+ (description
+ "This package provides Python code navigation, documentation lookup,
+ and code completion for Emacs. It uses a lightweight Python backend to offer
+ features like jumping to definitions, finding references, and viewing
+ documentation, enhancing the Python development experience within Emacs. The
+ package integrates seamlessly to support efficient coding and workflow
+ management.")
+ (license license:gpl3+))))
+
(define-public emacs-jedi
(package
(name "emacs-jedi")
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73335@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73335
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch