[PATCH] Add libliftoff

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • The Man
  • Steve George
Owner
unassigned
Submitted by
The Man
Severity
normal
T
T
The Man wrote on 17 Sep 04:43 +0200
(address . guix-patches@gnu.org)
CAPfwWaijsPDW4kmZf_dB+A4p02SKcxLq8r8Vajz6e0Kruwxc2w@mail.gmail.com

Attachment: file
Toggle diff (32 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index cb1d625d24..f6e04ee88c 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -3296,3 +3296,27 @@ (define-public libdecor
window decorations for them. It aims to provide multiple backends that
implements the decoration drawing.")
(license license:expat)))
+
+(define-public libliftoff
+ (package
+ (name "libliftoff")
+ (version "0.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/emersion/libliftoff")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "163g8ndsbma7acy2k9mrnvlpb7yi4431hgkx1gygkafgwpq1ii1x"))))
+ (build-system meson-build-system)
+ (native-inputs (list pkg-config))
+ (inputs (list libdrm))
+ (home-page "https://gitlab.freedesktop.org/emersion/libliftoff")
+ (synopsis "Lightweight KMS plane library")
+ (description
+ "Libliftoff eases the use of KMS planes from userspace without standing in your
+way. Users create \"virtual planes\" called layers, set KMS properties on them,
+and libliftoff will pick hardware planes for these layers if possible.")
+ (license license:expat)))
S
S
Steve George wrote on 22 Sep 16:07 +0200
[PATCH v2 0/1] Add libliftoff
(address . 73311@debbugs.gnu.org)(name . Steve George)(address . steve@futurile.net)
cover.1727012997.git.steve@futurile.net
Hi 'The Man',

Thanks for your contribution! Just be aware that it wasn't in the correct format so the CI system couldn't automatically build it. If it doesn't build a committer is less likely to take the time to look at it. Please have a look at the manual at the section preparing a patch (https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html)when you send your next contribution :-). Hopefully it will build automatically and a committer will have time to review it.

Review:
* submission: corrected patch format
* submission: checked source code hash
* submission: checked license, patch applies, build/reproducibility
* added Reviewed-by trailer
* re-roll to trigger QA build

The Man (1):
gnu: Add libliftoff.

gnu/packages/freedesktop.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)


base-commit: b7c94d528875415ea7ec6225d88a6b3d55fa2e14
--
2.46.0
S
S
Steve George wrote on 22 Sep 16:07 +0200
[PATCH v2 1/1] gnu: Add libliftoff.
(address . 73311@debbugs.gnu.org)
fa3cbf5056cf9580ef2e2d8aaf711c1e27115aef.1727012997.git.steve@futurile.net
From: The Man <squishypinkelephant@gmail.com>

* gnu/packages/freedesktop.scm (libliftoff): New variable.

Reviewed-by: Steve George <steve@futurile.net>

Change-Id: I19eda24aea4327bcd72a7e15ec0784ef1e302783
---
gnu/packages/freedesktop.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 993bb84ec6..2a78895a20 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -354,6 +354,30 @@ (define-public libglib-testing
(home-page "https://gitlab.gnome.org/pwithnall/libglib-testing")
(license license:lgpl2.1+)))
+(define-public libliftoff
+ (package
+ (name "libliftoff")
+ (version "0.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/emersion/libliftoff")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "163g8ndsbma7acy2k9mrnvlpb7yi4431hgkx1gygkafgwpq1ii1x"))))
+ (build-system meson-build-system)
+ (native-inputs (list pkg-config))
+ (inputs (list libdrm))
+ (home-page "https://gitlab.freedesktop.org/emersion/libliftoff")
+ (synopsis "Lightweight KMS plane library for compositors")
+ (description "Libliftoff eases the use of
+@acronym{KMS, Kernel Mode Setting} planes from userspace. Users create
+\"virtual planes\" called layers, set KMS properties on them, and libliftoff
+will pick hardware planes for these layers if possible.")
+ (license license:expat)))
+
(define-public malcontent
(package
(name "malcontent")
--
2.46.0
T
T
The Man wrote on 22 Sep 21:22 +0200
Re: [bug#73311] [PATCH v2 0/1] Add libliftoff
(name . Steve George)(address . steve@futurile.net)(address . 73311@debbugs.gnu.org)
CAPfwWaiY-6bSwrW3+FqafWp=v1UedxpiykBgHyLcB7w8icQ--w@mail.gmail.com
My apologies. I did not consider the format of the patch could cause an
issue. I will consider better means of submitting patches in the future,
instead of through my Gmail.

On Sun, Sep 22, 2024, 9:11 AM Steve George <steve@futurile.net> wrote:

Toggle quote (32 lines)
> Hi 'The Man',
>
> Thanks for your contribution! Just be aware that it wasn't in the correct
> format so the CI system couldn't automatically build it. If it doesn't
> build a committer is less likely to take the time to look at it. Please
> have a look at the manual at the section preparing a patch (
> https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html)
> when you send your next contribution :-). Hopefully it will build
> automatically and a committer will have time to review it.
>
> Review:
> * submission: corrected patch format
> * submission: checked source code hash
> * submission: checked license, patch applies, build/reproducibility
> * added Reviewed-by trailer
> * re-roll to trigger QA build
>
> The Man (1):
> gnu: Add libliftoff.
>
> gnu/packages/freedesktop.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
>
> base-commit: b7c94d528875415ea7ec6225d88a6b3d55fa2e14
> --
> 2.46.0
>
>
>
>
>
Attachment: file
A
A
Andreas Enge wrote on 26 Sep 09:45 +0200
Close
(address . 73311-done@debbugs.gnu.org)
ZvURGpl7CnavLzcb@jurong
QA does not seem to work right now. Given that the patch is more than
a week old and has been reviewed and that the package builds for me,
I take the liberty to apply it.

Thanks for the package and the review,

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73311@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73311
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch