[PATCH v4] gnu: git: Update to 2.47.1.

  • Done
  • quality assurance status badge
Details
4 participants
  • Ashish SHUKLA
  • Greg Hogan
  • Ludovic Courtès
  • Steve George
Owner
unassigned
Submitted by
Ashish SHUKLA
Severity
normal

Debbugs page

Ashish SHUKLA wrote 6 months ago
[PATCH] gnu: git: Update to 2.46.1.
(address . guix-patches@gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
daf583697763a13ea9a8b9619c8a4a8ac56da905.1726533794.git.ashish.is@lostca.se
* gnu/packages/version-control.scm (git-minimal): Update to 2.46.1.
(git)[arguments]<install-man-pages>: Update hash.

Change-Id: I667da2d99478c073aed60ab995d86220fd860050
---
gnu/packages/version-control.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 3bec28c4f7..c0dc623678 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -57,6 +57,7 @@
;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
;;; Copyright © 2024 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2024 Javier Olaechea <pirata@gmail.com>
+;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -250,14 +251,14 @@ (define git-cross-configure-flags
(define-public git-minimal
(package
(name "git-minimal")
- (version "2.46.0")
+ (version "2.46.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "15bzq9m6c033qiz5q5gw1nqw4m452vvqax30wbms6z4bl9i384kz"))))
+ "0hzmy1vhiz2w34bjdb633pw8ic0fhnl4100npjzcpd3apnwaz348"))))
(build-system gnu-build-system)
(arguments
(list
@@ -702,7 +703,7 @@ (define-public git
".tar.xz"))
(sha256
(base32
- "1lvvhzypllbyd8j6m0p9qgd3gqg10gch9s7lqif8vr9n80fqn4fw"))))))))))))
+ "0smz24yfdpczr2p03b4d6v3fn93g19gv9z8s0v4fjdx7w2xf8liw"))))))))))))
(native-inputs
(modify-inputs (package-native-inputs git-minimal)
;; For subtree documentation.

base-commit: 8dae6b47542b906682f83b06b0478fcbd0776fd6
--
2.46.1
Greg Hogan wrote 5 months ago
(name . Ashish SHUKLA)(address . ashish.is@lostca.se)(address . 73309@debbugs.gnu.org)
CA+3U0ZkGMz_KL761COF0HL1e_O5GVzTmnFgTspR=ch9boCxgtw@mail.gmail.com
On Mon, Sep 16, 2024 at 8:47 PM Ashish SHUKLA via Guix-patches via
<guix-patches@gnu.org> wrote:
Toggle quote (52 lines)
>
> * gnu/packages/version-control.scm (git-minimal): Update to 2.46.1.
> (git)[arguments]<install-man-pages>: Update hash.
>
> Change-Id: I667da2d99478c073aed60ab995d86220fd860050
> ---
> gnu/packages/version-control.scm | 7 ++++---
> 1 file changed, 4 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
> index 3bec28c4f7..c0dc623678 100644
> --- a/gnu/packages/version-control.scm
> +++ b/gnu/packages/version-control.scm
> @@ -57,6 +57,7 @@
> ;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
> ;;; Copyright © 2024 Simon Tournier <zimon.toutoune@gmail.com>
> ;;; Copyright © 2024 Javier Olaechea <pirata@gmail.com>
> +;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -250,14 +251,14 @@ (define git-cross-configure-flags
> (define-public git-minimal
> (package
> (name "git-minimal")
> - (version "2.46.0")
> + (version "2.46.1")
> (source (origin
> (method url-fetch)
> (uri (string-append "mirror://kernel.org/software/scm/git/git-"
> version ".tar.xz"))
> (sha256
> (base32
> - "15bzq9m6c033qiz5q5gw1nqw4m452vvqax30wbms6z4bl9i384kz"))))
> + "0hzmy1vhiz2w34bjdb633pw8ic0fhnl4100npjzcpd3apnwaz348"))))
> (build-system gnu-build-system)
> (arguments
> (list
> @@ -702,7 +703,7 @@ (define-public git
> ".tar.xz"))
> (sha256
> (base32
> - "1lvvhzypllbyd8j6m0p9qgd3gqg10gch9s7lqif8vr9n80fqn4fw"))))))))))))
> + "0smz24yfdpczr2p03b4d6v3fn93g19gv9z8s0v4fjdx7w2xf8liw"))))))))))))
> (native-inputs
> (modify-inputs (package-native-inputs git-minimal)
> ;; For subtree documentation.
>
> base-commit: 8dae6b47542b906682f83b06b0478fcbd0776fd6
> --
> 2.46.1

Would it be better to skip 2.46.1 given the release note for 2.46.2?

"It also reverts the "git patch-id" change that went into 2.46.1, as
it seems to have got a regression reported (I haven't verified, but it
is better to keep a known breakage than adding an unintended
regression)."
Ashish SHUKLA wrote 5 months ago
[PATCH] gnu: git: Update to 2.46.2.
(address . 73309@debbugs.gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)(address . code@greghogan.com)
c61ba8202b6ef9d740c40f49c7f50aab845ce8c0.1727858044.git.ashish.is@lostca.se
* gnu/packages/version-control.scm (git-minimal): Update to 2.46.2.
(git)[arguments]<install-man-pages>: Update hash.

Change-Id: I667da2d99478c073aed60ab995d86220fd860050
---
gnu/packages/version-control.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 87186985e9..e1e9258d81 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -254,14 +254,14 @@ (define git-cross-configure-flags
(define-public git-minimal
(package
(name "git-minimal")
- (version "2.46.0")
+ (version "2.46.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "15bzq9m6c033qiz5q5gw1nqw4m452vvqax30wbms6z4bl9i384kz"))))
+ "18rcmvximgyg3v1a9papi9djfamiak0ys5cmgx7ll29nhp3a3s2y"))))
(build-system gnu-build-system)
(arguments
(list
@@ -706,7 +706,7 @@ (define-public git
".tar.xz"))
(sha256
(base32
- "1lvvhzypllbyd8j6m0p9qgd3gqg10gch9s7lqif8vr9n80fqn4fw"))))))))))))
+ "1bn2jifax2w0q4p67qhnb3fwsx9qvqpa0h2c857zs8mnn2cmp6gy"))))))))))))
(native-inputs
(modify-inputs (package-native-inputs git-minimal)
;; For subtree documentation.

base-commit: b9f2ff6b8d361fa40f6db08378cb47afa2652c4e
--
2.46.2
Ashish SHUKLA wrote 5 months ago
Re: [bug#73309] [PATCH] gnu: git: Update to 2.46.1.
(name . Greg Hogan)(address . code@greghogan.com)(address . 73309@debbugs.gnu.org)
D4L6MP9F7WCO.2B5X0D8OIJYRH@lostca.se
On Tue Oct 1, 2024 at 4:26 PM CEST, Greg Hogan wrote:
Toggle quote (62 lines)
> On Mon, Sep 16, 2024 at 8:47 PM Ashish SHUKLA via Guix-patches via
> <guix-patches@gnu.org> wrote:
> >
> > * gnu/packages/version-control.scm (git-minimal): Update to 2.46.1.
> > (git)[arguments]<install-man-pages>: Update hash.
> >
> > Change-Id: I667da2d99478c073aed60ab995d86220fd860050
> > ---
> > gnu/packages/version-control.scm | 7 ++++---
> > 1 file changed, 4 insertions(+), 3 deletions(-)
> >
> > diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
> > index 3bec28c4f7..c0dc623678 100644
> > --- a/gnu/packages/version-control.scm
> > +++ b/gnu/packages/version-control.scm
> > @@ -57,6 +57,7 @@
> > ;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
> > ;;; Copyright © 2024 Simon Tournier <zimon.toutoune@gmail.com>
> > ;;; Copyright © 2024 Javier Olaechea <pirata@gmail.com>
> > +;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
> > ;;;
> > ;;; This file is part of GNU Guix.
> > ;;;
> > @@ -250,14 +251,14 @@ (define git-cross-configure-flags
> > (define-public git-minimal
> > (package
> > (name "git-minimal")
> > - (version "2.46.0")
> > + (version "2.46.1")
> > (source (origin
> > (method url-fetch)
> > (uri (string-append "mirror://kernel.org/software/scm/git/git-"
> > version ".tar.xz"))
> > (sha256
> > (base32
> > - "15bzq9m6c033qiz5q5gw1nqw4m452vvqax30wbms6z4bl9i384kz"))))
> > + "0hzmy1vhiz2w34bjdb633pw8ic0fhnl4100npjzcpd3apnwaz348"))))
> > (build-system gnu-build-system)
> > (arguments
> > (list
> > @@ -702,7 +703,7 @@ (define-public git
> > ".tar.xz"))
> > (sha256
> > (base32
> > - "1lvvhzypllbyd8j6m0p9qgd3gqg10gch9s7lqif8vr9n80fqn4fw"))))))))))))
> > + "0smz24yfdpczr2p03b4d6v3fn93g19gv9z8s0v4fjdx7w2xf8liw"))))))))))))
> > (native-inputs
> > (modify-inputs (package-native-inputs git-minimal)
> > ;; For subtree documentation.
> >
> > base-commit: 8dae6b47542b906682f83b06b0478fcbd0776fd6
> > --
> > 2.46.1
>
> Would it be better to skip 2.46.1 given the release note for 2.46.2?
> https://raw.githubusercontent.com/git/git/master/Documentation/RelNotes/2.46.2.txt
>
> "It also reverts the "git patch-id" change that went into 2.46.1, as
> it seems to have got a regression reported (I haven't verified, but it
> is better to keep a known breakage than adding an unintended
> regression)."

Thanks for pointing about this.

I just sent an updated patch.

--
Ashish
-----BEGIN PGP SIGNATURE-----

iQKoBAABCgCSFiEE9oLNzDncD+rhFiC2x0bPqedPpLAFAmb9BkhfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldEY2
ODJDRENDMzlEQzBGRUFFMTE2MjBCNkM3NDZDRkE5RTc0RkE0QjAUHGFzaGlzaC5p
c0Bsb3N0Y2Euc2UACgkQx0bPqedPpLBVFg//SZt5la4YqsiupNmemmkxhKWsWkVL
h3Vlpgk/Kemcn3jiiCI6Gygfe5Wu8MSSQMyXhYMkoZ3Ct/mz0hlya1wSClB2n42e
jr1DR0OcGQiCc6d5rtxf19qwl1OM9cGReFBknI/jpCEqh+LEi729R+PgoT8S1He9
W+LPr0rysAS+Sk4Te8lh1/Z1PnjYW5V7Txekp47QGvGXNbIQ860H+OzebsK1E+hx
Q3CDchqyKyXSmd8B8IYj4dnITBD8lo43W1M3gyc2afnB76bV8v1RYY3mFpuE+pJ2
uuGjEGUnhOA1QyuSkh1tavX115zdq2awYtuH0FSdM0zA0bQpj+SySOIPmGkqhCko
YN42/3JeDM/YqN6v/CjTN10g34A0t3ZEHEjgiG5wmY6fqzTGIrbJizZRvq17sRlf
+yW9QTBIBFRGnBvZXDnU83WWS3u8mwD1cEDEc73pr8vS43G5w/6Kq33lt4aBiLrO
G2WEEOD+7ZZq6lHnOkWjbIQiMEGUgFqdypCje2ALPQ57WdACw9cwIaP4qmJv/2Le
pNKJXcn/5/K4woydvbtK36gaZsNte32XOv5L/lsA7DN6XGZCi+Mq8HxfWYStbVMj
DO2nvSyTyDinzRgX+k15w/4WwLe/K/Jl9Bpzh/TXVWW+9voN2SuA8gagh1PNt/4Y
o7jyGwYnJxQSLFk=
=L8T7
-----END PGP SIGNATURE-----


Ashish SHUKLA wrote 5 months ago
retitle bug
(address . control@debbugs.gnu.org)
D4L6NFV2X5M0.1MU8392GAP711@lostca.se
retitle 73309 [PATCH] gnu: git: Update to 2.46.2.
quit
Steve George wrote 5 months ago
Review of 73309
(address . 73309@debbugs.gnu.org)
8705d548-5b61-47b1-b8eb-2472b51cea87@futurile.net
user guix
usertag 73309 + reviewed-looks-good
thanks

Guix QA review form submission:
- Commit is fine, built and installed
- Built about 100 of the 425 dependents
- no new failures (over things that are already failing on Master).

Items marked as checked: Lint warnings, Package builds, Commit messages
ashish.is wrote 5 months ago
[PATCH v3] gnu: git: Update to 2.47.0.
(address . 73309@debbugs.gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
5336807860b904779c4f814f8af408d3c2a8bd64.1728658133.git.ashish.is@lostca.se
From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/version-control.scm (git-minimal): Update to 2.47.0.
(git)[arguments]<install-man-pages>: Update hash.

Change-Id: I63ad29cf4002606737160d5615ed0845babefe3b
---
gnu/packages/version-control.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 09066d2fa4..8b17f26c79 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -254,14 +254,14 @@ (define git-cross-configure-flags
(define-public git-minimal
(package
(name "git-minimal")
- (version "2.46.0")
+ (version "2.47.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "15bzq9m6c033qiz5q5gw1nqw4m452vvqax30wbms6z4bl9i384kz"))))
+ "0kmwhxysxsvsmqnm9xwyiv4gi6ck9ph52z027ss72hkhi3d19q8w"))))
(build-system gnu-build-system)
(arguments
(list
@@ -706,7 +706,7 @@ (define-public git
".tar.xz"))
(sha256
(base32
- "1lvvhzypllbyd8j6m0p9qgd3gqg10gch9s7lqif8vr9n80fqn4fw"))))))))))))
+ "1f7sn4rf3j2339xv2ijzljxdjq9l1bl07zs8mb1fbjfxgfhfzpy8"))))))))))))
(native-inputs
(modify-inputs (package-native-inputs git-minimal)
;; For subtree documentation.

base-commit: 053accdde356eaf84751b16d3aaf1425f410a70b
--
2.47.0
Ashish SHUKLA wrote 5 months ago
retitle bug 73309
(address . control@debbugs.gnu.org)
D4T27ON0PC3T.375J9EZS8GO63@lostca.se
retitle 73309 [PATCH v3] gnu: git: Update to 2.47.0.
quit
ashish.is wrote 4 months ago
[PATCH] gnu: git: Update to 2.47.1.
(address . 73309@debbugs.gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
eeea60f18deb4dce59006cfb7b6537edae6f6b4c.1732649613.git.ashish.is@lostca.se
From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/version-control.scm (git-minimal): Update to 2.47.1.
(git)[arguments]<install-man-pages>: Update hash.

Change-Id: I63ad29cf4002606737160d5615ed0845babefe3b
---
gnu/packages/version-control.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index c892a83a98..bc4ad4ac52 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -258,14 +258,14 @@ (define git-cross-configure-flags
(define-public git-minimal
(package
(name "git-minimal")
- (version "2.46.0")
+ (version "2.47.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "15bzq9m6c033qiz5q5gw1nqw4m452vvqax30wbms6z4bl9i384kz"))))
+ "046kdr5dhg31hjcg6wpfqnwwbaqdjyax7n8wx5s26fdf4fxzkn7k"))))
(build-system gnu-build-system)
(arguments
(list
@@ -710,7 +710,7 @@ (define-public git
".tar.xz"))
(sha256
(base32
- "1lvvhzypllbyd8j6m0p9qgd3gqg10gch9s7lqif8vr9n80fqn4fw"))))))))))))
+ "04zfxwdhja82mm24isk2jxhp30q6l3nnnzv6gdrc0mmhi5d01hpz"))))))))))))
(native-inputs
(modify-inputs (package-native-inputs git-minimal)
;; For subtree documentation.

base-commit: a2a3264bb38568e892e69e64dcfd12829a9975ce
--
2.47.1
ashish.is wrote 4 months ago
[PATCH v4] gnu: git: Update to 2.47.1.
(address . 73309@debbugs.gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
d66b94b632057ded1d890b53b73ce85ecf63c171.1732649821.git.ashish.is@lostca.se
From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/version-control.scm (git-minimal): Update to 2.47.1.
(git)[arguments]<install-man-pages>: Update hash.

Change-Id: I43b730ab22dbf3c8750936cb342f96342b9ca0b0
---
Hi,

Please disregard previous patch.

gnu/packages/version-control.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index c892a83a98..bc4ad4ac52 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -258,14 +258,14 @@ (define git-cross-configure-flags
(define-public git-minimal
(package
(name "git-minimal")
- (version "2.46.0")
+ (version "2.47.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "15bzq9m6c033qiz5q5gw1nqw4m452vvqax30wbms6z4bl9i384kz"))))
+ "046kdr5dhg31hjcg6wpfqnwwbaqdjyax7n8wx5s26fdf4fxzkn7k"))))
(build-system gnu-build-system)
(arguments
(list
@@ -710,7 +710,7 @@ (define-public git
".tar.xz"))
(sha256
(base32
- "1lvvhzypllbyd8j6m0p9qgd3gqg10gch9s7lqif8vr9n80fqn4fw"))))))))))))
+ "04zfxwdhja82mm24isk2jxhp30q6l3nnnzv6gdrc0mmhi5d01hpz"))))))))))))
(native-inputs
(modify-inputs (package-native-inputs git-minimal)
;; For subtree documentation.

base-commit: a2a3264bb38568e892e69e64dcfd12829a9975ce
--
2.47.1
Ashish SHUKLA wrote 4 months ago
retitle debug
(address . control@debbugs.gnu.org)
D5WD4UG65X2G.789RZVB7HX62@lostca.se
retitle 73309 [PATCH v4] gnu: git: Update to 2.47.1.
quit
Ludovic Courtès wrote 3 months ago
Re: bug#73309: [PATCH v4] gnu: git: Update to 2.47.1.
(address . ashish.is@lostca.se)(address . 73309-done@debbugs.gnu.org)
877c7q6vnd.fsf_-_@gnu.org
ashish.is@lostca.se skribis:

Toggle quote (7 lines)
> From: Ashish SHUKLA <ashish.is@lostca.se>
>
> * gnu/packages/version-control.scm (git-minimal): Update to 2.47.1.
> (git)[arguments]<install-man-pages>: Update hash.
>
> Change-Id: I43b730ab22dbf3c8750936cb342f96342b9ca0b0

Finally applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73309@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73309
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help