guix deploy fails with dropbear ssh server

  • Open
  • quality assurance status badge
Details
2 participants
  • Attila Lendvai
  • Attila Lendvai
Owner
unassigned
Submitted by
Attila Lendvai
Severity
normal
A
A
Attila Lendvai wrote on 16 Sep 23:23 +0200
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
EOmyWn8SUP1TEf3v0WqkTp2JPcGVjSHfpOVN7-rlyMbB_95D2JEzMO08DH-XHqu-L7GNFW14gr8FXjTDrcMyA2ZSIAFo4QP3kuE2jsXdpps=@lendvai.name
should `guix deploy` work with dropbear?

on one of my servers i have replaced openssh with dropbear.

(service dropbear-service-type
(dropbear-configuration
(port-number 22)
(password-authentication? #false)
;; To allow `guix deploy` to connect as root.
(root-login? #true)))

i `guix deploy`ed the config, even rebooted the machine. all works fine, except when i want to `guix deploy` once again:

$ guix deploy x.scm
The following 1 machine will be deployed:
lendvai

guix deploy: deploying to lendvai...
;;; [2024/09/16 23:10:53.550882, 0] [GSSH ERROR] : #<input-output: channel (closed by the remote side) 7fccff89d080>
Backtrace:
In ice-9/boot-9.scm:
1752:10 19 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In guix/status.scm:
839:4 18 (call-with-status-report _ _)
In ice-9/boot-9.scm:
1752:10 17 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In guix/store.scm:
689:37 16 (thunk)
1330:8 15 (call-with-build-handler #<procedure 7fccf6b996c0 at guix/ui.scm:1240:2 (continue store things mode)> _)
In guix/scripts/deploy.scm:
284:23 14 (_)
In guix/store.scm:
1412:11 13 (map/accumulate-builds #<store-connection 256.100 7fccf0dc30a0> #<procedure 7fccff88e540 at guix/scripts/deploy.scm:285:45 (t-1e3fba6565d6004…> …)
1330:8 12 (call-with-build-handler #<procedure 7fccf6ba0b10 at guix/store.scm:1365:2 (continue store things mode)> _)
In ice-9/boot-9.scm:
1752:10 11 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In guix/scripts/deploy.scm:
166:29 10 (_)
In gnu/machine/ssh.scm:
513:25 9 (deploy-managed-host #<<machine> operating-system: #<<operating-system> kernel: #<package linux-libre@6.10.9 gnu/packages/linux.scm:974 7fccf4…>)
397:2 8 (check-deployment-sanity #<<machine> operating-system: #<<operating-system> kernel: #<package linux-libre@6.10.9 gnu/packages/linux.scm:974 7f…>)
365:17 7 (machine-check-building-for-appropriate-system _)
In guix/ssh.scm:
204:18 6 (remote-system _)
191:15 5 (remote-inferior _ _)
In ssh/popen.scm:
64:4 4 (open-remote-pipe* #<session root@lendvai.name:22 (connected) 7fccfd6fafe0> "r+" _ . _)
In unknown file:
3 (channel-open-session #<input-output: channel (closed by the remote side) 7fccff89d080>)
In ice-9/boot-9.scm:
1685:16 2 (raise-exception _ #:continuable? _)
1685:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
Throw to key `guile-ssh-error' with args `("channel-open-session" "" #<input-output: channel (closed by the remote side) 7fccff89d080> #f)'.



the ssh login part seems to have worked fine according to /var/log/secure:

Sep 16 23:10:52 localhost dropbear[489]: Pubkey auth succeeded for 'root' with ssh-ed25519 key SHA256:[...] from [...]
Sep 16 23:10:53 localhost dropbear[489]: Exit (root) from <...>: Exited normally

--
• attila lendvai
• PGP: 963F 5D5F 45C7 DFCD 0A39
--
“Let him who would move the world, first move himself.”
— Socrates (c. 470–399 BC, tried and executed)
A
A
Attila Lendvai wrote on 30 Sep 11:54 +0200
(name . bug#73306)(address . 73306@debbugs.gnu.org)
87plolpiv2.fsf@lendvai.name
this seems to be an upstream regression:


i can see the same failing assert in my server's /var/log/secure when i
try to `guix deploy` to it:

Failed assertion (src/common-channel.c:705): `!channel->sent_close'

<#secure method=pgpmime mode=sign>
--
• attila lendvai
• PGP: 963F 5D5F 45C7 DFCD 0A39
--
“Many abused children cling to the hope that growing up will bring escape and freedom.
But the personality formed in the environment of coercive control is not well adapted to adult life. The survivor is left with fundamental problems in basic trust, autonomy, and initiative. She approaches the task of early adulthood?establishing independence and intimacy?burdened by major impairments in self-care, in cognition and in memory, in identity, and in the capacity to form stable relationships.
She is still a prisoner of her childhood; attempting to create a new life, she reencounters the trauma.”
— Judith Lewis Herman (1942–)
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73306@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73306
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch