[PATCH 1/2] gnu: python-pycurl: Fix build by running the tests single-threaded.

  • Open
  • quality assurance status badge
Details
One participant
  • attila.lendvai
Owner
unassigned
Submitted by
attila.lendvai
Severity
normal
A
A
attila.lendvai wrote on 16 Sep 22:53 +0200
(address . guix-patches@gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
f392dfea88bd56784b44ab3e9500e28b6d052877.1726520027.git.attila@lendvai.name
From: Attila Lendvai <attila@lendvai.name>

* gnu/packages/python-web.scm (python-pycurl): Make test run single-threaded.
Reenable some tests that used to fail due to threading.
[test_request_without_certinfo]: Disable test/timebomb that probably uses an
expired CA.

Change-Id: I62bc60757cf2e005ed55768c84d8c178f63c35ec
---
gnu/packages/python-web.scm | 15 +++++++++------
1 file changed, 9 insertions(+), 6 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8b29f1cd936..94e349bedb0 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2024,15 +2024,18 @@ (define-public python-pycurl
(build-system pyproject-build-system)
(arguments
'(#:test-flags
- (list "-n" "auto"
+ (list
+ ;; The test suite is not thread safe:
+ ;; - some tests want to use the same port: address already in use
+ ;; - some tests use signal.Signal, i.e. main-thread only
+ "-n" "1"
"-k" (string-append
;; Disable hanginging tests
"not test_multi_socket_select"
;; E assert None is not None
;; E+ where None =
;; <tests.multi_callback_test.MultiCallbackTest
- ;; testMethod=test_easy_pause_unpause>.socket_result
- " and not test_easy_pause_unpause"
+ ;; testMethod=test_multi_socket_action>.timer_result
" and not test_multi_socket_action"
;; E pycurl.error: (1, '')
" and not test_http_version_3"
@@ -2045,9 +2048,9 @@ (define-public python-pycurl
;; OSError: tests/fake-curl/libcurl/with_openssl.so: cannot
;; open shared object file: No such file or directory
" and not test_libcurl_ssl_openssl"
- ;; pycurl.error: (56, 'Recv failure: Connection reset by
- ;; peer')
- " and not test_post_with_read_callback"))
+ ;; Probably due to an expired CA
+ " and not test_request_without_certinfo"
+ ))
#:phases (modify-phases %standard-phases
(add-before 'build 'configure-tls-backend
(lambda _

base-commit: 4f86fa20179ded1e6314eeba7da17309d501a32f
--
2.46.0
A
A
attila.lendvai wrote on 16 Sep 22:55 +0200
[PATCH 2/2] gnu: python-pycurl: Build from git.
(address . 73305@debbugs.gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
196054ea15207a26c7d9f3daf24334418333caf4.1726520125.git.attila@lendvai.name
From: Attila Lendvai <attila@lendvai.name>

Change-Id: I1b347c04022970ffe42a87530e525a83745ff84c
---
gnu/packages/python-web.scm | 11 ++++++++---
1 file changed, 8 insertions(+), 3 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 94e349bedb0..2dfbf5b66e5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2017,10 +2017,15 @@ (define-public python-pycurl
(version "7.45.2")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "pycurl" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pycurl/pycurl")
+ (commit (string-append
+ "REL_" (string-replace-substring version "." "_")))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1ji46b924caa4saxvjxs9h673yy0kif297nxpnjn84r7w05mjc2p"))))
+ (base32
+ "1dzdramcgf63m1zg8glhqa3ik9anzjy954mshk7s3z3gsi21n8fp"))))
(build-system pyproject-build-system)
(arguments
'(#:test-flags
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73305@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73305
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch