Simon Tournier wrote 6 months ago
(address . bug-guix@gnu.org)
Hi,
Toggle snippet (5 lines)
$ guix shell --pure
guix shell: warning: no packages specified; creating an empty environment
guix shell: warning: no packages specified; creating an empty environment
That’s because: one is from ’auto-detect-manifest’ in (guix scripts
shell):
(if (or (not interactive?)
disallow-implicit-load?
(options-contain-payload? opts))
opts
(match (find-file-in-parent-directories '("manifest.scm" "guix.scm"))
(#f
(warning (G_ "no packages specified; creating an empty environment~%"))
opts)
called by ’parse-args’ called by the entry-point command ’guix-sell’.
And another one is from ’guix-environment*’ in (guix scripts
environment):
(when (null? (manifest-entries manifest))
(warning (G_ "no packages specified; creating an empty environment~%")))
called by the entry-point command ’guix-shell’.
Well, since ‘guix environment’ is deprecated, I would suggest to remove
the warning in ’guix-environment*’. It would improve the “polish”.
Cheers,
simon
Reported by @lynn_sh@tech.lgbt from Mastodon. :-)