“guix shell --pure“ displays twice the same warning

  • Open
  • quality assurance status badge
Details
One participant
  • Simon Tournier
Owner
unassigned
Submitted by
Simon Tournier
Severity
normal

Debbugs page

Simon Tournier wrote 6 months ago
(address . bug-guix@gnu.org)
87tteggh71.fsf@gmail.com
Hi,

Toggle snippet (5 lines)
$ guix shell --pure
guix shell: warning: no packages specified; creating an empty environment
guix shell: warning: no packages specified; creating an empty environment

That’s because: one is from ’auto-detect-manifest’ in (guix scripts
shell):

(if (or (not interactive?)
disallow-implicit-load?
(options-contain-payload? opts))
opts
(match (find-file-in-parent-directories '("manifest.scm" "guix.scm"))
(#f
(warning (G_ "no packages specified; creating an empty environment~%"))
opts)

called by ’parse-args’ called by the entry-point command ’guix-sell’.

And another one is from ’guix-environment*’ in (guix scripts
environment):

(when (null? (manifest-entries manifest))
(warning (G_ "no packages specified; creating an empty environment~%")))

called by the entry-point command ’guix-shell’.

Well, since ‘guix environment’ is deprecated, I would suggest to remove
the warning in ’guix-environment*’. It would improve the “polish”.

Cheers,
simon

Reported by @lynn_sh@tech.lgbt from Mastodon. :-)
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73292@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73292
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help