[PATCH 0/2] Update bloomberg-bde.

  • Done
  • quality assurance status badge
Details
2 participants
  • Greg Hogan
  • Ludovic Courtès
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 15 Sep 22:34 +0200
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
cover.1726431170.git.code@greghogan.com
This both updates the package and reduces the number of excluded tests.
Based on our previous builds I had notified upstream of several test
failures, some of which were reproduced and fixed. I have successfully
built the package 5+ times but can re-exclude tests which fail for
others or on the substitute servers.

Greg Hogan (2):
gnu: bloomberg-bde-tools: Update to 4.13.0.0.
gnu: bloomberg-bde: Update to 4.14.0.0.

gnu/packages/cpp.scm | 32 ++++++++++----------------------
1 file changed, 10 insertions(+), 22 deletions(-)


base-commit: 4f86fa20179ded1e6314eeba7da17309d501a32f
--
2.46.0
G
G
Greg Hogan wrote on 15 Sep 22:37 +0200
[PATCH 1/2] gnu: bloomberg-bde-tools: Update to 4.13.0.0.
(address . 73283@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
f6b2ab85a41af5710f9cfcb1aa9b594ce343ec5c.1726431170.git.code@greghogan.com
* gnu/packages/cpp.scm (bloomberg-bde-tools): Update to 4.13.0.0.

Change-Id: I69694ef097c958b524a9701b04eab9290700eca8
---
gnu/packages/cpp.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 579dde6953..996fc74eaf 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2433,11 +2433,11 @@ (define-public simdjson-0.6
"038i9nmk85vpxvs546w6cyci0ppdrrp5wnlv1kffxw29x71a3g5l"))))))
(define-public bloomberg-bde-tools
- (let ((commit "f63dfe9114cd7df29623bd01f644b9f654253972"))
+ (let ((commit "23217675939d434537ef74b91f71b63054e36572"))
(package
(name "bloomberg-bde-tools")
;; Recent releases are not tagged so commit must be used for checkout.
- (version "3.118.0.0")
+ (version "4.13.0.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2446,7 +2446,7 @@ (define-public bloomberg-bde-tools
(file-name (git-file-name name version))
(sha256
(base32
- "1a5sw4xjwd222na3zkflm2gkmzhnfq17i8qapyaxszpiayf3hw6v"))
+ "1x440fa8fghigipn6w8zdr60kkvxrkxs2n9a5hf3y33b8aygh8iv"))
(patches
(search-patches
"bloomberg-bde-tools-fix-install-path.patch"))))
--
2.46.0
G
G
Greg Hogan wrote on 15 Sep 22:37 +0200
[PATCH 2/2] gnu: bloomberg-bde: Update to 4.14.0.0.
(address . 73283@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
02531e94244c1839e5d4989207474d2573497c0f.1726431170.git.code@greghogan.com
* gnu/packages/cpp.scm (bloomberg-bde): Update to 4.14.0.0.
[source](origin): Update test deletion list.

Change-Id: I147a00c44cb835a3d0198d4f8372fd93404f49bb
---
gnu/packages/cpp.scm | 26 +++++++-------------------
1 file changed, 7 insertions(+), 19 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 996fc74eaf..5fced92d06 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2460,11 +2460,11 @@ (define-public bloomberg-bde-tools
(license license:asl2.0))))
(define-public bloomberg-bde
- (let ((commit "77a0f39d538c20ae28bece9a81cac99a9e1df95d"))
+ (let ((commit "445a8ac4223b90ee0a46749b87ffbbd21788e132"))
(package
(name "bloomberg-bde")
;; Recent releases are not tagged so commit must be used for checkout.
- (version "3.118.0.1")
+ (version "4.14.0.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2473,7 +2473,7 @@ (define-public bloomberg-bde
(file-name (git-file-name name version))
(sha256
(base32
- "0nw5clkc9yipd03kijh4c8lxi9zkxfxcjhszl1xzwvgz8xmpampf"))
+ "1hf09d4fcn77s1vv6qrh0sa0rv9wijpk55km6p3zi2ymkb2cha3c"))
(patches
(search-patches
"bloomberg-bde-cmake-module-path.patch"))
@@ -2487,24 +2487,12 @@ (define-public bloomberg-bde
;; Delete failing tests.
(for-each
delete-file
- (list "groups/bal/ball/ball_asyncfileobserver.t.cpp"
- "groups/bal/ball/ball_fileobserver2.t.cpp"
- "groups/bal/ball/ball_recordstringformatter.t.cpp"
- "groups/bal/balst/balst_stacktraceresolver_filehelper.t.cpp"
+ (list "groups/bal/balcl/balcl_commandline.t.cpp"
+ "groups/bal/balst/balst_resolver_filehelper.t.cpp"
+ "groups/bal/balst/balst_stacktraceprintutil.t.cpp"
"groups/bal/balst/balst_stacktraceutil.t.cpp"
- "groups/bdl/bdlmt/bdlmt_eventscheduler.t.cpp"
- "groups/bdl/bdlmt/bdlmt_timereventscheduler.t.cpp"
- "groups/bdl/bdls/bdls_filesystemutil.t.cpp"
"groups/bsl/bslh/bslh_hash.t.cpp"
- "groups/bsl/bslh/bslh_hashpair.t.cpp"
- "groups/bsl/bsls/bsls_platform.t.cpp"
- "groups/bsl/bsls/bsls_stackaddressutil.t.cpp"
- "groups/bsl/bsls/bsls_stopwatch.t.cpp"
- "groups/bsl/bsls/bsls_timeutil.t.cpp"
- "groups/bsl/bslstl/bslstl_deque.1.t.cpp"
- "groups/bsl/bslstl/bslstl_deque.2.t.cpp"
- "groups/bsl/bslstl/bslstl_deque.3.t.cpp"
- "groups/bsl/bslstl/bslstl_function_invokerutil.t.cpp"))
+ "groups/bsl/bsls/bsls_timeutil.t.cpp"))
#t))))
(build-system cmake-build-system)
(arguments
--
2.46.0
L
L
Ludovic Courtès wrote on 17 Nov 23:00 +0100
Re: [bug#73283] [PATCH 0/2] Update bloomberg-bde.
(name . Greg Hogan)(address . code@greghogan.com)(address . 73283-done@debbugs.gnu.org)
87a5dxikr4.fsf@gnu.org
Hi,

Greg Hogan <code@greghogan.com> skribis:

Toggle quote (6 lines)
> This both updates the package and reduces the number of excluded tests.
> Based on our previous builds I had notified upstream of several test
> failures, some of which were reproduced and fixed. I have successfully
> built the package 5+ times but can re-exclude tests which fail for
> others or on the substitute servers.

Nice.

Toggle quote (4 lines)
> Greg Hogan (2):
> gnu: bloomberg-bde-tools: Update to 4.13.0.0.
> gnu: bloomberg-bde: Update to 4.14.0.0.

Finally applied both, thanks! (Unfortunately qa.guix isn’t helping,
hence the extra delay.)

I would suggest applying for commit access if you haven’t done so
already (I think we discussed it before, didn’t we?). I’m happy to
vouch for you!

Ludo’.
Closed
G
G
Greg Hogan wrote on 18 Nov 17:53 +0100
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 73283-done@debbugs.gnu.org)
CA+3U0ZnUP-_Aq-54tLCOx9WNhQx9+UUrWJ3yLW1KxmzKvjXwLA@mail.gmail.com
On Sun, Nov 17, 2024 at 5:00?PM Ludovic Courtès <ludo@gnu.org> wrote:
Toggle quote (9 lines)
>
> [...]
>
> I would suggest applying for commit access if you haven’t done so
> already (I think we discussed it before, didn’t we?). I’m happy to
> vouch for you!
>
> Ludo’.

I did, and you did, and I am (I think) patiently waiting to hear back
from a third committer.

Greg
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73283@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73283
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch