[PATCH] gnu: openblas: Add debug output.

  • Open
  • quality assurance status badge
Details
One participant
  • Artyom Bologov
Owner
unassigned
Submitted by
Artyom Bologov
Severity
normal

Debbugs page

Artyom Bologov wrote 6 months ago
(name . Guix Patches)(address . guix-patches@gnu.org)
87jzfdskc9.fsf@aartaka.me
Hi y'all,

This patch adds a debug output to OpenBLAS and adjusts build flags
accordingly. The final non-debug build is likely unaffected by DEBUG=1,
because Guix strips the debug symbols out anyway. Note that this change
likely requires checking the CI for the package, like with bug #73058.
From 1cd8da82659bf9d369201135c86717d2ea40d7ca Mon Sep 17 00:00:00 2001
From: Artyom Bologov <mail@aartaka.me>
Date: Sun, 15 Sep 2024 06:42:29 +0400
Subject: [PATCH] gnu: openblas: Add debug output.

* gnu/packages/maths.scm (openblas): Add "debug" output
[outputs]: Add argument, add "debug" output
[arguments]<#:make-flags>: Add DEBUG=1 flag
---
gnu/packages/maths.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a0cc0788ca..2d5b239548 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5173,6 +5173,7 @@ (define-public openblas
#:make-flags
#~(list (string-append "PREFIX=" #$output)
"SHELL=bash"
+ "DEBUG=1" ; enable debug symbols
"MAKE_NB_JOBS=0" ;use jobserver for submakes
"NO_STATIC=1" ;avoid a 67 MiB static archive
@@ -5225,6 +5226,7 @@ (define-public openblas
(list `(,gfortran "lib")))
(native-inputs
(list cunit gfortran perl))
+ (outputs '("out" "debug"))
(home-page "https://www.openblas.net/")
(synopsis "Optimized BLAS library based on GotoBLAS")
(description
--
2.41.0
Thanks,
--
Artyom Bologov
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73262@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73262
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help