(address . guix-patches@gnu.org)
boinc-server is not supposed to be installed this (or any other) packaged way.
Also, it uses a completely different versioning scheme.
I don't see any value keeping it here, thus with this patch I suggest to remove it completely.
Signed-off-by: Vitalii Koshura <lestat.de.lionkur@gmail.com>
---
gnu/packages/distributed.scm | 14 --------------
1 file changed, 14 deletions(-)
Toggle diff (24 lines)
diff --git a/gnu/packages/distributed.scm b/gnu/packages/distributed.scm
index b07acfd863..5430d1428f 100644
--- a/gnu/packages/distributed.scm
+++ b/gnu/packages/distributed.scm
@@ -83,17 +83,3 @@ (define-public boinc-client
(home-page "https://boinc.berkeley.edu/")
;; BOINC is distributed as LGPL3+, with some individual modules under GPL3+.
(license (list license:lgpl3+ license:gpl3+))))
-
-(define-public boinc-server
- ;; XXX The server and client packages duplicate many files such as /lib.
- ;; TODO: consolidate them?
- (package (inherit boinc-client)
- (name "boinc-server")
- (arguments
- (list
- #:configure-flags
- #~(list "--disable-client"
- "--disable-manager")
- #:parallel-build? #f))
- (inputs (list curl `(,mariadb "dev") openssl zlib))
- (propagated-inputs (list perl python-wrapper))))
--
2.34.1