[PATCH v1 0/2] Fix shortcut key issue with xfce4-pulseaudio-plugin

  • Open
  • quality assurance status badge
Details
One participant
  • Ashvith Shetty
Owner
unassigned
Submitted by
Ashvith Shetty
Severity
normal
A
A
Ashvith Shetty wrote on 13 Sep 23:56 +0200
(address . guix-patches@gnu.org)(name . Ashvith Shetty)(address . ashvithshetty10@gmail.com)
cover.1726264393.git.ashvithshetty10@gmail.com
This patch series resolves the issue with media key while using xfce4-pulseaudio-plugin.
Since the media keys work fine now, there's no need to provide xfce4-volumed-pulse as
another input for the xfce metapackage.

Ashvith Shetty (2):
gnu: xfce4-pulseaudio-plugin: Add inputs "keybinder" and "pavucontrol"
gnu: xfce: Remove input "xfce4-volumed-pulse"

gnu/packages/xfce.scm | 108 +++++++++++++++++++++---------------------
1 file changed, 55 insertions(+), 53 deletions(-)

--
2.46.0
A
A
Ashvith Shetty wrote on 13 Sep 23:59 +0200
[PATCH v1 1/2] gnu: xfce4-pulseaudio-plugin: Add inputs "keybinder" and "pavucontrol"
(address . 73239@debbugs.gnu.org)(name . Ashvith Shetty)(address . ashvithshetty10@gmail.com)
fc00102d987446c88d44bad691538c25288410ea.1726264393.git.ashvithshetty10@gmail.com
* gnu/packages/xfce.scm (xfce4-pulseaudio-plugin)[inputs]: Add the missing inputs "keybinder" and "pavucontrol"

Change-Id: Iab871e33e4821c2631d6ad19759e1d1a0b3af02d
---
gnu/packages/xfce.scm | 19 +++++++++++++------
1 file changed, 13 insertions(+), 6 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 33b8d59051..8277668f2c 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -504,15 +504,22 @@ (define-public xfce4-pulseaudio-plugin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/panel-plugins/"
"xfce4-pulseaudio-plugin/"
- (version-major+minor version) "/"
- "xfce4-pulseaudio-plugin-" version ".tar.bz2"))
+ (version-major+minor version)
+ "/"
+ "xfce4-pulseaudio-plugin-"
+ version
+ ".tar.bz2"))
(sha256
(base32 "0j037wnx0z22nw11mq0y3cnq1srr52zckjap3klj3hirghh2nx5x"))))
(build-system gnu-build-system)
- (native-inputs
- (list intltool pkg-config dbus-glib dbus))
- (inputs
- (list exo libnotify libxfce4ui pulseaudio xfce4-panel))
+ (native-inputs (list intltool pkg-config dbus-glib dbus))
+ (inputs (list exo
+ keybinder
+ libnotify
+ libxfce4ui
+ pavucontrol
+ pulseaudio
+ xfce4-panel))
(home-page "https://git.xfce.org/panel-plugins/xfce4-pulseaudio-plugin/")
(synopsis "PulseAudio panel plugin for Xfce")
(description
--
2.46.0
A
A
Ashvith Shetty wrote on 13 Sep 23:59 +0200
[PATCH v1 2/2] gnu: xfce: Remove input "xfce4-volumed-pulse"
(address . 73239@debbugs.gnu.org)(name . Ashvith Shetty)(address . ashvithshetty10@gmail.com)
76297635b28eaab58a0ff79ed78747d212495ca0.1726264393.git.ashvithshetty10@gmail.com
* gnu/packages/xfce.scm (xfce)[inputs]: Remove input "xfce4-volumed-pulse"

Change-Id: I80a80064c75907b2a1e6e880fab9f1e772921b13
---
gnu/packages/xfce.scm | 89 ++++++++++++++++++++-----------------------
1 file changed, 42 insertions(+), 47 deletions(-)

Toggle diff (110 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 8277668f2c..5ece50b69b 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1207,61 +1207,56 @@ (define-public xfce
(package
(name "xfce")
(version (package-version xfce4-session))
- (source #f)
+ (source
+ #f)
(build-system trivial-build-system)
(arguments
'(#:modules ((guix build union))
- #:builder
- (begin
- (use-modules (ice-9 match)
- (guix build union))
- (match %build-inputs
- (((names . directories) ...)
- (union-build (assoc-ref %outputs "out")
- directories)
- #t)))))
- (inputs
- (list exo
- garcon
- adwaita-icon-theme
- elementary-xfce-icon-theme
- greybird-gtk-theme
- hicolor-icon-theme
- mate-polkit-for-xfce
- mousepad
- ristretto
- shared-mime-info
- thunar
- thunar-volman
- tumbler
- xfce4-appfinder
- xfce4-notifyd ;for pop-up notifications
- xfce4-panel
- xfce4-power-manager
- xfce4-screenshooter
- xfce4-session
- xfce4-settings
- xfce4-taskmanager
- xfce4-terminal
- xfconf
- xfdesktop
- xfwm4
- xfwm4-themes
- xkill
- ;; Panel plugins.
- xfce4-battery-plugin
- xfce4-clipman-plugin
- xfce4-pulseaudio-plugin
- xfce4-volumed-pulse
- xfce4-xkb-plugin))
+ #:builder (begin
+ (use-modules (ice-9 match)
+ (guix build union))
+ (match %build-inputs
+ (((names . directories) ...)
+ (union-build (assoc-ref %outputs "out") directories) #t)))))
+ (inputs (list exo
+ garcon
+ adwaita-icon-theme
+ elementary-xfce-icon-theme
+ greybird-gtk-theme
+ hicolor-icon-theme
+ mate-polkit-for-xfce
+ mousepad
+ ristretto
+ shared-mime-info
+ thunar
+ thunar-volman
+ tumbler
+ xfce4-appfinder
+ xfce4-notifyd ;for pop-up notifications
+ xfce4-panel
+ xfce4-power-manager
+ xfce4-screenshooter
+ xfce4-session
+ xfce4-settings
+ xfce4-taskmanager
+ xfce4-terminal
+ xfconf
+ xfdesktop
+ xfwm4
+ xfwm4-themes
+ xkill
+ ;; Panel plugins.
+ xfce4-battery-plugin
+ xfce4-clipman-plugin
+ xfce4-pulseaudio-plugin
+ xfce4-xkb-plugin))
(propagated-inputs
;; Default font that applications such as IceCat require.
(list font-dejavu))
(native-search-paths
;; For finding panel and thunar plugins.
- (append
- (package-native-search-paths xfce4-panel)
- (package-native-search-paths thunar)))
+ (append (package-native-search-paths xfce4-panel)
+ (package-native-search-paths thunar)))
(home-page "https://www.xfce.org/")
(synopsis "Desktop environment (meta-package)")
(description
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73239@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73239
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch