(address . bug-guix@gnu.org)
Locally (with glib 2.80):
Toggle snippet (51 lines)
********* Start testing of tst_QBuffer *********
Config: Using QtTest library 6.6.3, Qt 6.6.3 (x86_64-little_endian-lp64 shared (dynamic) release build; by GCC 11.4.0), unknown unknown
PASS : tst_QBuffer::initTestCase()
PASS : tst_QBuffer::open()
PASS : tst_QBuffer::openWriteOnlyDoesNotTruncate()
PASS : tst_QBuffer::getSetCheck()
QWARN : tst_QBuffer::readBlock() QIODevice::read (QBuffer): device not open
PASS : tst_QBuffer::readBlock()
PASS : tst_QBuffer::readBlockPastEnd()
PASS : tst_QBuffer::writeBlock(small_bytearray)
PASS : tst_QBuffer::writeBlock(large_bytearray)
PASS : tst_QBuffer::seek()
SKIP : tst_QBuffer::invalidSeeks() This is a 32-bit-only test.
Loc: [/tmp/guix-build-qtbase-6.6.3.drv-0/qtbase-everywhere-src-6.6.3/tests/auto/corelib/io/qbuffer/tst_qbuffer.cpp(298)]
PASS : tst_QBuffer::seekTest(small_bytearray)
PASS : tst_QBuffer::seekTest(large_bytearray)
PASS : tst_QBuffer::read_rawdata()
PASS : tst_QBuffer::isSequential()
PASS : tst_QBuffer::signalTest(empty)
PASS : tst_QBuffer::signalTest(size 1)
PASS : tst_QBuffer::signalTest(size 2)
PASS : tst_QBuffer::signalTest(size 100)
PASS : tst_QBuffer::isClosedAfterClose()
PASS : tst_QBuffer::readLine(1)
PASS : tst_QBuffer::readLine(2)
PASS : tst_QBuffer::readLine(3)
PASS : tst_QBuffer::readLine(4)
PASS : tst_QBuffer::canReadLine(1)
PASS : tst_QBuffer::canReadLine(2)
PASS : tst_QBuffer::canReadLine(3)
PASS : tst_QBuffer::canReadLine(4)
PASS : tst_QBuffer::atEnd()
PASS : tst_QBuffer::readLineBoundaries()
PASS : tst_QBuffer::getAndUngetChar()
PASS : tst_QBuffer::writeAfterQByteArrayResize()
QDEBUG : tst_QBuffer::writeOfMoreThan2GiB() created dataset in 3578 ms
QDEBUG : tst_QBuffer::writeOfMoreThan2GiB() performed write in 77428 ms
writeOfMoreThan2GiB function time: 300000ms, total time: 300008ms
QFATAL : tst_QBuffer::writeOfMoreThan2GiB() Test function timed out
FAIL! : tst_QBuffer::writeOfMoreThan2GiB() Received a fatal error.
Totals: 30 passed, 1 failed, 1 skipped, 0 blacklisted, 300020ms
********* Finished testing of tst_QBuffer *********
Received signal 6 (SIGABRT)
writeOfMoreThan2GiB function time: 300012ms, total time: 300020ms
CMake Error at tst_qbufferWrapperRelWithDebInfo.cmake:18 (message):
/tmp/guix-build-qtbase-6.6.3.drv-0/build/tests/auto/corelib/io/qbuffer/tst_qbuffer
execution failed with exit code Subprocess aborted.
On CI [1]:
Toggle snippet (19 lines)
The following tests FAILED:
74 - tst_qsharedmemory (Failed)
QWARN : tst_QSharedMemory::useTooMuchMemory(SystemV-Q) QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/guix-build-qtbase-6.6.3.drv-0/runtime-nixbld'
[…
QWARN : tst_QSharedMemory::useTooMuchMemory(SystemV-Q) QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/guix-build-qtbase-6.6.3.drv-0/runtime-nixbld'
WARNING: tst_QSharedMemory::useTooMuchMemory(SystemV-Q) Maximum amount of warnings exceeded. Use -maxwarnings to override.
FAIL! : tst_QSharedMemory::useTooMuchMemory(SystemV-Q) 'sm->error() == QSharedMemory::OutOfResources || sm->error() == QSharedMemory::LockError' returned FALSE. ()
Loc: [/tmp/guix-build-qtbase-6.6.3.drv-0/qtbase-everywhere-src-6.6.3/tests/auto/corelib/ipc/qsharedmemory/tst_qsharedmemory.cpp(612)]
FAIL! : tst_QSharedMemory::useTooMuchMemory(SystemV-T) 'sm->error() == QSharedMemory::OutOfResources || sm->error() == QSharedMemory::LockError' returned FALSE. ()
Loc: [/tmp/guix-build-qtbase-6.6.3.drv-0/qtbase-everywhere-src-6.6.3/tests/auto/corelib/ipc/qsharedmemory/tst_qsharedmemory.cpp(612)]
SKIP : tst_QSharedMemory::attachTooMuch(POSIX) disabled
Loc: [/tmp/guix-build-qtbase-6.6.3.drv-0/qtbase-everywhere-src-6.6.3/tests/auto/corelib/ipc/qsharedmemory/tst_qsharedmemory.cpp(630)]
SKIP : tst_QSharedMemory::attachTooMuch(SystemV-Q) disabled
Loc: [/tmp/guix-build-qtbase-6.6.3.drv-0/qtbase-everywhere-src-6.6.3/tests/auto/corelib/ipc/qsharedmemory/tst_qsharedmemory.cpp(630)]
SKIP : tst_QSharedMemory::attachTooMuch(SystemV-T) disabled
Loc: [/tmp/guix-build-qtbase-6.6.3.drv-0/qtbase-everywhere-src-6.6.3/tests/auto/corelib/ipc/qsharedmemory/tst_qsharedmemory.cpp(630)]