[PATCH] gnu: Add pantheon-icons.

  • Open
  • quality assurance status badge
Details
One participant
  • altadil
Owner
unassigned
Submitted by
altadil
Severity
normal
A
A
altadil wrote on 13 Sep 13:52 +0200
(address . guix-patches@gnu.org)(name . altadil)(address . altadil@protonmail.com)
20240913115216.29824-1-altadil@protonmail.com
* gnu/packages/pantheon.scm (pantheon-icons): New variable.

Change-Id: I52b1a1f972964497d0a31727742b83cb0a26b0e4
---
guix build --no-grafts --check --rounds=2 ran successfully for
--system=x86_64-linux and aarch64-linux.
gnu/packages/pantheon.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 9268aff292..1c01893a03 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -196,6 +196,34 @@ (define-public pantheon-calendar
elementary OS.")
(license license:gpl3)))
+(define-public pantheon-icons
+ (package
+ (name "pantheon-icons")
+ (version "8.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elementary/icons")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04riisdq3fq6n7m0p0l0zq48np2sfwahi9f4xx471y7p9n091y8h"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-Dvolume_icons=false"
+ "-Dpalettes=false")))
+ (native-inputs (list gettext-minimal ;for msgfmt
+ librsvg
+ xcursorgen))
+ (propagated-inputs (list hicolor-icon-theme))
+ (synopsis "Named, vector icons for the pantheon desktop")
+ (description
+ "pantheon-icons is an original set of vector icons designed
+for elementary OS and its desktop environment: Pantheon.")
+ (home-page "https://elementary.io/open-source")
+ (license license:gpl3)))
+
(define-public pantheon-photos
(package
(name "pantheon-photos")
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73226@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73226
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch