[PATCH] gnu: Add go-github-com-jlaffaye-ftp.

  • Done
  • quality assurance status badge
Details
2 participants
  • Artyom V. Poptsov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 6 months ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
80457016560ad99aced6b7138b08020e845050fb.1726176920.git.poptsov.artyom@gmail.com
* gnu/packages/golang-web.scm (go-github-com-jlaffaye-ftp): New variable.

Change-Id: I51dca96f5a3f224eb96feda1196bf18d0c174633
---
gnu/packages/golang-web.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 2ff362fd8c..73a5bff348 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2528,6 +2528,30 @@ (define-public go-github-com-jhillyerd-enmime
geared towards parsing MIME encoded emails.")
(license license:expat)))
+(define-public go-github-com-jlaffaye-ftp
+ (package
+ (name "go-github-com-jlaffaye-ftp")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jlaffaye/ftp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0z9d1dxhx351158a22a08qbnfql7a1cajg6v3zm82m2rnp17ahir"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/jlaffaye/ftp"))
+ (native-inputs (list go-github-com-stretchr-testify))
+ (propagated-inputs (list go-github-com-hashicorp-go-multierror))
+ (home-page "https://github.com/jlaffaye/ftp")
+ (synopsis "FTP client package for Go")
+ (description "A File Transfer Protocol (FTP) client package for Go")
+ (license license:isc)))
+
(define-public go-github-com-jmespath-go-jmespath
(package
(name "go-github-com-jmespath-go-jmespath")

base-commit: 98bc13b9ea5f22a60de6c289d59072638001e08e
--
2.46.0
Sharlatan Hellseher wrote 6 months ago
(address . 73213-done@debbugs.gnu.org)
878qvrb7it.fsf@gmail.com
Hi,

Pushed as 3bcdb6a92e2ed49a4a0b290288e2bf052eddae57 to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmbopioACgkQdtcnv/Ys
0rUsqxAAqapktt/OT02iGRrgqhS/rbQoiYkoEDPOCGvbMs3/aH6HrAfVt7hhKaZN
bIz0HlDfR4G5pAios03+fI8/cf+gTp95/F54fXKG2mwZkZVm/5OncvLVp9/henSj
MU6ZPpEldcZ0WmLBJ+vK05Z2OeFL6hDnBLZu34+5+TIyFQVPNj/sgngyBXoJkPd2
Ju1CeZ/Sd1dRkxwiUwcsji+fwIPgNS9p00e2XOkSGEljIClBF0+RcWjrSPKIad2v
QbTR1ZosdQvB2iAiaLpuSldzdh1b+BClvLONfF3NXX4CpSdFbbYxdDyykvuIKNTX
dhtHFHQ5moxTrq625PQPAmUr5l7XiHv3nXUgbQdYgXlnRzrJLcqpasrdbt6FPpct
uZ/W7bYRgZtCmxbwx4XZnntpNW4UTJLOpfvsqgJSG2Nhq7lg2wNgXdzWIVClpQXs
QwSPGWXz1owZlubWG3VuyMG4jiV3zrQ0TIKIRT48P8+gn7IiLnoiYc0fo0U2SoPL
QZeezlX1qKDbmlwxtZqd1pKgxNWBrgto7nlPSKMsbqWjd6kBT6rKxD2sfmq6Pyda
Lad414utGzAZVmjDG88Qn1lgYz1wGZGwMB3jNCOwqtIqryvSg1cLgYEpDLb60e2R
8fP25ZlO6ETYRDnszExI0eoUlIlGq2h9ZM6E51IzQhfR1nP/GpM=
=568Q
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73213@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73213
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help