[PATCH 0/5] Add some Golang libraries from the "awesome-go" list

  • Done
  • quality assurance status badge
Details
2 participants
  • Artyom V. Poptsov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal
A
A
Artyom V. Poptsov wrote on 11 Sep 21:21 +0200
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cover.1726082409.git.poptsov.artyom@gmail.com
This patchset adds some Golang libraries from "awesome-go" list:

Artyom V. Poptsov (5):
gnu: Add go-github-com-tannerryan-ring.
gnu: Add go-github-com-philhofer-fwd.
gnu: Add go-github-com-tinylib-msgp.
gnu: Add go-github-com-workiva-go-datastructures.
gnu: Add go-github-com-liyue201-gostl.

gnu/packages/golang-xyz.scm | 159 ++++++++++++++++++++++++++++++++++++
1 file changed, 159 insertions(+)


base-commit: b46256b162e15420bb034a9e6d65ec46f1c03343
--
2.46.0
A
A
Artyom V. Poptsov wrote on 11 Sep 21:23 +0200
[PATCH 1/5] gnu: Add go-github-com-tannerryan-ring.
(address . 73184@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
647461c70212e4fce554618fccf2b5e85cffa473.1726082409.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-tannerryan-ring): New variable.

Change-Id: I14d280d6af0dd25ee8b2bd1a7565640223fdbe21
---
gnu/packages/golang-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c2059b7906..037cef32db 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6309,6 +6309,30 @@ (define-public go-github-com-syndtr-goleveldb
storage system.")
(license license:bsd-2)))
+(define-public go-github-com-tannerryan-ring
+ (package
+ (name "go-github-com-tannerryan-ring")
+ (version "1.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tannerryan/ring")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07q5qcg2wv696nnw3rrgc49mqijapdwp3xsscaxb5867bz79s841"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/tannerryan/ring"))
+ (home-page "https://github.com/tannerryan/ring")
+ (synopsis "High performance bloom filter")
+ (description
+ "@code{ring} provides a high performance and thread safe Go implementation of a
+@url{https://en.wikipedia.org/wiki/Bloom_filter, bloom filter}.")
+ (license license:bsd-2)))
+
(define-public go-github-com-teambition-rrule-go
(package
(name "go-github-com-teambition-rrule-go")
--
2.46.0
A
A
Artyom V. Poptsov wrote on 11 Sep 21:23 +0200
[PATCH 2/5] gnu: Add go-github-com-philhofer-fwd.
(address . 73184@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
b080793c762e4c6abcc128f2e10c80fc630e0c87.1726082409.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-philhofer-fwd): New variable.

Change-Id: I2ec89e3f6d9bd98fcde14ccb70d7373cafca38ff
---
gnu/packages/golang-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 037cef32db..89751e8fcb 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -5676,6 +5676,30 @@ (define-public go-github-com-pelletier-go-toml-v2
(list go-github-com-stretchr-testify))
(propagated-inputs '())))
+(define-public go-github-com-philhofer-fwd
+ (package
+ (name "go-github-com-philhofer-fwd")
+ (version "1.1.3-0.20240612014219-fbbf4953d986")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/philhofer/fwd")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vq27qy4sbbv316kb3jmf7np3iq6d4gq99gd53jcm2giabbqvgm5"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/philhofer/fwd"))
+ (home-page "https://github.com/philhofer/fwd")
+ (synopsis "Buffered reader/writer")
+ (description
+ "Package @code{fwd} provides a buffered reader and writer. Each has methods
+that help improve the encoding/decoding performance of some binary protocols.")
+ (license license:expat)))
+
(define-public go-github-com-pierrec-cmdflag
(package
(name "go-github-com-pierrec-cmdflag")
--
2.46.0
A
A
Artyom V. Poptsov wrote on 11 Sep 21:23 +0200
[PATCH 3/5] gnu: Add go-github-com-tinylib-msgp.
(address . 73184@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
2f7c95ff969416acfee70e439536fb941a60ad49.1726082409.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-tinylib-msgp): New variable.

Change-Id: I278d2d249029c9eb5f8eddb82007e9a22d65a9bc
---
gnu/packages/golang-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 89751e8fcb..eb04ff639b 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6529,6 +6529,33 @@ (define-public go-github-com-tidwall-sjson
document.")
(license license:expat)))
+(define-public go-github-com-tinylib-msgp
+ (package
+ (name "go-github-com-tinylib-msgp")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tinylib/msgp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mplb420i9cmf40qwsqzd1plln52nl0x0b7nkxffyr0pdh9za79a"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/tinylib/msgp"))
+ (propagated-inputs
+ (list go-github-com-philhofer-fwd
+ go-golang-org-x-tools))
+ (home-page "https://github.com/tinylib/msgp")
+ (synopsis "Go code generator for MessagePack")
+ (description
+ "This is a code generation tool and serialization library for
+@url{http://msgpack.org/, MessagePack}.")
+ (license license:expat)))
+
(define-public go-github-com-tklauser-go-sysconf
(package
(name "go-github-com-tklauser-go-sysconf")
--
2.46.0
A
A
Artyom V. Poptsov wrote on 11 Sep 21:23 +0200
[PATCH 5/5] gnu: Add go-github-com-liyue201-gostl.
(address . 73184@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
dae40959ae03f5e2786186b3d418c3e2cde58a27.1726082409.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-liyue201-gostl): New variable.

Change-Id: I6abdb2f1ca4bd5e53c2b5a72214dcd5b34cbf20d
---
gnu/packages/golang-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 7cad8c7e94..2046e9d1d7 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4251,6 +4251,39 @@ (define-public go-github-com-libp2p-go-msgio
length-delimited slices. It's helpful for building wire protocols.")
(license license:expat)))
+(define-public go-github-com-liyue201-gostl
+ (package
+ (name "go-github-com-liyue201-gostl")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/liyue201/gostl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dxzh791agir21dp1jmfa1bvqc23byz93fx3jlm94brlgm9zdkd3"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/liyue201/gostl"
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
+ (native-inputs (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/liyue201/gostl")
+ (synopsis "Data structure and algorithm library for Go")
+ (description
+ "@code{gostl} is a data structure and algorithm library for Go, designed to
+provide functions similar to C++ STL.")
+ (license license:expat)))
+
(define-public go-github-com-logrusorgru-aurora
(package
(name "go-github-com-logrusorgru-aurora")
--
2.46.0
A
A
Artyom V. Poptsov wrote on 11 Sep 21:23 +0200
[PATCH 4/5] gnu: Add go-github-com-workiva-go-datastructures.
(address . 73184@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
273c37819556c45cc9b9ce2b68e326e39031ed53.1726082409.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-workiva-go-datastructures): New variable.

Change-Id: I1523c7aeaed0910fbfbfe7fc96566684fdd2dab8
---
gnu/packages/golang-xyz.scm | 51 +++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index eb04ff639b..7cad8c7e94 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6789,6 +6789,57 @@ (define-public go-github-com-whyrusleeping-go-sysinfo
@code{MemoryInfo}.")
(license license:expat)))
+(define-public go-github-com-workiva-go-datastructures
+ (package
+ (name "go-github-com-workiva-go-datastructures")
+ (version "1.1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Workiva/go-datastructures")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09k5zg0ma8z5bcfwk3viccaxzrrk5pyfhk5hkr9x34vgcnlk0jx7"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/Workiva/go-datastructures"))
+ (native-inputs (list go-github-com-stretchr-testify))
+ (propagated-inputs (list go-github-com-tinylib-msgp))
+ (home-page "https://github.com/Workiva/go-datastructures")
+ (synopsis "Collection of Go data structures")
+ (description
+ "@code{go-datastructures} is a collection of useful, performant, and thread-safe
+Go data structures.
+
+It includes:
+@itemize
+@item Augmented Tree
+@item Bitarray
+@item Futures
+@item Queue
+@item Fibonacci Heap
+@item Range Tree
+@item Set
+@item Threadsafe
+@item AVL Tree
+@item X-Fast Trie
+@item Y-Fast Trie
+@item Fast Integer Hashmap
+@item Skiplist
+@item Sort
+@item Numerics
+@item B+ Tree
+@item Immutable B Tree
+@item Ctrie
+@item Dtrie
+@item Persistent List
+@item Simple Graph
+@end itemize")
+ (license license:asl2.0)))
+
(define-public go-github-com-xhit-go-str2duration-v2
(package
(name "go-github-com-xhit-go-str2duration-v2")
--
2.46.0
S
S
Sharlatan Hellseher wrote on 16 Sep 23:41 +0200
[PATCH 0/5] Add some Golang libraries from the "awesome-go" list
(address . 73184@debbugs.gnu.org)
87bk0nb7ju.fsf@gmail.com
Hi,

I've pushed 2 of 3 preposed patches, some of them are already on
go-team, sorry if missed them in first place.

- patches [5/5]
- [X] [PATCH 1/5] gnu: Add go-github-com-tannerryan-ring.
- Applied on master
- [X] [PATCH 2/5] gnu: Add go-github-com-philhofer-fwd.
It's already on go-team
- [X] [PATCH 3/5] gnu: Add go-github-com-tinylib-msgp.
It's already on go-team
- [X] [PATCH 4/5] gnu: Add go-github-com-workiva-go-datastructures.
Pending for go-team merge or may be applied on it,
- [X] [PATCH 5/5] gnu: Add go-github-com-liyue201-gostl.
- Applied on master

Feel free to rebase on go-team and push missing ones or wait when
go-team is merged (hope soon).

Pushed 2 as 58405cbe3a..bee20255f7 to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmbopgUACgkQdtcnv/Ys
0rXEtBAAijlXSZVWds3ViBmgY7OQJx/LaJa18UZZP4Loly529tHwkzR+XGi6QkQj
dmN3fe71pHStXIKzK4zaJqWRKLAsQXChsTxYy+znkmDTNaUO/HhF8X78Abag1tR7
oq9E/0ZKbE0Faztyt6onxitsACY+iaWJem9ktmqfZTT34cjr7S/RmSoJsNoh18zn
NY2OfzdcHeaHNeSjjo+lFUDwBIiEFE9GW0nTn1FYugueIIEz5P92xM/KFpRtwnen
mwVmLAHWfhSgnWMoi2UA5l4QRlA7Q2GlaXDBjYiwFMYgNmN1ngDaFyxR5v7tc5nZ
UzTGVJMfQudzd9TU1+akgEqIu+u5q4tMUuqD1RzxZ2PgH85e5G+tNeG0ohogGY3V
qzzA0YI9fBc+3z0O9h1M6UvdmJQDgiDHIGhvcBoxTXyoFwdk1G4/Gkp6jUkGFy4d
EXKUUDQfBYRdu/z86k4+QGAEBmiIXk+rJmzZYfNLJznnSLLwH2RjjS3T7Bl3CgEG
4WadHHzbwscK8unK+o+F5w1CvssfsSullveRmF2Spm2AdVC2Zh0DHZ6+uJXa9Zvp
2zU2HCjUmkr+h0XDdr5NlohWGjFCNju6O7pIJudV1YeaPVBT2AbomXQkGpWRLQ+a
CSfNSXGimlYPsB7eMackiZeCebr0kJKSeQ5vEdtpPNEsSXkZDbM=
=f4op
-----END PGP SIGNATURE-----

S
S
Sharlatan Hellseher wrote on 21 Sep 16:25 +0200
(address . 73184-done@debbugs.gnu.org)
87tte9axtj.fsf@gmail.com
Hi,

I've extend tests and description for
go-github-com-workiva-go-datastructures and pushed as 776edb9c8d to
go-team.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmbu10gACgkQdtcnv/Ys
0rXQow//XvkeWstJQsWzHT2vCfViDzmUQek6xzUK+gFhX6y60KAdeOMvCM3o/hJR
nlNrFgx9iMRnM+8U8g0egLz8sOXRXpQ6UGMnva6or801bjaf7aeWHGdBFA46mplV
NVIPh7uMw1E5pPjjuIvk3lRJRLyUN3AkYiSeqLlpQXZJliUvb0p0dHgmb5Bjfuwz
LhMxRVNHGQi1y+Sipkae+YZhPwPzy919DNfcEXpE+622XvNHApMneOfeWwipsdoF
e6FXnNxJSRIa0MZTD2BaAWvixV/MJRB/QcoEbB0tHGcbmDCJENxyiKajP44+6A3N
z6PhL2virMqwe0aWOrD9BYgnE33axlRDJ8vCNoqFz1LRWceEg2BuNvLh/gaVzxhR
O22pOjpenBFcPpdI4P099VqGOBv5CDWqkeVPfVvjp/i9LuqAfnrFX3VKPzk48vI6
5evYHlPLkMLl9vtIwTmphvg6SXTONUZWMbwxVortJ45qFBGwgnMl0nOpnTu3bizK
EOv2ZM2vNJJ/uNFCh6fOmj68G7FjTgiOSCTxUn77o16uya3NWh0cBiXp2ppjWCZi
y8IkOoSeiif5ZGMCCz8jEAoKYB6g2fvaT5xBidG2Dso6GqsmoaV4peZIbRpF/uyt
F0/u5wGq6Ucc0NvxiM2wUz6dEq7pns6A+cvF0ITEIu4lESP+H68=
=RNaW
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73184@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73184
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch