[PATCH 0/2] Remove lablgtk.

  • Done
  • quality assurance status badge
Details
One participant
  • Josselin Poiret
Owner
unassigned
Submitted by
Josselin Poiret
Severity
normal
J
J
Josselin Poiret wrote on 11 Sep 15:35 +0200
(address . guix-patches@gnu.org)(name . Josselin Poiret)(address . dev@jpoiret.xyz)
cover.1726058997.git.dev@jpoiret.xyz
This patch series removes lablgtk, as it's actually not needed for any of our
leaf packages.

Josselin Poiret (2):
gnu: ocaml-cairo2: Only build cairo2 package, remove unneeded deps.
gnu: lablgtk: Remove variable.

gnu/packages/ocaml.scm | 72 ++----------------------------------------
1 file changed, 3 insertions(+), 69 deletions(-)


base-commit: b6d5a7f5836739dab884b49a64ca354794dd845f
--
2.45.2
J
J
Josselin Poiret wrote on 11 Sep 18:02 +0200
[PATCH 1/2] gnu: ocaml-cairo2: Only build cairo2 package, remove unneeded deps.
(address . 73179@debbugs.gnu.org)(name . Josselin Poiret)(address . dev@jpoiret.xyz)
2e379751126e2a3fb01c6af53183f30b107bb667.1726058997.git.dev@jpoiret.xyz
From: Josselin Poiret <dev@jpoiret.xyz>

* gnu/packages/ocaml.scm (ocaml-cairo2): Only build cairo2 and not other ocaml
packages alongside. Remove unneeded dependencies gtk+-2 and lablgtk.

Change-Id: I46a026cf0ed26789a590a889d2db47f32b9a97c8
---
gnu/packages/ocaml.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 6ba5f5e374..804c51c5b0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8404,10 +8404,10 @@ (define-public ocaml-cairo2
(base32
"06ag9b88ihhr7yd3s9l0ac7ysig02fmlmsswybbsvz71ni0mb105"))))
(build-system dune-build-system)
+ (arguments
+ (list #:package "cairo2"))
(inputs
- `(("cairo" ,cairo)
- ("gtk+-2" ,gtk+-2)
- ("lablgtk" ,lablgtk)))
+ `(("cairo" ,cairo)))
(native-inputs
(list pkg-config))
(home-page "https://github.com/Chris00/ocaml-cairo")
--
2.45.2
J
J
Josselin Poiret wrote on 11 Sep 18:02 +0200
[PATCH 2/2] gnu: lablgtk: Remove variable.
(address . 73179@debbugs.gnu.org)(name . Josselin Poiret)(address . dev@jpoiret.xyz)
3764d618c00972d6c1c7e6914df9170cf32330ee.1726058997.git.dev@jpoiret.xyz
From: Josselin Poiret <dev@jpoiret.xyz>

* gnu/packages/ocaml.scm (lablgtk): Package is no longer used as a dependency.

Change-Id: I7e3d1e5c0bd65a4938b0e08012094603d9d55cc5
---
gnu/packages/ocaml.scm | 66 ------------------------------------------
1 file changed, 66 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 804c51c5b0..9d29105cdb 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1404,72 +1404,6 @@ (define-public ocaml-bigarray-compat
@code{Stdlib.Bigarray} in OCaml.")
(license license:isc)))
-(define-public lablgtk
- (package
- (name "lablgtk")
- (version "2.18.11")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/garrigue/lablgtk")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "179ipx0c6bpxm4gz0syxgqy09dp5p4x9qsdil7s9jlx8ffg1mm0w"))))
- (build-system gnu-build-system)
- (native-inputs
- (list ;; Build failure with make-4.4, so we use make-4.2.
- ;; See <https://github.com/garrigue/lablgtk/issues/170>.
- gnu-make-4.2
- ocaml
- ocaml-findlib
- pkg-config))
- ;; FIXME: Add inputs gtkgl-2.0, libpanelapplet-2.0, gtkspell-2.0,
- ;; and gtk+-quartz-2.0 once available.
- (inputs
- (list gtk+-2
- gtksourceview-2
- libgnomecanvas
- libgnomeui
- libglade
- (librsvg-for-system)))
- (arguments
- `(#:tests? #f ; no check target
-
- ;; opt: also install cmxa files
- #:make-flags (list "all" "opt"
- (string-append "FINDLIBDIR="
- (assoc-ref %outputs "out")
- "/lib/ocaml"))
- ;; Occasionally we would get "Error: Unbound module GtkThread" when
- ;; compiling 'gtkThInit.ml', with 'make -j'. So build sequentially.
- #:parallel-build? #f
-
- #:phases
- (modify-phases %standard-phases
- (add-before 'install 'prepare-install
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (ocaml (assoc-ref inputs "ocaml")))
- ;; Install into the output and not the ocaml directory.
- (mkdir-p (string-append out "/lib/ocaml"))
- (substitute* "config.make"
- ((ocaml) out))
- #t))))))
- (home-page "http://lablgtk.forge.ocamlcore.org/")
- (synopsis "GTK+ bindings for OCaml")
- (description
- "LablGtk is an OCaml interface to GTK+ 1.2 and 2.x. It provides
-a strongly-typed object-oriented interface that is compatible with the
-dynamic typing of GTK+. Most widgets and methods are available. LablGtk
-also provides bindings to
-gdk-pixbuf, the GLArea widget (in combination with LablGL), gnomecanvas,
-gnomeui, gtksourceview, gtkspell,
-libglade (and it an generate OCaml code from .glade files),
-libpanel, librsvg and quartz.")
- (license license:lgpl2.1)))
-
(define-public binsec
(package
(name "binsec")
--
2.45.2
J
J
Josselin Poiret wrote on 12 Oct 11:55 +0200
Re: [PATCH 1/2] gnu: ocaml-cairo2: Only build cairo2 package, remove unneeded deps.
(address . 73179-done@debbugs.gnu.org)
87jzedhci2.fsf@jpoiret.xyz
Merged as a531af142ffdb2a31cf9e6258c336fcf2dbe755b.

Josselin Poiret <dev@jpoiret.xyz> writes:

Toggle quote (32 lines)
> From: Josselin Poiret <dev@jpoiret.xyz>
>
> * gnu/packages/ocaml.scm (ocaml-cairo2): Only build cairo2 and not other ocaml
> packages alongside. Remove unneeded dependencies gtk+-2 and lablgtk.
>
> Change-Id: I46a026cf0ed26789a590a889d2db47f32b9a97c8
> ---
> gnu/packages/ocaml.scm | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index 6ba5f5e374..804c51c5b0 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -8404,10 +8404,10 @@ (define-public ocaml-cairo2
> (base32
> "06ag9b88ihhr7yd3s9l0ac7ysig02fmlmsswybbsvz71ni0mb105"))))
> (build-system dune-build-system)
> + (arguments
> + (list #:package "cairo2"))
> (inputs
> - `(("cairo" ,cairo)
> - ("gtk+-2" ,gtk+-2)
> - ("lablgtk" ,lablgtk)))
> + `(("cairo" ,cairo)))
> (native-inputs
> (list pkg-config))
> (home-page "https://github.com/Chris00/ocaml-cairo")
> --
> 2.45.2
>

--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCAAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmcKR3UQHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5FhcaiujhC/4ulskz3k8Tmv9AIfMiRRvnJmmcS5u2HFMB
J6BlHf765UpKHd9G1tYCaLlNdUKF0QDqZMbtvzp8IxMCBOh8qyH/1zXtfQRcDOkK
rkFQowxpd7ZyasLhdaj4marBwfeUDwHVtn5lnULK6lTLY35gvcuwAUerF7A18MTK
p9XIEApCWZCf0N4jelEUexj0JcusdzGqYUh8huEG/jRa1IyECWwez2+XStud0uSh
lquz7XAzL4Weojhq0Yd6KEF9NWPcUN2an+O/ZQxd0XxEdatcsda6aBtqh6IU98mf
ZbfEo+3OxA0x8ZPXaNyauIEGidYElQ6lP192nGFcBIxszFeP/OaCeRmh9kw0DFOb
GaFIFvHGmO66qpwTAPpfV0XpHCNGF+ZxPxXIR4zEexIhuYgRnbIbJYYTDCV1XZXK
u0xk6n7tZnetirwXekVcsaEe8rF05ecQjHnpo4pbCRH9r88ljKVWc8Il6xFDgXcd
TP75ifXkfgeLNO+wAOwYsR1IxGing3I=
=c8DY
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73179@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73179
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch