[PATCH] gnu: go-1.20: Build with gccgo-12 on some systems.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 11 Sep 12:04 +0200
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
3b84788fb81704ab8ee1d325f51e0570c00cc6a1.1726047022.git.efraim@flashner.co.il
* gnu/packages/golang.scm (go-1.20)[native-inputs]: Don't replace the
gccgo input on architectures bootstrapping go with it.

Change-Id: I26831b2bcfe623f6eb0ac7c16b463e5e873110e6
---

This should only cause rebuilds on riscv64 and ppc64le.

gnu/packages/golang.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9f04b8e4232..95aca837ffc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016-2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016-2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
;;; Copyright © 2016 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2016, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
@@ -811,7 +811,10 @@ (define-public go-1.20
;; See 'src/cmd/dist/notgo117.go' in the source code distribution,
;; as well as the upstream discussion of this topic:
;; https://go.dev/issue/44505
- (alist-replace "go" (list go-1.17) (package-native-inputs go-1.17)))))
+ ;; We continue to use gccgo-12 since it provides go-1.18.
+ (if (member (%current-system) (package-supported-systems go-1.4))
+ (alist-replace "go" (list go-1.17) (package-native-inputs go-1.17))
+ (package-native-inputs go-1.17)))))
(define-public go-1.21
(package

base-commit: b6d5a7f5836739dab884b49a64ca354794dd845f
--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
S
S
Sharlatan Hellseher wrote on 12 Sep 16:32 +0200
(address . 73176-done@debbugs.gnu.org)
875xr1lz6v.fsf@gmail.com
Hi,

Pushed as d893d040478f07fbfb08e0ff18549ab4215dcca2 to go-team.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmbi+5kACgkQdtcnv/Ys
0rXoMA/+KdSxVLYn1raGfeaQ8eAqRnT2t/Xlqxz+QNps0YX+aPgaeHz/hoLFECho
rrGzwkPb154Td1mIQ+ENFuoT0KgvLIaH80yat6PYzgNA3j22BrBxbqV4WF30Z3KQ
tnHtfKV6IdH9YbdC1iyUlB3LTMAwbbxX7KUAjY5rY0Hkwy0Mz5B9wNbaBfgrwhsq
DeZXgx4OhBZl+mp5GsNjMBCU1bKaIJ7F2CFErukKOt7dQT4i2HpUHFLwi10EWbM2
+SrWR0YOc/peoArOKgpcvs2PBpc7gGMDj3jPxhVaxH4wB2Vuin12A2JAZARgpvt6
Mx5K7MVf3QwPN7LxPmcM3AQKAjajIUNTMBDJuAafFpAc8rruNsgs+4mUuWAGtGUz
zVLoI75knjJripasSrhjH8Ldxd1SP8zxbjC0b97XNJqJ2NRHLEGhSqYk/EncmtlL
AiB183px5x3IQRvaIktkigj9l1oQUagxY4s7iWUjOc81ZEgW2mFhVuoWEoiIEBl4
K53W+QJJPj+MyAUPTbaRc+B96hs7teieERIN4BqPdOpydql+ihI3wk1R0v4uW/1A
xY/wnNvFS10za12l9AqVp0k5C3fqBBWGH9ZE9DsEoYJLgnswWu5VBlCj+6cTFrpg
qngeQi5Cpb5M8OfJI6VpMSW9/BgpI4YpWwUJHV3U8ZPlGu7PP80=
=yVkU
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73176@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73176
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch