(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
* gnu/packages/golang.scm (go-1.20)[native-inputs]: Don't replace the
gccgo input on architectures bootstrapping go with it.
Change-Id: I26831b2bcfe623f6eb0ac7c16b463e5e873110e6
---
This should only cause rebuilds on riscv64 and ppc64le.
gnu/packages/golang.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)
Toggle diff (29 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9f04b8e4232..95aca837ffc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016-2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016-2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
;;; Copyright © 2016 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2016, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
@@ -811,7 +811,10 @@ (define-public go-1.20
;; See 'src/cmd/dist/notgo117.go' in the source code distribution,
;; as well as the upstream discussion of this topic:
;; https://go.dev/issue/44505
- (alist-replace "go" (list go-1.17) (package-native-inputs go-1.17)))))
+ ;; We continue to use gccgo-12 since it provides go-1.18.
+ (if (member (%current-system) (package-supported-systems go-1.4))
+ (alist-replace "go" (list go-1.17) (package-native-inputs go-1.17))
+ (package-native-inputs go-1.17)))))
(define-public go-1.21
(package
base-commit: b6d5a7f5836739dab884b49a64ca354794dd845f
--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted