From 1df4a966abce35fc8841843e45c942682dc153f5 Mon Sep 17 00:00:00 2001
Message-ID: <1df4a966abce35fc8841843e45c942682dc153f5.1726007239.git.pirata@gmail.com>
* gnu/packages/ruby.scm (ruby-net-smpt): Fix check phase.
The tests where failing due to the SSL certificate being used
expired. Regenerate the certificate running the check phase.
Change-Id: I8bd72f2e929f496996f6fd88b13a4d95837273da
---
gnu/packages/ruby.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)
Toggle diff (42 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5af1bb1cef..c401a8eab3 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -102,6 +102,7 @@ (define-module (gnu packages ruby)
#:use-module (guix modules)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
+ #:use-module ((guix build utils) #:select (with-directory-excursion))
#:use-module (gnu packages xml)
#:use-module (gnu packages web)
#:use-module (guix build-system ruby)
@@ -4722,6 +4723,25 @@ (define-public ruby-net-smtp
(base32
"0ca2wh45xvc09rv6v6sz3vbnkzrjzk5c4l6dk50zk4dwxvghma8r"))))
(build-system ruby-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'regenerate-certificate
+ ;; On version 0.5.0 a Makefile was introduced to regenerated the
+ ;; certificates, and instead of calling openssl directory we could
+ ;; do (with-directory-excursion "test/net/fixtures" (invoke "make"
+ ;; "regen_certs"). However the certificate is expired versions before 0.5.0 as well.
+ (lambda _
+ (with-directory-excursion "test/net/fixtures"
+ (invoke "openssl" "req" "-new" "-key" "server.key" "-out" "server.csr" "-subj"
+ "/C=JP/ST=Shimane/O=Ruby Core Team/OU=Ruby Test/CN=localhost")
+ (invoke "openssl" "req" "-new" "-x509" "-days" "3650" "-key" "server.key" "-out" "cacert.pem" "-subj"
+ "/C=JP/ST=Shimane/L=Matz-e city/O=Ruby Core Team/CN=Ruby Test CA/emailAddress=security@ruby-lang.org")
+ (invoke "openssl" "x509" "-days" "3650" "-CA" "cacert.pem" "-CAkey"
+ "server.key" "-set_serial" "00" "-in" "server.csr" "-req" "-out" "server.crt")
+ (invoke "rm" "server.csr"))
+)))))
+ (inputs (list openssl))
(propagated-inputs (list ruby-net-protocol))
(synopsis "Simple Mail Transfer Protocol client library for Ruby")
(description "This library provides functionality to send Internet mail
base-commit: 7f05b73d90f740c6a139f0e706b717d3174f6321
--
2.45.2