[PATCH] gnu: ddd: Update to 3.4.1.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andy Tai
  • Ludovic Courtès
  • Simon Tournier
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 6 months ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
b0760ae63d9ea43a6ff6bac6557cfbc2c59437aa.1725863812.git.atai@atai.org
* gnu/packages/debug.scm (ddd): Update to 3.4.1.
[source](origin): Add new patch to fix build.
[arguments]<#:configure-flags>: Add explicit flag fir freetype
include path.
[native-inputs]: Add bison, flex and perl.
[inputs]: Add freetype, libxaw, and libxft.
* gnu/packages/patches/ddd-build.patch: New file.
* gnu/local.mk: Register new file.

Change-Id: Ic305cc0c7e15d0f0565f2adde514a43497e11f98
---
gnu/local.mk | 1 +
gnu/packages/debug.scm | 18 ++++++++++--------
gnu/packages/patches/ddd-build.patch | 24 ++++++++++++++++++++++++
3 files changed, 35 insertions(+), 8 deletions(-)
create mode 100644 gnu/packages/patches/ddd-build.patch

Toggle diff (91 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index ed630041ff..dbf8902cd1 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1127,6 +1127,7 @@ dist_patch_DATA = \
%D%/packages/patches/dbus-c++-gcc-compat.patch \
%D%/packages/patches/dbus-c++-threading-mutex.patch \
%D%/packages/patches/dbxfs-remove-sentry-sdk.patch \
+ %D%/packages/patches/ddd-build.patch \
%D%/packages/patches/debops-constants-for-external-program-names.patch \
%D%/packages/patches/debops-debops-defaults-fall-back-to-less.patch \
%D%/packages/patches/dee-vapi.patch \
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index cc8e05746a..dd559c3faf 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -52,6 +52,7 @@ (define-module (gnu packages debug)
#:use-module (gnu packages code)
#:use-module (gnu packages compression)
#:use-module (gnu packages flex)
+ #:use-module (gnu packages fontutils)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gdb)
#:use-module (gnu packages glib)
@@ -1006,23 +1007,24 @@ (define-public seer-gdb
(define-public ddd
(package
(name "ddd")
- (version "3.4.0")
+ (version "3.4.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/ddd/ddd-" version ".tar.gz"))
+ (patches (search-patches "ddd-build.patch"))
(sha256
(base32
- "03sqsfiri5p130cmmzh2wikg0gisql496rvdhr1qaidh1f5bqk2x"))))
+ "12gfyh139rim49m56lxm36ckdyiiz4n3la3y6ik1aqgrqfk1fxdq"))))
(build-system gnu-build-system)
(arguments
- (list #:tests? #f ;tests require manual intervention
- ;; Avoid "friend declaration specifies default arguments and isn’t
- ;; a definition" errors.
- #:configure-flags #~(list "CXXFLAGS=-fpermissive")))
+ (list #:tests? #f ;tests require manual intervention
+ #:configure-flags
+ #~(list (string-append "--with-freetype-includes="
+ #$(this-package-input "freetype") "/include/freetype2"))))
(native-inputs
- (list pkg-config))
+ (list pkg-config bison flex perl))
(inputs
- (list motif ncurses gdb))
+ (list libxaw libxft freetype motif ncurses gdb))
(synopsis "Graphical front-end for GDB and other debuggers")
(description "GNU DDD, the Data Display Debugger, is a graphical front-end
for command-line debuggers. Many back-end debuggers are supported, notably
diff --git a/gnu/packages/patches/ddd-build.patch b/gnu/packages/patches/ddd-build.patch
new file mode 100644
index 0000000000..d172e47168
--- /dev/null
+++ b/gnu/packages/patches/ddd-build.patch
@@ -0,0 +1,24 @@
+Index: ddd/Makefile.am
+===================================================================
+--- old/ddd/Makefile.am (revision 7508)
++++ new/ddd/Makefile.am (working copy)
+@@ -655,7 +655,7 @@
+ LIBXFT = @XFT_LIBS@ -lfontconfig
+
+ # Freetype2 headers
+-XFTINCLUDE = @XFT_INCLUDE@
++XFTINCLUDE = -I@XFT_INCLUDE@
+
+ # X Miscellaneous Utilities needed for Athena and Motif >= 2.0 (lXmu)
+ LIBXMU = @XMU_LIBS@
+--- old/ddd/Makefile.in (revision 7508)
++++ new/ddd/Makefile.in (working copy)
+@@ -1307,7 +1307,7 @@
+ LIBXFT = @XFT_LIBS@ -lfontconfig
+
+ # Freetype2 headers
+-XFTINCLUDE = @XFT_INCLUDE@
++XFTINCLUDE = -I@XFT_INCLUDE@
+
+ # X Miscellaneous Utilities needed for Athena and Motif >= 2.0 (lXmu)
+ LIBXMU = @XMU_LIBS@

base-commit: 056910ec864cb7cf3225a0c27679d94405db7dcd
--
2.34.1
Andy Tai wrote 6 months ago
this-package-input vs. propagated-inputs in package definition
CAJsg1E-j83OyrsiUE=ig_6n8mTkieEvnmMfR7suPOVVa+yd2-w@mail.gmail.com
A question on package definition (likely scope of guix-devel, but
anyway posted here first):

I have updated the definition of package ddd which has libxft as
input. Libxft in turn has freefont as propagated-input. In the
definition of ddd I tried to do

(this-package-input "freefont")

which returns #f.

I had to add freefont as input to ddd to make this work.

As propagated-input should be propagated, shall the addition of
freefont as input to ddd be unneeded?
Simon Tournier wrote 6 months ago
87v7z4r5o7.fsf@gmail.com
Hi,

On Mon, 09 Sep 2024 at 11:27, Andy Tai <atai@atai.org> wrote:

Toggle quote (3 lines)
> I have updated the definition of package ddd which has libxft as
> input. Libxft in turn has freefont as propagated-input.

What do you mean by ’freefont’? libxft reads:

(propagated-inputs
;; xft.pc refers to all these.
(list libxrender
freetype
fontconfig))


Cheers,
simon
Andy Tai wrote 6 months ago
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
CAJsg1E-LRDp1ybv+ZuX52a=3_mfqExZfwnJ4ivTmnUGrT8LeYA@mail.gmail.com
Sorry I meant freetype

On Tue, Sep 10, 2024 at 1:34 AM Simon Tournier <zimon.toutoune@gmail.com> wrote:
Toggle quote (19 lines)
>
> Hi,
>
> On Mon, 09 Sep 2024 at 11:27, Andy Tai <atai@atai.org> wrote:
>
> > I have updated the definition of package ddd which has libxft as
> > input. Libxft in turn has freefont as propagated-input.
>
> What do you mean by ’freefont’? libxft reads:
>
> (propagated-inputs
> ;; xft.pc refers to all these.
> (list libxrender
> freetype
> fontconfig))
>
>
> Cheers,
> simon
Simon Tournier wrote 6 months ago
87ed5ra0sb.fsf@gmail.com
Hi,

On Mon, 09 Sep 2024 at 11:27, Andy Tai <atai@atai.org> wrote:
Toggle quote (11 lines)
> A question on package definition (likely scope of guix-devel, but
> anyway posted here first):
>
> I have updated the definition of package ddd which has libxft as
> input. Libxft in turn has freefont as propagated-input. In the
> definition of ddd I tried to do
>
> (this-package-input "freefont")
>
> which returns #f.

I think that’s expected. ’this-package-input’ searches only in the list
of ’inputs’ and ’propagated-inputs’ of the package itself and not of the
inputs. Somehow, it’s not recursive and “freetype” is not an “inputs”
of the package ddd.

BTW, I am not sure to understand what mean a propagated-inputs in the
context of a build. I mean, it sounds at run-time, not build-time. No?
Do I miss something?

Toggle quote (2 lines)
> I had to add freefont as input to ddd to make this work.

BTW, for the package ddd, is freetype an input or also a
propagated-input ?


Toggle quote (3 lines)
> As propagated-input should be propagated, shall the addition of
> freefont as input to ddd be unneeded?

Well, for sure, considering the current implementation, you cannot reach
the propagated-inputs of the inputs using this-package-inputs.


Cheers,
simon
Andy Tai wrote 6 months ago
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
CAJsg1E8Xt0VKi3V2JBNrMbT0RSuaEG5j5zPwbws+xwwXyhTRgQ@mail.gmail.com
OK I don't know if this is "implementation detail" or a bug, or is as
intended, that

Toggle quote (2 lines)
>considering the current implementation, you cannot reach the propagated-inputs of the inputs using this-package-inputs.

(seems like a bug to me)

Also, would the same package be in the input list and the
propagated-input list be a problem?

On Fri, Sep 13, 2024 at 7:24 AM Simon Tournier <zimon.toutoune@gmail.com> wrote:
Toggle quote (4 lines)
> > I had to add freefont as input to ddd to make this work.
>
> BTW, for the package ddd, is freetype an input or also a
> propagated-input ?
Simon Tournier wrote 6 months ago
(name . Andy Tai)(address . atai@atai.org)
87ldzmtm1l.fsf@gmail.com
Hi,

On lun., 16 sept. 2024 at 13:51, Andy Tai <atai@atai.org> wrote:
Toggle quote (7 lines)
> OK I don't know if this is "implementation detail" or a bug, or is as
> intended, that
>
>>considering the current implementation, you cannot reach the propagated-inputs of the inputs using this-package-inputs.
>
> (seems like a bug to me)

I do not the see the bug. :-) Somehow ’propagated-inputs’ is a run-time
concept, when ’this-package-input’ is a build-time concept.

Roughly, building a package, seen as a functional view, you have to
explicitly list all the inputs of the function. And there is no hidden
input implicitly attached to one of these inputs.

Somehow, from the point of the package, we list its dependencies and the
package “sees” these dependencies.


Toggle quote (3 lines)
> Also, would the same package be in the input list and the
> propagated-input list be a problem?

Reading the entry for ’propagated inputs’ in the Manual:

Sometimes packages have “propagated inputs”: these are dependencies
that automatically get installed along with the required package
(*note ‘propagated-inputs’ in ‘package’ objects:
package-propagated-inputs, for information about propagated inputs
in package definitions).

An example is the GNU MPC library: its C header files refer to
those of the GNU MPFR library, which in turn refer to those of the
GMP library. Thus, when installing MPC, the MPFR and GMP libraries
also get installed in the profile; removing MPC also removes MPFR
and GMP—unless they had also been explicitly installed by the user.


and following the suggested link:

Lastly, ‘propagated-inputs’ is similar to ‘inputs’, but the
specified packages will be automatically installed to profiles
(*note the role of profiles in Guix: Features.) alongside the
package they belong to (*note ‘guix package’:
package-cmd-propagated-inputs, for information on how ‘guix
package’ deals with propagated inputs).

For example this is necessary when packaging a C/C++ library
that needs headers of another library to compile, or when a
pkg-config file refers to another one via its ‘Requires’
field.

Another example where ‘propagated-inputs’ is useful is for
languages that lack a facility to record the run-time search
path akin to the ‘RUNPATH’ of ELF files; this includes Guile,
Python, Perl, and more. When packaging libraries written in
those languages, ensure they can find library code they depend
on at run time by listing run-time dependencies in
‘propagated-inputs’ rather than ‘inputs’.



In other words, you put the package dependency under ’inputs’ and if the
internal machinery is unable to correctly set the search path, then you
have to manually move the dependency from ’inputs’ to
’propagated-inputs’. If freefont is required run-time by the package
’ddd’ and if the machinery is unable to record search patch, then yes
freefont should be listed under propagated-inputs of ’ddd’.

Maybe I am missing something.

HTH,
simon
Andy Tai wrote 6 months ago
[PATCH v2] gnu: ddd: Update to 3.4.1.
(address . 73137@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
9adbf31b6d3b528e1ce9286483f77996c221a848.1727231148.git.atai@atai.org
* gnu/packages/debug.scm (ddd): Update to 3.4.1.
[source](origin): Add new patch to fix build.
[arguments]<#:configure-flags>: Add explicit flag fir freetype
include path.
[native-inputs]: Add bison, flex and perl.
[inputs]: Add freetype, libxaw, and libxft.
* gnu/packages/patches/ddd-build.patch: New file.
* gnu/local.mk: Register new file.

Change-Id: Ic305cc0c7e15d0f0565f2adde514a43497e11f98
---
gnu/local.mk | 1 +
gnu/packages/debug.scm | 18 ++++++++++--------
gnu/packages/patches/ddd-build.patch | 24 ++++++++++++++++++++++++
3 files changed, 35 insertions(+), 8 deletions(-)
create mode 100644 gnu/packages/patches/ddd-build.patch

Toggle diff (91 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 795ff822a4..29631b0a41 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1129,6 +1129,7 @@ dist_patch_DATA = \
%D%/packages/patches/dbus-c++-gcc-compat.patch \
%D%/packages/patches/dbus-c++-threading-mutex.patch \
%D%/packages/patches/dbxfs-remove-sentry-sdk.patch \
+ %D%/packages/patches/ddd-build.patch \
%D%/packages/patches/debops-constants-for-external-program-names.patch \
%D%/packages/patches/debops-debops-defaults-fall-back-to-less.patch \
%D%/packages/patches/dee-vapi.patch \
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index b8ddafaba6..526d5d408a 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -52,6 +52,7 @@ (define-module (gnu packages debug)
#:use-module (gnu packages code)
#:use-module (gnu packages compression)
#:use-module (gnu packages flex)
+ #:use-module (gnu packages fontutils)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gdb)
#:use-module (gnu packages glib)
@@ -1006,23 +1007,24 @@ (define-public seer-gdb
(define-public ddd
(package
(name "ddd")
- (version "3.4.0")
+ (version "3.4.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/ddd/ddd-" version ".tar.gz"))
+ (patches (search-patches "ddd-build.patch"))
(sha256
(base32
- "03sqsfiri5p130cmmzh2wikg0gisql496rvdhr1qaidh1f5bqk2x"))))
+ "12gfyh139rim49m56lxm36ckdyiiz4n3la3y6ik1aqgrqfk1fxdq"))))
(build-system gnu-build-system)
(arguments
- (list #:tests? #f ;tests require manual intervention
- ;; Avoid "friend declaration specifies default arguments and isn’t
- ;; a definition" errors.
- #:configure-flags #~(list "CXXFLAGS=-fpermissive")))
+ (list #:tests? #f ;tests require manual intervention
+ #:configure-flags
+ #~(list (string-append "--with-freetype-includes="
+ #$(this-package-input "freetype") "/include/freetype2"))))
(native-inputs
- (list pkg-config))
+ (list pkg-config bison flex perl))
(inputs
- (list motif ncurses gdb))
+ (list libxaw libxft freetype motif ncurses gdb))
(synopsis "Graphical front-end for GDB and other debuggers")
(description "GNU DDD, the Data Display Debugger, is a graphical front-end
for command-line debuggers. Many back-end debuggers are supported, notably
diff --git a/gnu/packages/patches/ddd-build.patch b/gnu/packages/patches/ddd-build.patch
new file mode 100644
index 0000000000..d172e47168
--- /dev/null
+++ b/gnu/packages/patches/ddd-build.patch
@@ -0,0 +1,24 @@
+Index: ddd/Makefile.am
+===================================================================
+--- old/ddd/Makefile.am (revision 7508)
++++ new/ddd/Makefile.am (working copy)
+@@ -655,7 +655,7 @@
+ LIBXFT = @XFT_LIBS@ -lfontconfig
+
+ # Freetype2 headers
+-XFTINCLUDE = @XFT_INCLUDE@
++XFTINCLUDE = -I@XFT_INCLUDE@
+
+ # X Miscellaneous Utilities needed for Athena and Motif >= 2.0 (lXmu)
+ LIBXMU = @XMU_LIBS@
+--- old/ddd/Makefile.in (revision 7508)
++++ new/ddd/Makefile.in (working copy)
+@@ -1307,7 +1307,7 @@
+ LIBXFT = @XFT_LIBS@ -lfontconfig
+
+ # Freetype2 headers
+-XFTINCLUDE = @XFT_INCLUDE@
++XFTINCLUDE = -I@XFT_INCLUDE@
+
+ # X Miscellaneous Utilities needed for Athena and Motif >= 2.0 (lXmu)
+ LIBXMU = @XMU_LIBS@

base-commit: 3ac69c1a757430d6dfdd37eb948ba1d6967967cc
--
2.34.1
Ludovic Courtès wrote 5 months ago
(name . Andy Tai)(address . atai@atai.org)(address . 73137-done@debbugs.gnu.org)
87o73zriop.fsf@gnu.org
Hi,

Andy Tai <atai@atai.org> skribis:

Toggle quote (11 lines)
> * gnu/packages/debug.scm (ddd): Update to 3.4.1.
> [source](origin): Add new patch to fix build.
> [arguments]<#:configure-flags>: Add explicit flag fir freetype
> include path.
> [native-inputs]: Add bison, flex and perl.
> [inputs]: Add freetype, libxaw, and libxft.
> * gnu/packages/patches/ddd-build.patch: New file.
> * gnu/local.mk: Register new file.
>
> Change-Id: Ic305cc0c7e15d0f0565f2adde514a43497e11f98

Applied after adding a comment at the top of the patch (see below), as
suggested by ‘guix lint’.

Thanks,
Ludo’.
Toggle diff (12 lines)
diff --git a/gnu/packages/patches/ddd-build.patch b/gnu/packages/patches/ddd-build.patch
index d172e47168..5db2833504 100644
--- a/gnu/packages/patches/ddd-build.patch
+++ b/gnu/packages/patches/ddd-build.patch
@@ -1,5 +1,5 @@
-Index: ddd/Makefile.am
-===================================================================
+Add missing '-I' flag.
+
--- old/ddd/Makefile.am (revision 7508)
+++ new/ddd/Makefile.am (working copy)
@@ -655,7 +655,7 @@
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73137@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73137
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help