[PATCH] Enable parallel tests for GTK

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Maxim Cournoyer
  • The Man
Owner
unassigned
Submitted by
The Man
Severity
normal

Debbugs page

The Man wrote 6 months ago
(address . guix-patches@gnu.org)
CAPfwWagUzJd_v+n2JR=P-yhutJ3VudHeJ+mLeXgKJGaCv3prcw@mail.gmail.com
In the middle of testing a set of patches that caused a large number of
rebuilds, I noticed the gtk package was taking an obscenely long time to
run checks. Upon inspection I found out it was not running tests as
parallel.
seconds.
The fix is obvious and will save time on future rebuilds.
Attachment: file
Toggle diff (12 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 3d4766713d..f0f6a0cd9a 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1195,6 +1195,7 @@ (define-public gtk
(string=? (%current-system) "aarch64-linux"))
"--no-suite=wayland_gles2_failing"
"--no-suite=wayland_gles_failing"))
+ #:parallel-tests? #t
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'generate-gdk-pixbuf-loaders-cache-file
Ludovic Courtès wrote 5 months ago
(name . The Man)(address . squishypinkelephant@gmail.com)(address . 73135@debbugs.gnu.org)
8734lbsxw4.fsf@gnu.org
Hi,

The Man <squishypinkelephant@gmail.com> skribis:

Toggle quote (17 lines)
> In the middle of testing a set of patches that caused a large number of
> rebuilds, I noticed the gtk package was taking an obscenely long time to
> run checks. Upon inspection I found out it was not running tests as
> parallel.
> For example, https://ci.guix.gnu.org/build/5623913/details took >3000!
> seconds.
> The fix is obvious and will save time on future rebuilds.
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index 3d4766713d..f0f6a0cd9a 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -1195,6 +1195,7 @@ (define-public gtk
> (string=? (%current-system) "aarch64-linux"))
> "--no-suite=wayland_gles2_failing"
> "--no-suite=wayland_gles_failing"))
> + #:parallel-tests? #t

I wonder why #:parallel-tests? defaults to #f in ‘meson-build-system’,
contrary to what other build systems do.

I think we should create a branch where we change it to #t, and merge it
once we’re done rebuilding all the packages and fixing any relevant
failure.

Would you like to give that a try?

Thanks,
Ludo’.
The Man wrote 5 months ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 73135@debbugs.gnu.org)
CAPfwWahp2=ULn8v22ZcW-m7nqzjT=R3Sspc+yWpjKucGOGyAcA@mail.gmail.com
Sounds like a good idea to me.

On Fri, Oct 4, 2024, 10:14 AM Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (34 lines)
> Hi,
>
> The Man <squishypinkelephant@gmail.com> skribis:
>
> > In the middle of testing a set of patches that caused a large number of
> > rebuilds, I noticed the gtk package was taking an obscenely long time to
> > run checks. Upon inspection I found out it was not running tests as
> > parallel.
> > For example, https://ci.guix.gnu.org/build/5623913/details took >3000!
> > seconds.
> > The fix is obvious and will save time on future rebuilds.
> > diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> > index 3d4766713d..f0f6a0cd9a 100644
> > --- a/gnu/packages/gtk.scm
> > +++ b/gnu/packages/gtk.scm
> > @@ -1195,6 +1195,7 @@ (define-public gtk
> > (string=? (%current-system)
> "aarch64-linux"))
> > "--no-suite=wayland_gles2_failing"
> > "--no-suite=wayland_gles_failing"))
> > + #:parallel-tests? #t
>
> I wonder why #:parallel-tests? defaults to #f in ‘meson-build-system’,
> contrary to what other build systems do.
>
> I think we should create a branch where we change it to #t, and merge it
> once we’re done rebuilding all the packages and fixing any relevant
> failure.
>
> Would you like to give that a try?
>
> Thanks,
> Ludo’.
>
Attachment: file
Maxim Cournoyer wrote 5 months ago
(name . The Man)(address . squishypinkelephant@gmail.com)
877camlo9l.fsf@gmail.com
Hi,

The Man <squishypinkelephant@gmail.com> writes:

Toggle quote (2 lines)
> Sounds like a good idea to me.


It hasn't started building anything yet (it's buildin guix at that
revision for now).

There's an RSS feed to keep track of it:

--
Thanks,
Maxim
Maxim Cournoyer wrote 5 months ago
(name . The Man)(address . squishypinkelephant@gmail.com)
87r08lopey.fsf@gmail.com
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (14 lines)
> Hi,
>
> The Man <squishypinkelephant@gmail.com> writes:
>
>> Sounds like a good idea to me.
>
> Implemented! See: https://ci.guix.gnu.org/jobset/meson-parallel-tests
>
> It hasn't started building anything yet (it's buildin guix at that
> revision for now).
>
> There's an RSS feed to keep track of it:
> https://ci.guix.gnu.org/events/rss/?specification=meson-parallel-tests

No issues whatsoever found:

Will prepare the branch merge request and close this one.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73135@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73135
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help