[PATCH gnome-team] gnu: glib: Update to 2.80.5.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 8 Sep 22:44 +0200
(address . guix-patches@gnu.org)
29a668e15846a06eeab999db38296bf45d0810a0.1725829268.git.liliana.prikler@gmail.com
* gnu/packages/glib.scm (glib): Update to 2.80.5.
[native-inputs]: Add python-packaging-bootstrap.
---
gnu/packages/glib.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index d6275ea63e..a0f1949f2f 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -73,6 +73,7 @@ (define-module (gnu packages glib)
#:use-module (gnu packages popt)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages web)
@@ -243,7 +244,7 @@ (define-public dbus-verbose
(define glib
(package
(name "glib")
- (version "2.78.0")
+ (version "2.80.5")
(source
(origin
(method url-fetch)
@@ -252,7 +253,7 @@ (define glib
name "/" (string-take version 4) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "0c3vagxl77wma85qinbj974jvw96n5bvch2m7hqcwxq8fa5spsj4"))
+ (base32 "0wb77rnfcfmz368dg7b8d4waif8qddidcdvyvszmns9wh3gaj8wz"))
(patches
(search-patches "glib-appinfo-watch.patch"
"glib-skip-failing-test.patch"))
@@ -483,6 +484,7 @@ (define glib
perl ;needed by GIO tests
pkg-config
python ;for 'patch-python-references
+ python-packaging-bootstrap
python-wrapper
tzdata-for-tests)) ;for tests/gdatetime.c
(inputs

base-commit: bf0af917fe6127d79251c7c0f3e3d33e1e8b1403
--
2.45.2
M
M
Maxim Cournoyer wrote on 11 Sep 05:46 +0200
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87cyla4zuj.fsf@gmail.com
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (3 lines)
> * gnu/packages/glib.scm (glib): Update to 2.80.5.
> [native-inputs]: Add python-packaging-bootstrap.

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
L
L
Liliana Marie Prikler wrote on 8 Sep 22:44 +0200
[PATCH gnome-team v2] gnu: glib: Update to 2.80.5.
(address . 73127@debbugs.gnu.org)
e109399d65161022198c923330aff313dc079977.1726247742.git.liliana.prikler@gmail.com
* gnu/packages/glib.scm (glib): Update to 2.80.5.
[#:phases]: Add ‘wrap-python’.
[inputs]: Add python-packaging-bootstrap.
---

v2 fixes builds in dependent packages, but may come at the cost of making
glib no longer cross-compilable (note: I don't know whether it can be
cross-built currently, and would like some pointers on how to achieve
this for a potential v3). qtbase still fails --- bug report incoming.

gnu/packages/glib.scm | 20 +++++++++++++++-----
1 file changed, 15 insertions(+), 5 deletions(-)

Toggle diff (68 lines)
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index d6275ea63e..72bcbdcc61 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -73,6 +73,7 @@ (define-module (gnu packages glib)
#:use-module (gnu packages popt)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages web)
@@ -243,7 +244,7 @@ (define-public dbus-verbose
(define glib
(package
(name "glib")
- (version "2.78.0")
+ (version "2.80.5")
(source
(origin
(method url-fetch)
@@ -252,7 +253,7 @@ (define glib
name "/" (string-take version 4) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "0c3vagxl77wma85qinbj974jvw96n5bvch2m7hqcwxq8fa5spsj4"))
+ (base32 "0wb77rnfcfmz368dg7b8d4waif8qddidcdvyvszmns9wh3gaj8wz"))
(patches
(search-patches "glib-appinfo-watch.patch"
"glib-skip-failing-test.patch"))
@@ -475,7 +476,12 @@ (define glib
(("^bindir=.*")
"")
(("=\\$\\{bindir\\}/")
- "=")))))))
+ "="))))
+ (add-after 'install 'wrap-python
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; gdbus-codegen imports packaging.version.
+ (wrap-program (search-input-file outputs "bin/gdbus-codegen")
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))))))))
(native-inputs
(list dbus
gettext-minimal
@@ -486,13 +492,17 @@ (define glib
python-wrapper
tzdata-for-tests)) ;for tests/gdatetime.c
(inputs
- (list ;; "python", "python-wrapper" and "bash-minimal"
+ (list
+ ;; "python", "python-wrapper" and "bash-minimal"
;; are for the 'patch-shebangs' phase, to make
;; sure the installed scripts end up with a correct shebang
;; when cross-compiling.
+ ;; "python-packaging-bootstrap" is needed by 'wrap-python' to
+ ;; ensure gdbus-codegen works as expected.
bash-minimal
python
- python-wrapper))
+ python-wrapper
+ python-packaging-bootstrap))
(propagated-inputs
(list libffi ; in the Requires.private field of gobject-2.0.pc
pcre2 ; in the Requires.private field of glib-2.0.pc

base-commit: bf0af917fe6127d79251c7c0f3e3d33e1e8b1403
--
2.45.2
M
M
Maxim Cournoyer wrote on 14 Sep 15:20 +0200
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
8734m2tlrc.fsf@gmail.com
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (10 lines)
> * gnu/packages/glib.scm (glib): Update to 2.80.5.
> [#:phases]: Add ‘wrap-python’.
> [inputs]: Add python-packaging-bootstrap.
> ---
>
> v2 fixes builds in dependent packages, but may come at the cost of making
> glib no longer cross-compilable (note: I don't know whether it can be
> cross-built currently, and would like some pointers on how to achieve
> this for a potential v3). qtbase still fails --- bug report incoming.

I wouldn't worry too much about making it non cross-compilable by adding
a Python input; I had a patch making it possible to cross-compile python
packages on old core-updates, I should revisit it.

The rest looks fine to me.

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 12 Nov 09:31 +0100
Re: bug#73127: [PATCH gnome-team] gnu: glib: Update to 2.80.5.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87msi46efw.fsf_-_@gmail.com
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (20 lines)
> Hi Liliana,
>
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
>> * gnu/packages/glib.scm (glib): Update to 2.80.5.
>> [#:phases]: Add ‘wrap-python’.
>> [inputs]: Add python-packaging-bootstrap.
>> ---
>>
>> v2 fixes builds in dependent packages, but may come at the cost of making
>> glib no longer cross-compilable (note: I don't know whether it can be
>> cross-built currently, and would like some pointers on how to achieve
>> this for a potential v3). qtbase still fails --- bug report incoming.
>
> I wouldn't worry too much about making it non cross-compilable by adding
> a Python input; I had a patch making it possible to cross-compile python
> packages on old core-updates, I should revisit it.
>
> The rest looks fine to me.

That's obsolete by glib 2.83.0 on my latest gnome-team submission (bug
#74306).

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73127@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73127
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch