(address . guix-patches@gnu.org)
* gnu/packages/glib.scm (glib): Update to 2.80.5.
[native-inputs]: Add python-packaging-bootstrap.
---
gnu/packages/glib.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
Toggle diff (42 lines)
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index d6275ea63e..a0f1949f2f 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -73,6 +73,7 @@ (define-module (gnu packages glib)
#:use-module (gnu packages popt)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages web)
@@ -243,7 +244,7 @@ (define-public dbus-verbose
(define glib
(package
(name "glib")
- (version "2.78.0")
+ (version "2.80.5")
(source
(origin
(method url-fetch)
@@ -252,7 +253,7 @@ (define glib
name "/" (string-take version 4) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "0c3vagxl77wma85qinbj974jvw96n5bvch2m7hqcwxq8fa5spsj4"))
+ (base32 "0wb77rnfcfmz368dg7b8d4waif8qddidcdvyvszmns9wh3gaj8wz"))
(patches
(search-patches "glib-appinfo-watch.patch"
"glib-skip-failing-test.patch"))
@@ -483,6 +484,7 @@ (define glib
perl ;needed by GIO tests
pkg-config
python ;for 'patch-python-references
+ python-packaging-bootstrap
python-wrapper
tzdata-for-tests)) ;for tests/gdatetime.c
(inputs
base-commit: bf0af917fe6127d79251c7c0f3e3d33e1e8b1403
--
2.45.2